Showing results for 
Search instead for 
Did you mean: 


Adept I

Ryzen 5 7600X crashes randomly and in games

Hello AMD Community! c:

I just finished building my second PC two days ago and I am having some issues I can't seem to fix.
As I am planning on getting a 4080 Super in a few weeks, I'm using the integrated graphics of my 7600X, which seems to be a problem.

When I start a more demanding game, such as Cyberpunk 2077, Baldurs Gate 3 or even Foundations (cute little game, can recommend it :P) , the game starts for half a second, then the screen turns green and it shuts down the PC. Or at least it crashes something, as the power LED is still on... These crashes also happen randomly during normal use when something more demanding is happening, such as opening multiple programs at once.
However, they do not occur when running cinebench 2024. Maybe this points towards an issue with the iGPU on my chip?

I have even tried undervolting the CPU to try and keep it in check but that did not help either. :c
Hopefully someone can help me here, I'm at a loss... thank you. c:

PC Specs:
- Motherboard: ASUS ProArt X670E Creator
- CPU: Ryzen 5 7600X (running at a maximum 86 celsius when stock, around 70 celsius when undervolted by 30)
- CPU Cooler: Noctua NH-D15
- RAM: 2x32GB G.Skill Flare X5 DDR5-6000, at EXPO II
- SSD: Crucial P3 Plus 4TB
- PSU: Seasonic Prime TX-1000 ATX 3.0

1 Solution

Hey c:

I got the RX7600 installed and now it's running everything perfectly. Apparently the iGPU just can't handle such large displays... Thanks for all your help! c:

View solution in original post

11 Replies
Big Boss

EllaMaxine, please stay out of the BIOS until this is figured and do a Clear CMOS. Post a screenshot of the Details tab of the Event Viewer for a couple of these errors. Like this:

+ System

- Provider

[ Name] Microsoft-Windows-Kernel-Power
[ Guid] {331c3b3a-2005-44c2-ac5e-77220c37d6b4}

EventID 41

Version 8

Level 1

Task 63

Opcode 0

Keywords 0x8000400000000002

- TimeCreated

[ SystemTime] 2024-01-10T14:38:17.8098234Z

EventRecordID 134566


- Execution

[ ProcessID] 4
[ ThreadID] 8

Channel System

Computer John-AMD-TR3

- Security

[ UserID] S-1-5-18

- EventData

BugcheckCode 10
BugcheckParameter1 0x0
BugcheckParameter2 0x0
BugcheckParameter3 0x0
BugcheckParameter4 0x0
SleepInProgress 0
PowerButtonTimestamp 0
BootAppStatus 0
Checkpoint 0
ConnectedStandbyInProgress false
SystemSleepTransitionsToOn 0
CsEntryScenarioInstanceId 0
BugcheckInfoFromEFI true
CheckpointStatus 0
CsEntryScenarioInstanceIdV2 0
LongPowerButtonPressDetected false

Thanks, John.

Screenshot 2024-01-14 105435.png

 hey, thanks for your response! Sorry for doing it with an image, I’ve had weird problems with this site and this is the only way I managed to make it work :c

I hope you can find something in the data, and again, thank you very much.

Have a great day! ☺️


EllaMaxine, no problem. I Right clicked your image and clicked Save as, then I could search the image with Google. It shows a BugcheckCode 0. I recently replied to a similar problem but cannot find it quickly. Please see if you can. Did you do a Clear CMOS? Please post a screenshot of Ryzen Master (RM) Advanced view running Cinebench and at Idle. Did you DL and install your AMD drivers from here?  if not, please do. Please look in C:\Windows\Minidump and see if there are any files, if so please attach a couple here. This forum is very iffy but using Paste Without Formatting helps me a lot. Thanks and enjoy, John.

Alright, I'm glad it worked! I really struggled with the site for half an hour before doing it from my iPhone XD

Anyways, thanks for responding! I have a attached four images, one in Idle state and three in various stages of a cinebench run. I installed the drivers from the official 7600X Support Page, and the link you provided actually only has specific drivers up to the 5000 series, so I think I chose the most official path possible in this case.
And yes, I have cleared the CMOS and even after that the crashes still occur. 
The C\Windows\Minidump Folder does not exist on my system.

I hope you can make something of this information.
Thank you once again! c:

IdleIdleAfter 6 minutes (and HWInfo)After 6 minutes (and HWInfo)Cinebench_Start.png







Also, stupid question but do you think it could be caused by my display? 
It's 4K, 120Hz and HDR 600. Maybe that's just too much for the little thing and it crashes :c


EllaMaxine, thanks. Great job. I will DL the images and get back to you. I do not think the monitor can cause this error, but is always a good idea to try a different one if you have one.

I am glad to help. It is part of my technical hobby right now. Thanks and enjoy, John.

Screenshot 2024-01-14 204447.png

I also got this error earlier when Baldurs Gate crashed, but it's not super helpful. Maybe you can use it c:

Also, using a 1440p Monitor fixes quite a few of my issues. Don't think I had a total PC crash since switching


EllaMaxine, great, perhaps you fixed it already. I hope you did report the issue, I expect they have gathered some error data from your system. Do you have halting or stutter issues?

So far Cinebench looks fine. Here is a shot of my RM. How did you get rid of the Temperature, Speed, Power, Current Voltage section? RM.pngPlease tell me what version of RM you have: About on front page. Thanks and enjoy, John.

What monitor were you running with crashes? How much VRAM do you have allocated? I assume you are using the builtin graphics.


Hey c:

I got the RX7600 installed and now it's running everything perfectly. Apparently the iGPU just can't handle such large displays... Thanks for all your help! c:

Thanks,  EllaMaxine. Great job! Enjoy, John.

Adept II

Ya ha comprobado si la fuente de alimentación proporciona la energía que necesita??? Puede ser que por lo que indicas desde el principio es que la fuente de alimentación es muy pequeña, de acuerdo a lo que describes deberías tener una fuente de alimentación de 700W aproximadamente, espero que puedas o hayas podido solucionar tu problema