Showing results for 
Search instead for 
Did you mean: 


Adept I

Ryzen 5 3600 won't boot into OS

My computer randomly a couple weeks ago and entered a boot loop. Upon powering on, I do have a successful POST and I can see my BIOS splash screen and enter the BIOS if I need to. It's only when I choose to boot Windows either from my SSD or attempt a fresh install from a USB stick, it restarts seconds after seeing the Windows logo.

Specs (all parts were bought and assembled about a month ago):

Asus Rog Strix B450-F - Mobo

AMD Ryzen 5 3600 - CPU

Asus ROG STRIX Radeon RX 5700XT - GPU

2 x 8GB GSkill Trident Z RGB 3000MhZ - RAM

Kingston A2000 1TB NVME - SSD

Gamdias Kratos M1-750W - PSU

Things I've tried so far:

  1. I recently purchased the GPU and SSD and installed them and my PC ran fine until last night. I have since swapped them out for my older Sapphire Pulse RX 570 8GB and a Kingston A400 240GB SSD to rule them out as the culprits.

  2. I have checked that I have the latest version of my BIOS installed (ver 3003).

  3. I have tried to unseat the RAM modules and try one at a time. I have also run memtest with no errors.

  4. I have removed and reinstalled my CMOS battery, also tried the jumper method.

  5. I have no peripherals installed (aside from RGB fans and light strips) other than my mouse, keyboard, and monitor.

  6. I have disabled core performance boost and precision boost overdrive.
  7. I have tried undervolting the CPU at a max 1.3V @ 3000MhZ (as suggested on some forums)
  8. I have tried both enabling and disabling DOCP.
  9. I have tried booting Linux off a USB and was able to see this error before the automatic restart (mce: Hardware Error)
  10. I have RMA'd my motherboard thinking that was the issue and ASUS sent me another motherboard and I still have the same issue.
  11. I have tried the PSU in another machine and it works perfectly fine.

I am not sure what my next steps should be. I am so used to being able to at least boot from a Windows install USB stick. I'm not an expert but could it be that the CPU is reaching the maximum temperature when trying to boot into an OS and that is what is causing the restart loop? (although temps show 40 degrees celsius in BIOS so really not sure)

I am about to start the RMA process with AMD but wanted to see if there was anything I may have missed or if anyone else had a similar issue that was resolved before I move forward with it.

Any help I can get is really appreciated. Thanks.

*EDIT: added screenshot of error screen from attemped Linux USB boot.

4 Replies

At this point you should replace the CPU.

I think so as well. Waiting for AMD to get back to me with the next phase of the RMA process. Thanks!

 start with one memory stick and see if windows will boot


Already tried. Thanks!