cancel
Showing results for 
Search instead for 
Did you mean: 

Processors

kryogenic
Journeyman III

Ryzen 3400G no hdmi output

Hello everyone, I'm desperate with my new build, bought new components this week to build my new PC but after connecting everything, the fans spin and the PC powers up but there's no output in the monitor.

Here's the full specs:

- MB: AsRock B450M Pro 4

- APU: Ryzen 5 3400G

- RAM: 2x8 DDR4 3200Mhz HyperX Fury 

- SSD: Kingston 140GB

- PSU: Seasonic M12II 520W EVO Edition(Fully Modular)

- Case: Cooler Master Q300L

All components were open first time and are new but I asked my MOBO vendor to update the BIOS so it supports my 3400G, I suspect that's the problem, when I got everything together the PCI-E Express slot was open, so maybe they updated it with a GPU and that messed up the MOBO configs, I'm just pretty much desperate and I really need a fix for this.

I already tried switching up RAM slots, they're both in A2 B2, I also tried to boot up without RAM no output still, tried to clear CMOS, idk if I did it right tho, I don't have a jumper connector so I did it with a screwdriver but maybe I did it wrong, no way to tell, I did a lot of research but havent reached a solution and yes, everything is connected where it should be connected.

Thanks in advance.

Tags (3)
2 Replies
miwo1604
Adept I

Re: Ryzen 3400G no hdmi output

Hi.

I have also the 3400G and Asrock B450M Pro4 and it works stable with G.Skill AEGIS F4-3000C16D-16GISB Memory 16GB DDR4 ( 2x8GB ) at 2933. 3000 is causing bluescreens. You will need newest catalyst from 16th July or it will be a massacre.

0 Likes
elstaci
MVP

Re: Ryzen 3400G no hdmi output

Make sure in BIOS that the iGPU is either enabled or on "Auto". 

Make sure you have the correct BIOS Version installed - P3.30 which is for all 3xxx Processors.

The latest BIOS for our Motherboard is P3.40. Need to first download and install the VGA All-In-One Driver set which includes the Chip Set. Just click on the Blue Link in the BIOS download page: ASRock > B450M Pro4 

0 Likes