Showing results for 
Search instead for 
Did you mean: 


Adept I

New Ryzen build freezing

Hello Everyone

I would very much like any support I can get in resolving this issue.

I just finished a brand new Ryzen build. It runs very well under load, but freezes randomly at idle. By "freezes" i mean it's like everything stops responding instantly, mouse doesn't move, no BSOD, no restart, no graphical artifacts.

The only way out is cold reboot via the case reset button.

CPU: 1800x

MB: ASRock x370 Taichi (with latest BIOS as of now - 4.40)

RAM G.Skill Flare-X 3200

GPU: Asus ROG RX580

PSU: Seasonic Prime Ultra Titanium 750W

System temps are very well within normal parameters. Cooling is provided by 3x140mm Noctua fans connected directly into the MB (So i can monitor their RPM and adjust PWM curve), CPU is cooled by an NH-U12S SE-AM4. System voltages from the PSU are rock-stable too - the Seasonic doesn't break a sweat.

This is a system which I intend to use for my daily work and stability is of utmost importance for me. I haven't overclocked anything - everything is at stock "Auto". I even down-stepped the RAM from the XMP-3200 profile to the safe JEDEC 2400Mhz.

Brand new Windows 10 x64 Pro installed on a Samsung 960 Evo 256GB SSD.

Latest OS updates applied.

Latest drivers for the Chipset, GPU and other peripherals applied.

Latest BIOS.

Latest firmware for the SSD drives.

Disabled PCI Express Link State Power Management (within Power Options).

Disabled Hard Disk Turnoff timeout (within Power Options).

Ran sfc and dism.

The funny thing is it rock-stable on all the stress tests i threw at it. 3DMark, CPU-Z, Aida64, Heaven Benchmark, and several hours of Memtest86. It's just this totally random hard lock screen freeze (or whatever you can name it) when I'm basically doing nothing - like writing in a text document or going around in the Control Panel, or even when i'm not at the computer at all. There's nothing in the Event Log (besides the improper shutdown message), no crash dumps either.

Sorry for the long post, but i'm very frustrated and disappointed. If I could just reproduce the issue every time that would be great and narrow-down the possible culprit, but alas...

1 Solution
Adept I

Please check my thread on the ASRock support forums for the solution:

View solution in original post

56 Replies

after doing this my computer has become sluggish and at times my pc lags so much that the computers reads my mouse movements after 5-10 seconds, it has not fixed the stuttering in games sadly, I think only option left now is to switch to intel 

Journeyman III

Hello I am having a similar problem but when I play games or try to do anything else it will freeze my screen and can’t move my stuff I have a gtx 1660 a ryzen 5 3400g mother board is a Tuf gaming B450P ram is Corsair vengeance 8GB at 2934 hrz win10 home 64Bit

i have done all the things I could think of to fix but hasn’t fixed tried to do a restore on the system but the pc froze on it 


hi,the problem in your case seems to be like RAM problem. update bios or run ram at 2133 mhz speed.


It’s not the ramm as it still freezes plus it might be the fact that it’s only at a bass of 2400 hrz

Sent from my iPhone

Adept I

I know this is a pretty old thread but I just want to share my experience with this exact same issue and how I fixed it.

I built a brand new system with a ryzen 5 2600, b450 mobo, rx 580. For the PSU I got a Seasonic M12ii Evo 520W. The system worked fine, or so I thought, until the exact same issue as described here started occuring like 2 days after building the PC. Completely random freezes while the PC is idle or under basic usage, like web browsing, watching videos etc. , forcing me to hard reset.

I updated my BIOS, tried hav0k's solution above to change the BIOS option to Typical Current Idle. Nothing. Tried messing around with other power options, both in windows and the BIOS. Still nothing. Then I tried to overclock the CPU and set it to run at a fixed clock and voltage. As this disables the c6/c7 states, the freezing stopped. But that wasn't a proper solution for me. I had no interest in overclocking my CPU at all. Soo..
I found this new "advanced" PSU tier list. I noticed that my Seasonic PSU was at the lowest tier, with a note: "doesn't meet c6/c7". At this point I was furious and completely sure that the PSU is at fault. So I got rid of it (sold it to some unlucky guy, let's just hope that he doesn't use Ryzen) and got myself a Cooler Master MWE Gold 650W. Reverted my BIOS settings and power options to default. Guess what? Absolutely ZERO freezes since then.
So if you have this issue, it's very much a possibility that your PSU doesn't properly support c6/c7 states, and you have to get a new one which does if you want to use your CPU's power saving capabilities.


Hello thanks for the reply but that was not my issue mine was was with falt with the bios not excepting the ryzen 5 3400 g on the board I was using and had to go with the X570 version of the board I had and is working properly now

Sent from my iPhone

Journeyman III

Currently having a similar problem with my new build. Slapped it all together, got excited, installed Windows 10 Pro 64bit and instantly went to update windows since it's a 2015 release version, so it needs lots of updates. But failed to even search for updates. Later on I just get constant freezes and have to press the reset button on the front panel of the computer. Only once got the error code of clock_watchdog_timeout. 

CPU: Ryzen 9 3900X
GPU: Gigabyte RTX 2080
RAM: Corsair Vengeance Pro 64GB
SSD: Samsung 1TB M.2

Updated the bios on the motherboard already and still no change.
I'm leaning towards the newly released cpu being faulty as I've seen other posts of people getting them replaced under warranty and fixing the problem.


Similar here, new build, ryzen 3700x, Gigabyte B550M DS3-H 16 GB Corsair Vengeance 3200 MHz, Evga gtx 960 4GB. Ive tried most suggestions here but no luck. Though the weird thing is that if i check the task-manager, when these random freezez occur, everything is "normal" no high cpu-usage etc, everything is updating in realtime, its just that my O/S SSD gets 100% active time, everything else seems normal. The freezes are random when i browse etc, never in stresstests like Prime95. So, im wondering if in my case my Adata SP550 120GB is the issue? I might try to reinstall on my Kingston 480GB SSD but hoping for some help from here first.  Cheers from Sweden and stay safe everyone!



man yes exact same issue with 5600x. 

was switching to AMD a bad idea..

is this cpu issue for sure?
should i ask for replacement?


Well, i think in my case the issue was actually my Adata SP550 SSD. I have removed it and now no more random freezes



I have been fighting with this issue for more then a month now.

My build 11.2021:

1. MB Gigabyte x570 (a lot of problems - I think the problem may be related to motherboard more then to CPU)

2. CPU/APU - Ryzen 5600G

3. PSU - Thermaltake Toughpower GF 750W 80 Plus Gold (I consider it decent, but on Linustechtips list it is considered for low-end systems)

My system was halting in 5-15 minutes after startup. I eliminated RAM, SSD , Windows (Linux Mint after week of flawless working fine also halted). I actually considered running Windows in Virtual Machine on Linux permantently. Since Linux also has this problem I skipped this way.

On my system I have one solution that works 100%, but it has vices. I strees one core with benchmark (CPU-Z or prime 95). Actually you can do it with any software and set affinity via Task Manager. In my case I can run rendering for multiple hours, and it works fine.

It is very annonying, but since my build was to replace previous workstation I cannot afford not running the machine, even virtually loaded.

Since the solution is more like work-around of the problem, I was looking for some real solution, and I think I found it on this thread.


- set in BIOS - Power Supply Idle Control - Typical idle

- disable in BIOS - Cool’n quiet mode

- I also set High Performance in Windows Power Options, but I don't think it changes much



I must admit that AMD CPU is very fast, but...

I was using only Intel systems for decades, and had no such problems ever. If I knew how bumpy road was ahead of setting a system on AMD I would never go for it.



Just built a new PC with a 5800x, Asus b550f gaming, 8gbx2 ram, 3060ti, 2xSSD 240GB (Adata for the OS that I have been using for the last 8 years). At first I kept my old windows 10 and noticed thise weird hickups/freezes where the pc kinda doesn't respond but I can't still move the mouse cursor or get the voice of a video I'm watching. I read avout disabeling C-state which didn't solve the problem. I upgraded to Win11 bit still the same issue. Reinstalled amd chipset drivers... nothing worked.

Now I'm resetting the OS for a fresh install and if it doesn't help I'll probably move the OS to the NVMe and see if it fixes it.

Journeyman III

More than 1 year later, I'd like to give a summary of my personal situation (small company with a few employees):

- Out of overall more than 10 machines equipped with Ryzen's, 90% are perfectly stable
  * Mostly Epyc servers, one threadripper, one Ryzen apu, one new Ryzen 3900 - all perfectly stable

- The one exception, my laptop, an HP envy 360, freezes on average once per day

- We are exclusively running Linux, Centos and Ubuntu on all machines, this includes the laptop

- Only in the very beginning did we see some spurious hangs on one of earlier desktop Ryzen builds, I had the processor RMA'd by AMD but it made no difference, still freezing but then -without any change that we know of- working stable.

- At some point updated freezing laptop's BIOS to latest version, but no change. Played with all options which are available in BIOS (not many) - no change

- The laptop is actually pretty crappy and aptly named after one of the 7 deadly sins (Seriously??)   I hope the next laptop, Lenovo on order, will be better, at least Lenovo lets you open the machine for updates without forcing you to practically destroy the case

Adept I

Got some more info for users that are still having this issue: There's reports online that the problem is fixed after increasing the minimum clock from 300 MHz to 600 MHz by manually disabling the 300 MHz state in the wattman .xml profile file, since Radeon settings doesn't let you do that.






<STATE ID="0" Enabled="False"

then load the edited .xml profile in wattman to apply the change.

Solution was found on reddit: 

Journeyman III

just want to say i have freeze problems, bsod every minutes with my new Ryzen setup and it all fixed with latest Windows 10 by downloading directly from Microsoft and install via uefi USB . ( I used to install old version of windows 10 and update it later)


My gear is

Ryzen 7 3700x

Gigabyte B450M s2H

Hyperx 32GB 3200

PSU 6000w



Hope it helps.


I still have freezing problems, I have recently installed a fresh copy of windows 10 directcly from microsoft webside and nothing. Can somebody tell me the best solution. Is it something related to the bios power setting or cpu clock??

Ryzen 2600X

HyperX Fury Black 16GB DDR4 2666MHz x2

Gigabyte B450M DS3H


Did you install into NVME ssd?