cancel
Showing results for 
Search instead for 
Did you mean: 

Processors

clicknext
Journeyman III

New PC with Ryzen 3600 won't POST

Jump to solution

My PC won't POST:

  • Power LED turns on

  • All fans turn

  • No signal goes to the monitor

Video of what happens : https://photos.app.goo.gl/gwE2QsTgx3T9tiPTA

My mobo came with the Ryzen 3000 Desktop Ready sticker.

I've tried removing all components except for:

  • CPU

  • GPU + 8 pin PCI-E power

  • 1 Stick of RAM

  • 24 Pin ATX power

  • 8 pin CPU power

  • CPU fan

  • Power button

  • Power LED

I've also tried putting the GPU directly in the PCI-E slot, just in case it was the GPU riser causing the problem.

But still I get nothing. My case doesn't have a built-in speaker for POST beeps AFAIK and there's no way I can get one immediately. Is there any way to debug this without it?

If anyone is able to give me some pointers, it would be greatly appreciated!

PCPartPicker Part List

0 Likes
1 Solution

Accepted Solutions
elstaci
MVP

Re: New PC with Ryzen 3600 won't POST

Jump to solution

Double check the BIOS/UEFI version on your motherboard. It needs BIOS/UEFI Version F40 to support all 3rd generation AMD Processors: B450 I AORUS PRO WIFI (rev. 1.0) | Motherboard - GIGABYTE U.S.A. 

Note: The original BIOS version for that particular Motherboard was F1.

Check either the box of the Motherboard or the Motherboard itself to locate the BIOS version it has installed.

If your Motherboard has F40 or later version installed than you have another problem. Make sure your Monitor cables are connected to the GPU card and not the Motherboard's video outputs.

View solution in original post

4 Replies
elstaci
MVP

Re: New PC with Ryzen 3600 won't POST

Jump to solution

Double check the BIOS/UEFI version on your motherboard. It needs BIOS/UEFI Version F40 to support all 3rd generation AMD Processors: B450 I AORUS PRO WIFI (rev. 1.0) | Motherboard - GIGABYTE U.S.A. 

Note: The original BIOS version for that particular Motherboard was F1.

Check either the box of the Motherboard or the Motherboard itself to locate the BIOS version it has installed.

If your Motherboard has F40 or later version installed than you have another problem. Make sure your Monitor cables are connected to the GPU card and not the Motherboard's video outputs.

View solution in original post

clicknext
Journeyman III

Re: New PC with Ryzen 3600 won't POST

Jump to solution

Thanks for the help elstaci! Your guess seemed like the most likely explanation to me.

The problem ended up being an error on my part, not seating the memory correctly.

After I got it to boot, I found that the motherboard came with BIOS version F50, which does support Ryzen 5 3600.

hardcoregames_
Big Boss

Re: New PC with Ryzen 3600 won't POST

Jump to solution

clicknext wrote:

Thanks for the help elstaci! Your guess seemed like the most likely explanation to me.

 

The problem ended up being an error on my part, not seating the memory correctly.

 

After I got it to boot, I found that the motherboard came with BIOS version F50, which does support Ryzen 5 3600.

Its is uncommon that RAM is not installed properly. Usually the sticks just pop in place.

My MSI X470 Gaming Plus has red LED by the RAM to show its OK

Some boards now offer a 2 digit code for BIOS errors. I have a bag of beepers so I can attach one of them to the speaker header and listen to the beep codes.

andreab67
Journeyman III

Re: New PC with Ryzen 3600 won't POST

Jump to solution

 Upgrade to latest BIOS - currently 3001 - inside teh BIOS there is a new compatibility option you need to turn on.

It fixed my issues - Ryzen 12 cores - 128G RAM - NVidia 1070 GPU PCI3 - Booting from RAID 0 - 2x 1TB Aurus PCIe4 NVMe

0 Likes