Showing results for 
Search instead for 
Did you mean: 


Adept I

My 2700x stays at 90 - 100% EDC

My 2700x at stock setting is staying boosted between 4.1 to 4.3 and is at 90% - 100% EDC at all times, even when idling. I don't have the option for Ryzen Balanced Mode in my power settings. And I've tried to set the minimum usage to 5% and still nothing changes. The only way I can get it to go down is by going into power save mode, but that locks all cores down to 2.2 ghz, which is unacceptable for gaming. Is there any other way to fix this? 


3 Replies

You sure there's nothing in the background using CPU resources?

Are you using Windows 10 1903?

Are you using the latest chipset drivers?

Are you using the latest BIOS for your motherboard?

I have nothing running in the background, performance tab on task manager shows me at around 5% usage, while ryzen master shows me at 90-100% usage in EDC. 

I'm currently using windows 1903, the latest chipset drivers and latest BIOS. 


So correction, I didn't have the latest chipset driver. After installing it and setting the Ryzen Balance power plan, I'm not sitting around 40-50% EDC usage. Thanks man!