Showing results for 
Search instead for 
Did you mean: 


Adept I

Issue with DDR5 Speeds - EXPO does not work nore does any RAM Speed above JEDEC work


I recently bought myself a Ryzen 7700 X processor with a new motherboard and DDR5 6000 RAM.

I cannot reach any DDR5 Speeds above JEDEC 4800 40-40-40-82 and faced a lot strange errors. I know that 6000 is an OC and there is no guarantee to reach this speed. However, I have tested 5600 and 5200 profiles. This always leads to the errors described below.

Since I have this processor I had tested two motherboard from different vendorts + 2 different DDR5 Kits.

I also changed the power supply and the sata cables.  + removed all not  required storage devices, GPU and so on.

The Motherboards are:

- Gigabyte X670 AORUS ELITE AX

- ASUS ROG STRIX B650E - E Gaming Wifi


KF560C36BBEK2-32 from Kingston

- F5-6000J3636F16GX2-TZ5NR from G-Skill

The system with the ASUS board works stable with RAM JEDEC and I have not yet encountered any instability yet.

But this is only the case since the latest BIOS version. With the delivered version, I could not even access the UEFI. When I try to increas the RAM Speed on this Board it will always be stuck when the "Pre memory System Agent initialization is started" and the RED CPU LED lights up. After a few seconds the systems reboots and everything start again.

In contrast, the Gigabyte board was so unstable that UEFI crashed when saving the setting and I was unable to flash the bios to the latest version. The update process froze and the board now no longer works.

The only common denominator in my system is the CPU. I have a suspicion that it is damaged.
Does anyone have any ideas what else I could try?

Thanks in advance!



34 Replies
Big Boss

Floppes, are you saying you are running two different memories?!? You should start by getting rid of one vendor's memory and trying only one. I have an older Gigabyte board and it has a Qflash button on the back that can be used to flash without a processor. Please read your manual and try that if you have it. Thanks and enjoy, John.

No I am not using two different kits at the same time. I have used both kits on both boards.

I sent the Gigabyte board back today to the vendor. I was not able to do a Q-Flash. 

Thanks, Floppes. When you are running again, please post screenshots of Ryzen Master (RM) both Basic and Advanced mode running Cinebench R23. Please start with default setting before trying OCing. Post Event Log details for any errors and post the parts you have not reported, like cooler, Power supply,memory size etc. Thanks and enjoy, John.


the system configuration is as follows:

- Ryzen 7 7700 X

- Cooler: DARK ROCK 4 be quiet

- RAM: KF560C36BBEK2-32 from Kingston

- Board: ASUS ROG STRIX B650E - E Gaming Wifi

- Power Supply Corsair HX Platinum 850 Watt

- 3x M.2 drives from Kingston and Crucial  (1x PCIE 4.0)

- Samsung SATA SSD 500GB

- AMD Radeon 6800XT GPU

The Ryzen Master Info you asked for:

Screenshot 2023-01-03 132059.pngScreenshot 2023-01-03 132618.pngScreenshot 2023-01-03 133140.png


Moreover I had to clean reinstall Windows 11 yesterday, since I had a lot of issues after the motherboard change.

Now I have a new issue, which is loosing all USB connectivity of my mouse and so on. The screen goes black and stays there for >1 minute. Sound in the background continous. After that I get the message that my graphics driver stopped working from the radeon app.

In the eventlog i can find those errors:

Screenshot 2023-01-03 133355.pngScreenshot 2023-01-03 133316.png

Screenshot 2023-01-03 152211.png

it's really frustrating as I've been dealing with an unstable system for weeks now and other errors keep popping up

Why is your temperature at 95C ? Did you take that screenshot while it was under heavy load?

I know 7000-series can reach 95C, but when you have only 8-cores, a fairly capable air-cooler and are not running a stress test... How are you idle temps? Have you tried curve optimizer.. set negative 5 or negative 10, might be able to go even lower to reduce temp and increase performance.

Does this problem exist with other games or test software, or just WoW?

MADZyren, Floppes's temperature is at 95C because CB R23 is running and all cores are running over 5GHz. Enjoy, John.

Thanks, Floppes. There is a problem shown here where Basic view on one side says you are running PBO and the other Default. The Advanced mode indicates you are running PBO. Did you set PBO in the BIOS? Please do a Clear CMOS then set default settings. Do not OC anything. Then run your test (all default) and post the screenshots. Did you get all your AMD drivers from here? Enjoy, John.


no activated PBO for that run in the Bios, because my score was even lower without it. Compared to test results from outlets I am far below. I know that my RAM is running at JEDEC only, but is that impacting so much?

I hit the temperature at full load, but when I play a game or anything with a load like that I hit about 75°C. I do not think that I have a cooling issue in that regard.

Moreover I noticed microlags in games like CS:GO and World of Warcraft, which really do not have high CPU load. I changed the internet provider using my mobile phone to exclude any network or network controller (Cabel and Wi-Fi) related issues.

Kind regards


Adept I


did you solve the problem already?

I also have an Asus B650E Strix board  with a 7700X and already tested two 2x16 DDR5 6000 kits. It won't boot as long EXPO is activated. Everything above 5000mhz doesn't work. 

I wonder if this is CPU or MoBo related.


Lastest Bios is installed.

Philey, If you would like some help, please open a new thread and post the data I requested of Floppes. Thanks and enjoy, John.

No solution yet. My board does not even run with 5000.

Adept I

same issue here, 

hopefully we can get the answer

babamioseng, I doubt you have the same issue. Please open a new thread and post the information I have requested of Floppes. Thanks and enjoy, John.


I have the Strix E-E too. It has built-in optimized memory profiles for different kits. What happens if you use them?

"But this is only the case since the latest BIOS version. With the delivered version, I could not even access the UEFI. When I try to increas the RAM Speed on this Board it will always be stuck when the "Pre memory System Agent initialization is started" and the RED CPU LED lights up. After a few seconds the systems reboots and everything start again."

I am still using an early BIOS version. Never flashed. My BIOS version is 0421. I have heard bad things about new BIOSes with AM5, so still waiting for a mature BIOS to update to.

AM5 takes a long time to boot in the beginning, before it starts working. What if you just enable XMP/DOCP and let the machine do its thing. Wait at least 10 minutes before doing anything.

Journeyman III

I have the same problem. My memory is G.Skill Flare x5 DDR5-5600 32GBx4 CL36-36-36-89 1.25v F5-5600J3636D32Gx2-FX5 and ROG Srix X670E-E latest BIOS.   I enabled the easy EXPO II with defaults and it failed into Safe Bios.  I enable EXPO II in the Advanced AI Tweaker, and anything set between 5600MHZ - 5000MHZ it will fail into Safe Bios.   4800MHZ, 4600MHZ and 4400MHZ worked, but were unstable.  I ended on 4200MHZ, it's going great.   Just give me my 5600MHZ plz.

Adept I

You have to enable Expo, get in the Dram timings and on Refresh Interval set it to AUTO - by typing Auto and NOT 23K something. 

These are the settings that worked on my Gaming Rig:

My computer was running on 4800Mhz, unacceptable, so I did the EXPO and everything went haywire with BSOD, Crash etc.

After much tweaking, I fixed my new gaming setup in BIOS with an Enabled EXPO setting and manually checking the parameters in detail. 

ASUS 1222 version

AMD Expo on G Skill International Ent - Available as download PDF on manufacturer's website
JEDEC Mem Speed 1
ENABLE EXPO on EZMode set to 6000MHz
Go to Advance F7
Verify Correct Timings: (Find yours if its available either wise AUTO)Screenshot 2023-03-08 004638.png
Tcl 36
Trcd 36
Trp 36
Tras 96
Trc 132
Twr 90
Trfc1 884
Trfc2 480
Trfcsb 390
VDD 1.35
VDDQ 1.35
PMIC Sync All
Mem VDD 1.35
Mem VDDQ 1.35
VPP 1.8
VDDP 1.050

and most Importantly!
Refresh Interval set to AUTO

I hope this helps GAME ON!


Adept I

Yet again, AMD strikes.


MSI Pro-XX670-P running AM5 7600x with G.Skill Trident Z5 NEO RGB Series F5-6000J3636F16GX2-TZ5NR DDR5-6000 everything works.

Upgraded to AM5 7900X3D.  XMP profiles no longer are selectable.  DDR5-6000 timings must be manually entered, random system crashes, hangups and intermittent issues.  Reduce memory timings below 5000 (I'm using DDR5-4800) everything works again.

Tried multiple BIOS from MSI, swapped CPUs (7600x and 7900X3D).  Anything above DDR5-5000 with the X3D CPU, was a no bueno.

Official MSI response:

"Hello the QVL list on this specific board (Pro X670-P) does list support for this set of memory (G.Skill Trident Z5 NEO RGB Series F5-6000J3636F16GX2-TZ5NR ) with your previous CPU (AMD AM5 7600x) as being compatible out of the box but it is possible that a BIOS release some time down the road will include support for your current CPU the 7900X3D and your current memory modules to be fully supported with each other under the XMP profiling as it is technically considered a (OC) however we have only released one BIOS for this board at this current time as the one we have released is only a BETA."

MSI Response: Pro-X670-P BIOS 7D67v174(Beta version) XMP and X3D CPU Conflicts? | MSI Global English...


are they both Samsung kits?

Gskill Flare X 5 2x16GB EXPO 6000 CAS36 (Samsung) kit I have has issues on both a Gigabyte B650M Aorus Elite AX with both a 7950x and a 7600 .. and on an ASRock B650E Steel Legend with the 7950x. Booting with EXPO enabled is hit and miss. Once I can finally get it to boot into Windows with EXPO enabled, it's as stable as a rock though

It took many tries initially with fiddling with voltages .. switching the power supply off and THEN try booting up .. I figured out that I would need to make any changes I wanted , except enabling EXPO .. save & exit .. and reboot into BIOS and then enable EXPO and that was my best bet to actually get into Windows.

Rebooting from Windows was challenging.. turning off the PC and then turning on instead of restarting was again , the better bet

Replacing the fickle Samsung kit with 2 different Hynix kits (2x16GB XMP 6000 CAS30, 2x32GB XMP 6400 CAS32) on both systems and now not a single issue

ThreeDee PC specs

The CPU was broken. Got a new one and now it works fine.


Hi Floppes, 

I was about to reply to your thread as I have the same setup (ASUS ROG Strix B650E-E) except I use a G.Skill CL30 2x16 kit and I can run it at 6000 using EXPO I or EXPO II in the bios, no issues.  

The only issue I have had is after a bios update. After the update has completed it will occasionally hang during POST with a C5 or CS code being displayed. I found out that by removing the 2nd DIM  and reboot then the system will then boot up fine. I then re-install the 2nd DIM and power back on and it boots fine. It's a pain when it happens though. 

Anyway, glad to hear it's working now, not so good it was a bad CPU though.


Funny, got my new CPU back from RMA this friday and got no problems anymore aswell



What's funnier is I just  got my brand new replacement cpu from AMD and it still doesnt work lol. I hate this. its  been 6 months my pc is  just dead. 

Same... Just got a replacement 7600x and still gives errors in prime95... The shop tested my mobo and ram with another cpu with which they didn't get any errors. I don't know if it was 7600x too or another 7xxx series cpu, so I don't know if it's that all the 7600x's are broken or what, but what I do know is that this will be my last AMD setup in a long while.

Adept I

In watching the utuber, Ancient Gameplays, at 18:45 in his video, (622) DDR5 4800 vs 5200 vs 5600 vs 6000MHz | Ryzen 7000 Benchmarks - YouTube, he mentioned the same issue I was having.

My system is now fixed, since I changed out my DDR memory from Samsung to Hynix chips.  The G.Skill Trident Z5 NEO RGB memory uses Samsung and swapping to  Flare X5 (with Hynix chips) absolutely solved my issue.

It does circle the drain in that X3D chips, and AMD 7 series CPUs, are very touchy in terms of memory and speeds.  They're very twitchy and it seems variances in manufacturing tolerances are large enough that the probability of getting components that exceed these tolerances, when you add all the tolerances together, the summation is not that unlikely.  Not too common, but, not highly unlikely either.

Journeyman III

Unfortunately I'm facing the same issue here.


My combination is ASUS X670 P CSM + Ryzen 7950x + Gskill 7200 memory (F5-7200J3445G16GX2-TZ5RK).

RAM is listed in Mainboard supported memories.

Any confiruration above 4800 does not finish post in less than 30min and I have not waited longer. Asus support can not say how long post should take.

Asus support does not know under what bios version it was tested. Asus support has no information what BIOS setup was used (voltages, frequencies...) during testing. My conclusion from discussion with ASUS  support was that "maybe someone in taiwan managed to finish POST on 4800". Which is true, but for me unbelievable that someone can put it on compatibility list based on this information only.

Based on tips from various forums I managed to finish post with (with significantly increased voltages and memory temperatures around 60-70 degrees), but memtest is failing latest after 15min. Windows managed to boot but crash frequently, linux (debian) does not managed to boot. The only way to wakeup computer from sleep is reset of CMOS.

I have extensively searched on internet and discussed with people around me I found nobody who managed to get memory working (minimal 24h memtest run without error) on frequency above 4800.

I'm personally very surprised that this experimental platform was released to public.

For me the argument that anything above 4800 is overclocking is not valid, it is the same as if AMD would state that 100MHz is base clock for Ryzen 7950x and anything above is overclocking. AMD says 4.5 to 5.85 and it works exactly as said/written. ASUS writes down 7200, but works only 4800.

I'm very dissapointed with my purchase and with my knowledge it is not possible to identify if AM5 + x670 is experimental, or ASUS design/bios is experimental, or Gskill memories are experimental. Returning complete purchase. Sorry AMD.

Warning for others: If you are not sufficiently knowledgeable and skilled stay with 4800 memories, that are unfortunately not available in my country and have extremely bad timings on levels of ancient ddr3.


 = This is my opinion and experience throughout the decades = 

You paired one of the lowest end boards that ASUS has to offer with the highest end that AMD AM5 CPU's has in its lineup.

This is an unbalanced build.

Even my older RoG Strix B450 E gaming had better power delivery than the board you have not mentioning the rest of the components.

I have the 7950X with a ASUS RoG Strix X670E-A and memory is rock solid with EXPO enabled and in this forum you'll see several users also with rock solid builds.

The Englishman

You are right, but situation with mainboards is very problematic, let me explain:

I need 1x PCIe x16 for GPU + 1x PCIe x4 for storage + 1x PCIe x4 for networking. On top of this 2x M2 slot PCIe 4.0 is fully sufficient (one for windows, one for Debian).

I was looking at ROG STRIX X670E-F GAMING WIFI (this is on the edge with PCIe ports as the cards are mechanically x16 versions so there might be problem with physical dimensions) and none of compatible memories was available (if we exclude the slowest 4800/48 memories) and the listed Gskill 7200 is not compatible with the board (according to ASUS).

If you can recommend any combination of mainboard + RAM that works and has 3 PCIe ports (x16 physically, x16, x4, x4 electrically) it would be great and I will be very thankful. My considerations for RAM have been (in decreasing priority) 7800/36 (not on compatibility list), 7200/34 (on compatibility list, bought), 7600/36, 8000/38.

I'm not really builder, I build cca 1xPC per year (starting in ancient times of 386) and this is first time in my life that I had freeze during POST. I do not want any overclocking (e.g. running 7200 memory on 8000), I want to run only frequencies as written on memory sticks (7200/34 in this case). In my previous Intel (sorry for competition brand usage) build I selected in bios my memory and it runs on 1st attempt, post in cca 5seconds and no problems, all tests have run without errors. This time I decided to switch to AMD because I have observed problems with big/small cores scheduler causing problems/slowdowns. Was thinking that same cores=less problems, unfortunately I was wrong.

Photo shows one of the rare cases where 7200 managed to get thru POST, but memtest was showing lot of errors.20231021_135240.jpg

Tests used are Memtest, Prime, Furmark and Unigine. As Memtest was failing (when it maneged to complete POST) after few minutes I did not continue with other test.

Edit: for clarification, during all testing the storage and networking cards have been NOT present, only GPU was present to get picture on monitor (=only one PCI3 x16 occupied)

Edit2: In fact I have just now run thru all available mainboards and did not manage to find other one with x16/x4/x4 configuration, asrock has usually x16/x4/x1, MSI has usually x8/x8/x4, Gigabite uses x16/x4/x1 combination.

Journeyman III

Sorry adding rest of components:

CPU cooler: Noctua NH-D15

M2 drives: 2x Kingston KC3000 NVMe 1TB + AXAGON CLR-M2XL - only one M2 drive was installed during testing

PSU: Seasonic Focus GX 850 Gold


CASE: Fractal Design Define XL R2 (Edit: all fans replaced with Arctic P14)

MONITORS: 2x LG 24MB37PM + LG OLED55C22 (this is actually a TV, but for me no problem) - during testing only one LG 24MB37PM was connected



Get the X670E PRO ART Creator

2x 16 reinforced PCI 16x slot (16X+16X+4X)

2x Ethernet, so you can let go the extra card for networking and one being 10G.

Plenty of VRM power and WiFi for that emergency or bluetooth connections.

You will get better memory support as well.

Be sure to upgrade that PSU, a 7900XTX plus an unrestrained 7950X can put some pressure on that 850Watt.

Good Luck





The Englishman
Journeyman III

Upgrading PSU is no problem - 1000 is OK? If needed more different type is needed as focus GX tops on 1000W.

With the board there are several problems


- Ports are x16/x0/x0 or x8/x8/x2 (basically allowing only GPU), not clear from manual if x16/x0/x2 will be accepted by the board, but still this does not change anything as again only GPU can be installed

- Network card can not be omitted, because I use 4 port SFP+ card, that has one connection to remote storage and one connection to network (totaling 4 fibres needed and 2 SFP+ ports) (reason 1) and also I have tested several metalic 10G cards and none can reach more than 2G continuous (tested on cat 8.1 2000 MHz cable) (reason 2)

- No slot for local storage card

Edit: Not to mention size of 2000MHz cables (metalic 1x2000MHz cable = 40G, optical cable of the same diameter 192 fibres = 960G)


The board you are looking for is neither the one you have nor the one I recommended.

You are looking at workstation and/or server level requirements and for that, a consumer grade board+cpu won't do you any good. You need extra lanes that only a a Threadripper HEDT can provide.
...Or change the way you network with the computer.

I also have to ask, what is the point to have a 7900XTX at 16X if the board you have doesn't even have support for PCI-e 5.0? You are using a 16X PCI4.0 that is the same bandwidth as the 8X PCI5.0 for the 7900XTX while running it on the ProArt.

Another thing, you are requesting more PCI-E lanes than the CPU can provide, so you will get bottlenecked eventually. From the 3x M.2 slot, the X670P gets, only the first two comes from the CPU, so either one get disabled or share, haven't looked into the manual to be honest.

Ryzen 7950 will offer you 24lanes, 16 for GPU and 8 for two NVME plus 4 to the chipset.


If you populate 16+4+4 (every PCI-e from CPU is exhausted) Remains 4 lanes for the M.2_3 slot that get them from the chipset, common between every board.

If you populate every PCI-e slot plus the two first M.2 slots that come from CPU, it needs to share the lanes somehow.

From the 24 lanes the CPU offers you cannot get 24+8, the CPU can't do it. It needs to share the lanes, if that happens, then you will get PCI4.0 at 1X which is enough speed for one link on the 10G card to work... unless... the card doesn't like it because you are not feeding it with 4x lanes. Again, you have to check with vendor and the board manual carefully.

Either way, I think you may be trying to do high level work with low level budget, hence the Prime Board.

I'm sorry..

The Englishman
Journeyman III

Will try to respond to all points:

1. GPU currently all GPUs (including 7900 XTX) are 4.0, this means that speed in 5.0 x16 slot is 4.0 x16, speed in 5.0 x8 slot is NOT 5.0 x8, but 4.0 x8.

2. PCIe lanes explained (sorry your description of lanes distribution is not accurate): one of chipset main tasks is to multiply PCIe lanes (it makes sense, as it would be waste of performance if CPU should serve some "old" 4.0 x4 or 3.0 x4 lanes), of course this creates bottle neck and I'm fully aware of this as chipset has only PCIe 4.0 x4 lines to CPU connection, anything above will need to wait for free capacity (details will be explained later). In explanation below I use some simplification as there are few devils hidden in timing between 3.0 and 4.0, behavior of chipset in case of PCIe to PCIe communication, overheads etc... but these are omitted as I do not want to write novel

2.A. PCIe lanes (first take the ASUS PRIME): PCIe 4.0 x16 is connected to CPU (this is GPU, so GPU has dedicated lanes only for GPU), then 2x PCIe 4.0 x4 is from chipset, but as cards (storage and network) installed are 3.0 x8 they will operate in 3.0 x4 mode which means they can both run full speed and does not saturate x670-cpu lanes. M2 slots are connected as follows M2.1 operates at 5.0 x4 from CPU (dedicated lines), M2.2 operates at 4.0 x4 from CPU (dedidated lines) as SSDs are 4.0 x4 they will be fine and as they have dedicated lines there will be no bottle neck created. Total CPU will have 28 (16 for GPU + 8 for x670 + 2x4 for SSDs) lines used and this is exactly CPU number of lines.

2.B. PCIe lanes (now ProArt X670E-CREATOR WIFI the two PCIe 5.0 slots have 16 lanes (together) from CPU, for this reason if 2nd slot is empty first can get x16, but if 2nd slot is occupied both get x8, this means that GPU will run on 4.0 x8 (crippled mode), network card will run on 3.0 x8 (great) storage will run on 3.0 x2 from chipset (very bad). For M2 slots situation is very similar to PRIME board so no separate explanation here. As you can see the installation in ProArt X670E-CREATOR WIFI will harm performance of GPU and storage (or GPU and network). As the slowest activities are copy between storages (local storage, remote storage, local ssd) it is very important for me to have NOT crippled bandwidth for these activities

I do not want to say that Creator is bad board, definitely it is great board, "only" not suitable for my purpose.

As you can see from description distribution on CPU lines of PRIME board is ideal for my purpose and number of 7950x lanes is fully sufficient, unfortunately there is problem with memory in this board which hopefully ASUS can solve in few months as in current state it is purely experimental and not working at all. I consider the only option in current situation to wait until ASUS will manage to develop working bios and then I will try my luck again

For AM5 platform the cost of board is no decision factor for me, but the 'distribution' of PCIe lines definitely is decision factor. As of now I'm not aware of other board that has support for my configuration.

Considering threadripper the most significant problem with this setup is very bad single thread performance. Here mostly windows applications still have not learned about multiprocessing and this will significantly reduce performance in many applications I'm using. For this reason CPU decision process was following: I have selected 'top 10' single core performance CPUs and from these CPUs have selected the one with best multi core performance, and 7950x was the winner.


As for the first, you are absolutely right.

I was not aware of the PCI gen of the 7900XTX, didn't even bothered to look and took it for granted. So yes, you are stranded to 8X 4.0 in most cases.

For the Second.

I'm quite right, you are just explaining it in a different manner.

the CPU will give to the chipset 4x lanes then the chipset will multiply BUT! It will share the bandwidth, you cannot make "magic" out of what the CPU can provide.

Short version

"Promontory 21 offers a total of 16 PCI-Express lanes. Four of these are used to connect to the CPU, over a Gen 4 interface, as mentioned before. In the X670/X670E daisy-chained configuration the secondary chipset connects to the primary chipset, it has no direct link to the processor."

So what happens is:
All the multiplied lanes do exist and can be assigned but they have to rely on the bandwidth that the CPU gives on the existing 4 and then it needs to share even more for the daisy chained chipset.

As for the rest, I stated it very clear, I haven't read the board manual, I do not know the lane assignment other than the picture on the website. Hence my example with M.2 slots.

You seem very knowledgeable about what you are choosing, almost 100% theoretical, but in my opinion, (the first one I gave) You seem to lack some experience and trying to build a system purely out of specs ignoring the fact the Prime is a VERY LOW END board not suitable for the 7950X, not only the VRM's are weak but for other several reasons. I know they list the CPU on the compatible/supported section but guess what, the ram is on the compatible/supported section too right? Yet, fails to work.

The Englishman
Journeyman III

Finally I decided to return complete computer.

Have spend many night at internet, but the mentioned Asus Prime x670 P CSM is the only board in the world (currently) having x16/x4/x4 PCIe bus.

Based on this I have ordered again with different memory kit (KF560C32RWK2-64) this time. It does not even finished POST and I can not access anything.

The board has connected only CPU+Cooler, RAM, power led, power button, 24pin power, 8 pin power, 4 pin power, cpu fan.

Everything else was removed. I believe there is nothing more I can strip off from the setup.  On outside ports only display port, keyboard and mouse is connected.

I fully understand comments from johnnyenglish that this is low end board, but I only wanted it to finish post, this is not high end computing.