Showing results for 
Search instead for 
Did you mean: 


Journeyman III

Gigabyte X570 Aorus Pro / AMD Ryzen 7 3700X issues (CPU_LED)

Hey everyone,

My request for help

In the past couple of days I have gotten myself a brand new Gigabyte X570 Aorus Pro motherboard and an AMD Ryzen 7 3700X CPU.

At the first boot I didn't get anything to display, until I remembered that I read somewhere that AMD Ryzen required a dedicated GPU. So I decided to mount the motherboard into my case as well as the GPU (MSI GeFore GTX 1080 Ti Gaming X Trio).

The second time the system did boot into the Windows I had already pre-installed on the M.2 SSD (Kingston A2000). Due to multi-boot questions I got on the boot, I decided to perform a clean install of Windows. So I prepared a stick, plugged it in and initiated the Windows 10 installation. The setup was still transfering files and data so I decided to get back to work.

About ~15 minutes later I decided to check on the installation and I noticed the system was shut down.

After attempting to boot the system, I didn't see any display output or anything. After checking the motherboard I noticed there was a CPU_LED burning contantly. No additional LED switches were made during the boot.

A picture I took during the succesful boot, does not show any status LED's burning, so it was succesful at one point.

Relevant software and hardware

Motherboard: Gigabyte X570 Aorus Pro

CPU: AMD Ryzen 7 3700X

CPU cooler: Stock (AMD Wraith Prism)

GPU: MSI GeForce GTX 1080 Ti Gaming X Trio

PSU: Focus Plus 650 Gold

Memory: Kingston HyperX Fury HX421C14FBK2/16 (Yes it is odd, but I tried to spread the costs of the system upgrade, the motherboard and CPU should be compatible with it)

SSD: 1TB M.2 Kingston A2000

What I have tried thus far

1. Reconnecting the power supply (have you tried turning it off and on again?)

2. Relocated the memory sticks

2.1 Slot 1

2.2 Slot 2

2.3 Slot 1 and 3

2.4 Slot 2 and 4

3. Reconnected all power supplies to the motherboard

4. CPU-cable attached to CPU_OPT instead of CPU_FAN

I'm running out of ideas and I have no idea what to do, or what the problem could be.

I'm really hoping some of you have a brilliant idea.

Kind Regards,


1 Reply
Journeyman III

Was there any solution to this issue as currently having these exact issues with same motherboard and cpu any help to solution would be much appreciated.