cancel
Showing results for 
Search instead for 
Did you mean: 

Processors

Feren
Journeyman III

Freezing upon starting my laptop with AMD Ryzen 5900HX

Good morning,

I have recently encountered an issue with my Asus Rog Strix 15 laptop, equipped with an AMD Ryzen 5900HX processor and an RTX 3070 graphics card (model g513qr). For the past few days, I've been experiencing freezes upon booting up the laptop, specifically when the Asus logo appears. At this point, I am only able to access the BIOS, unable to perform any other actions.

My laptop is currently running BIOS version 331, and despite my attempts to resolve the issue through resets, formatting, RAM and SSD changes, and even attempting to install BIOS version 330, the problem persists, resulting in frequent freezes.

It's crucial to note that the warranty for my laptop expired in August, limiting the available options for repair. Given that this laptop was a substantial $2000 investment in 2021, I am deeply concerned that it may become an expensive paperweight.

As a burgeoning content creator, the situation becomes even more critical as this laptop is essential for my work. In my quest for solutions, I turn to the community in the hope of gaining guidance on possible fixes or suggestions to address this problem. I do not wish to assume that both Asus and AMD have betrayed my trust, but the growing frustration leads me to consider this possibility. If confirmed, I will not hesitate to share my experience to dissuade other users from considering this brand in the future.

I appreciate any advice or assistance you can provide on this matter. I am genuinely worn out by this situation and hope to find a solution to once again enjoy my investment.

Thank you.

PD: I tried to disable the TPM. Since I couldn't do it directly on the laptop, I used a new SSD in another laptop, installed Windows, and disabled the TPM through System32. I then placed that SSD back into the ROG Strix G513, and it worked; the laptop booted up, and I reached the desktop. However, this success was short-lived, as it froze again after just 5 minutes. Therefore, the solution did not prove effective. Furthermore, after turning it off and on again, it continued freezing at the Asus logo.

I'm just tired... and disappointed.

0 Likes
0 Replies