Showing results for 
Search instead for 
Did you mean: 


Adept I

Enabling UEFI Mode causes 1 long and 2 short beeps from the motherboard

Hi. When i change bios from CSM to UEFI i can't load the Windows, I hear 1 long beep 2 short and then nothing, just black screen and after a lot of force restarts i can load my system.
The same problem on Win10 and Win11, no differences, i just set CSM to UEFI and this started, if i set it back everything again works perfectly.
I don't think that i have any problems with my GPU cause my PC works since 2020 march about 16-17 hours everyday and i have no problems with render or playing any games.
Also i've been reading a lot of threads about this problem and other people don't have GOP Driver information in their bios settings, but after setting CSM to UEFI i restart my PC open the BIOS and i see that bios sees my GPU.

Below the list of steps that i did already.

PC Specs:
Ryzen 5 2600,
MSI B450M Pro VDH Max,
GTX 1650 super.
Disks types are GUID (Which is GPT as i know),

I set all my Bios settings to default.
I tried the other GPU.
I cleaned my PCI-E connector on GPU with eraser.
I took off the CMOS battery and set everything on default with it.
I updated my bios to the newest one, tried everything there and get back again to my bios version.
Tried to turn on without connecting HDMI cable.
Full tested my RAM with Memtest86.
Full stress test with OCCT.
Even Prime95 for 6 hours.

I wish you all the best and Merry Christmas!
I hope this year will give you the best rewards and good mental and health condition<3

Thanks for reading my thread, love you all.

12 Replies

Screenshot 2022-12-20 171626.png

Sounds like your Nvidia GPU card has Firmware or vBIOS issues or your Nvidia Driver is at fault.

Would you tell me please how to check it is AMI or something else?


I found that 1 long beep and 2 short beeps means on MSI bios gpu issue, and i have no diea what is firmaware or vbios to be honest


According to your Motherboard's BIOS download page it mentions it uses AMI BIOS:

Screenshot 2022-12-20 171626.png

vBIOS is the same as your Motherboard's BIOS (Firmware). It controls everything in your GPU card.

If the GPU card's vBIOS is corrupted or not working correctly your GPU card will not work the way it should.

I suggest you open a Nvidia G-Force Forum thread and post your question there for help. Sounds either a Hardware (GPU card) or Nvidia Driver issue.

NOTE: You seemed to be very inexperience in Computers. I suggest you have someone next to you help you understand and to do what other Users reply to you.

But my GPU works perfectly in benchmarks, games or render programs, why should it work uncorrect?


THanks a lot for trying to help me bro! Appreciate it! Wish you a merry christmas !

Adept I

Hello, I also faced this problem! Asus b560 motherboard, 580xfx video card, wrote in xfx support, on the asus website, zero sense. I solved the problem by selecting and flashing the BIOS on the website techpowerup. Even the sent bios from the xfx representative did not fit. But even if I managed to pick up and solve the problem, but I didn’t solve the 2nd problem: the fact is that if you modify this BIOS and flash it, then during boot you will not enter the BIOS of the motherboard, but the desktop will boot (on the Russian-language site I was offered a solution), but I did not try it. Yes, CSM helps in both cases. But we are talking about UEFI. Sorry for the transliteration and Merry Christmas.

я понимаю русский, но не понял что там у тебя за вторая ошибка


RUS: я имею ввиду, когда вы модифицируете (установите свои значения в биосе видеокарты) (не важно в каком), прошьете биос, то после загрузки вы не попадете в настройки биоса материнской платы (я нажимал DEL но безрезультатно - не была видна даже заставка загрузки виндовс ), но рабочий стол загрузится и вы будите пользоваться как обычно. Решение предложили на русскоязычном форуме. но я не пробывал.

ENG (transliteration): I mean, when you modify (set your values in the BIOS of the video card) (it doesn’t matter which one), flash the BIOS, then after loading you will not get into the BIOS settings of the motherboard (I pressed DEL but to no avail - even the Windows boot splash screen was not visible ), but the desktop will load and you will use it as usual. The solution was proposed on a Russian-speaking forum. but I haven't tried it.


Вот видео моего монитора, такой цветной квадрат появляется когда прошит любой (не модифицированный биос)  -

Такого нет лишь на том биосе, который мне удалось подобрать


ENG : Here is a video of my monitor, such a colored square appears when any (not modified BIOS) is flashed -

This is not only on the bios that I managed to pick up



Is there a reason you installed Windows using the CSM mode?  This BIOS mode is all but obsolete.

Got some sad news for you.  Reinstall windows with the UEFI mode.  After you install Windows 10, upgrade to Windows 11 through the upgrade process. 

Famous last words of a RedNeck "Hey Ya'll, WATCH THIS"
Big Boss

CloudieMesto, those look like beep codes are from your MB vendor not AMI, but the MB manual does not define them. I suggest you open a support request with MSI. Is your BIOS up to date? Recommend you use it? Did you get all AMD drivers from here? Have you answered all zapiecek's questions - one comment:CSM is not required to run non-UEFI BIOS unless you need for something in particular. Some GPU's do not support UEFI - use GPU-Z to check. Thanks and enjoy, John.