Showing results for 
Search instead for 
Did you mean: 


Adept II

AMD Ryzen 3900X stuck at very low (500 Mhz) frequencies on several cores

Hi all,

I am seeing an issue wherein my AMD's 3900x core 0, 1, and 2 are stuck at around 500 Mhz clock speed. All the other cores are running as expected, except for the first three.

This issue is intermittent.

I have attached screenshot from CPUID HWMonitor:


I let my system run for about an hour now, and these frequencies have not changed. A Reboot will surely fix the issue. 

Is anyone else experiencing this issue, and knows how to resolve it?




G.SKILL Ripjaws V Series 32GB DDR4 3200 (PC4 25600)


199 Replies

i had this issue 4 months ago. 3700x + asus tuf x570 plus. mailed AMD with 100 bench test pics of CPU..i tryed everything like yours. restart . can fix this issue but when every cold start do this,  u feel like crazy. THIS S AMDchipset driver issue.when i update lastest drivers, just once time i ve seen that low clcok speed in 3 months and when i update i never seen this issue yet . BUT lots of TUFx570 user has that problem.
My PC stabil now.
w10 x64 2004
1407 x570 Tuf Bios AMD driver.

Adept I

Since I turned off fast startup in Windows and fast boot in BIOS, the problem has not appeared. About a month (1-2 power-up a day). Also updated Windows to the latest version.

Adept II

stayer_mc‌ Thanks for the follow-up. I am pleased to also to report that I have not seen the low frequency issue ever since I turned off fast startup. Definitely something software related.

I haven't not seen the issue come back in over a month so far. So I am confident this was the issue.

Adept I

Yes, it is definitely a software problem. As we see payo36 changed everything that was possible to change but the issue remained. Although I contacted the AMD warranty service about this and after several questions they suggested trying a different motherboard and if it doesn’t help, then return the processor to the seller under warranty. I ordered it in another country, so this is completely inconvenient.

Adept I

Only happens with the 2.70 bios for my motherboard x570 Taichi (AMD AGESA Combo-AM4 Patch B).  Rolling back the bios to 2.10 (AMD AGESA Combo-AM4 ABBA) fixes the issue.  Fast boot works in 2.70 and not always in 2.10.  Cores get stuck at 500Mhz or some other frequency.  There is no fix, just try disabling fast boot or roll back bios version.

Anyway 2.10 has the EDC bug which makes your cpu boost like crazy.  If you are entering your motherboard power values manually into PBO and say your motherboard is 500A EDC maximum (cpu default is 140A).  You type it in but forget the zeros, thus 5 is entered.  The cpu will go crazy and boost all core to 4.4GHz in cinebench r20 and Time spy cpu (and other avx loads).  In games you can get an all core boost of 4600Mhz.

NVIDIA GeForce RTX 2080 video card benchmark result - AMD Ryzen 7 3800X,ASRock X570 Taichi CPU score with EDC bug.

Journeyman III

I had the same issue with my 3800x this morning after booting up my PC. This is the fourth times it happens to me since I build my PC in march 13.


My PC:


ROG Strix X570-E Gaming (BIOS 1407)

Crucial Ballistix RGB (2 x 8 GB) 3600Mhz (CL16)

Windows 10 Home 64bits 1909

I have fast startup enable (I might try to change it)


Instead of rebooting this time, I went to the settings and changed the power plan from Ryzen High Performance to Balanced to see if it will do some sort of a reset and it does: the core clock instantly came back to normal (notice the actual speed column vs the minimum one in the picture below). 

Capture (2).PNG


 When I return back to the High Performance profile, the core clock also stay normal, so it means there is something that doesn't initialize correctly with Windows or the AMD driver during the boot. It would be interesting to know if it also happens on Linux.

 I compared the last chipset driver installer from ASUS website (release in 2020/01/20) to the one from AMD (, release 4/7/2020)  and there is a slight difference. The installers are not the same, the one from ASUS install OEM app profile (it isn't useful for me since I have an nvidia), and the driver version for the PCI and the GPIO Controller are slightly higher with the installer from AMD. The drivers from ASUS are installed in my system right now, so perhaps using the latest driver from AMD, like jaydeejoy, is the solution.

Driver installer from ASUS:

   Has OEM app profile 1.00.0000

   AMD GPIO Controller Driver

   AMD PCI Driver

Driver installer from AMD:

   AMD GPIO Controller Driver

   AMD PCI Driver

Btw, for those who have an Asus motherboard, go check if there is new BIOS update for your specific model, 1408 version is released for mine :

"1.Improve system stability
2.Add BCLK Frequency and SB Clock Spread Spectrum items into BIOS Advanced mode. "


AMD saıd, dont use ASUS driver, USE AMD lastest driver. Asus drivers are outdate and not stabil. i mailed ASUS 1000 times for a new bios (bclk speed) and they done


try fresh install windows 10 (2004) and do not install any driver from Asus..Use AMD high Performance thats it.

I had this same issue on my first install of W10, the OS kept switching the power plan on every single boot.

I did some reading on this and I found out that there must be some conflict, or Windows thinks there is one (regardless if there really is). When I removed 1usmus CPP this all seemed to stop for the most part and I haven't reinstalled it on my new OS install.

I am not sure I can recommend that CPP anymore, for the first 4 months I had the 3950X, I was 100% behind recommending it. However, I wonder if it was part of the reason that I had to re-install W10 after only 4 months. For now, I am just using Ryzen Balanced and Power Saver modes, not worrying about any CPPs. 

If you are having a similar issue, where your power plan is randomly switching on you, finding it in PS mode or a non-Ryzen plan, then you have a conflict with the CPP too. I can't guarantee removing the 1usmus plan will stop it, as I did a full re-install shortly after that. It sounds like a good place to start though. 

There is also a chance we missed some of the needed settings to use the 1usmus plan, although I triple checked all of mine. My ASUS X570-E STRIX is missing some of the requested options, though, so maybe that is why?

Good luck! 

Journeyman III

I have exactly the same issue with 3900X and Asus Tuf Gaming X570-Plus. A few days ago about 3 cores were stuck at 500MHz and one was at 1500MHz while the rest were fine. I reseated the CPU and heatsink thinking it was some kind of throttling and it was fixed for a few days. Today nearly all the cores did it, tanking performance in everyday tasks. Restarting fixed it, but I'm really curious what the problem could be. Someone early mentioned the VDDCR SOC voltage shouldn't be as high as 1.362V. Mine is the same and I haven't touched it - that's what the motherboard has set it at according to Ryzen Master.

Edit: I've just checked in the BIOS and the SOC voltage is set to 1.1V, so idk why it's showing so high in Ryzen Master

Journeyman III

My 3600x has the same issue. But it‘s not always at 0.5ghz. Sometimes it gets stuck somewhere between 0.5 and 2.5ghz. I tried all the mentioned solutions except the fast boot. Let‘s see if this is going to help.

Since I went amd I had so many issues that changing the powerplan for a second seems like an acceptable solution...

Adept I

mine also gave this problem in all cores, I use a ryzen 5 2600, and it gets stuck at 0.54ghz, I already tried to solve it with the motherboard manufacturer and it didn't, the bios is up to date, now I opened a support ticket in amd for a solution. Mine only goes out of 0.54ghz if I turn off and on the pc or suspend and return.

Still unsolved, I'm starting to think it's a manufacturing defect of the processor because several motherboards have the same problem.


please try installing the latest chipset drivers if you have not already.


mine is B350, everything is up to date and also windows 10. aaaa.jpg

Adept I

This can not be a coincidence. My 3900X has the exact same problem, with different brands of motherboard and memory. 

At times, some cores get stuck at a very low clock speed.

Just like OP, Cores #0, #1, and #2, are stuck at 559.0 MHz. 

This results in terrible responsiveness and performance of my PC! Even opening a folder, browser, or other app takes way too long. Going to fullscreen and back on YouTube takes seconds. 

I didn't change anything, this problem suddenly appeared recently. Power plan is set to high performance of course.  

Rebooting sometimes seems to fix it, but I'm desperate for a solution. This behaviour is unacceptable. 

AMD Ryzen 9 3900X - Scythe Fuma

Gigabyte X570 Aorus Elite

64GB Crucial 3000C16

Palit GTX1070 Super JetStream

Corsair MP510 960GB

Samsung 850 EVO 1TB

OCZ TR150 960GB

Corsair 760T + HX850i

Win 10 Pro


My x570 aorus elite behaves the same. I ordered a new aorus elite, to see if it´s the motherboard.

Journeyman III

I have had this with up to 9 Cores Affected on my 3900x and the Asus x570-E. 

My Solution was to not use a AMD Power Plan I hope it stays fixed.

Adept I

I was running the memories at 2933mhz which is according to the amd website for ryzen 5 2600 processors and it gave this problem, now I left it at 2666mhz and so far the problem has not appeared and I do not use xmp, I believe that or amd it has the wrong data for the maximum memory or the motherboard.
What frequency of memory do you use? 


hello all,

I encounter this problem with my 3950x and MSI x570 Godlike from November to April with the old bios AGESA, old AMD chipset 1.11 and AMD Ryzen Master never installed.

Sometimes at boot I stayed locked to 500Mhz

With the latest bios with AGESA, never appended again.

I use now AMD chipset 2.04, AMD High perf power plan and have AMD Ryzen master installed but not used.

Adept I

Just registered for this.

Needless to say I'm too having this issue. First the proof:


CPU: 3900X

Mobo: gigabyte aorus master x570

PSU: Seasonic Prime PX-850

RAM: G.Skill F4-3200C14Q-32GFX


Rest shouldn't be an issue.

The temperature can not be an issue, cuz the temperature never goes too high - meaning I never saw it above 70C

I'm not sure when this issue appears, but randomly happens.
So I'm used to work in this PC at home(just switched from laptop to this new PC) - freelance software development - and sometimes when I'm done with work, and it's time to chill I just realize that the PC is just painfully slow. Sometimes I realize the slowness during work too, but there are days when there is no issue with the CPU at all.

BIOS is on default settings. BIOS version is fresh. PC config is like a months old. There is an XMP setting, but as I see it's not on atm.

As I can see it here it seems to be a major bug/issue, cuz different ppl have this issue with different setup. So I'm kinda disappointed, cuz if I would release a product, which has this major issue for months after the release, my clients would cook me alive for sure.


what is the speed of the memory configured in the bios?

Adept I

Interesting fact: I remembered that I had the XMP profile on, and now that I restarted the PC it seems like I was right about it. However after the PC boots up, in the HWinfo it says that the memory is running on the default 2400Mhz(1200Mhz)

I'm not sure if this is related.


If you change the xmp, set a memory speed to run, I put 2667mhz to not give any more problems, usually as motherboards limit it to 2133mhz without any configuration.

Adept I

Happened to me as well. Completely fresh install on a new MB/CPU/RAM. Asus TUF x570, R3900X, HyperX 3.3Ghz.

All firmwares and drivers are latest, including BIOS.

Nothing changed, just one morning at cold boot the cores were stuck at 559Mhz. Started uninstalling proprietary softwares, tuning programs and changing power plans, nothing seems to help. Now disabled fast boot and set power plan to W10 default to see if it still happens. 

Really frustrating.


I've been having the same issue since april 21st.

My setup was 2 months old at the time.

3950x running at stock speeds no PBO
Gigabyte Aorus Master x570 f11

G.Skill Trident Z neo 3600 cl16.

Samsung 970 pro Nvme m.2 1tb

Windows 10 1909 update.

Latest chipset drivers installed (from AMD's site, April update)

I initialy placed a ticket to RMA my CPU in order to discuss the issue with them. They did authorize the RMA code immediately but I haven't followed through yet given that it seems to me that it is a software problem (windows and drivers). Sending away my CPU for a month (at best) and being unable to work for that time is not financially reasonable right now. Especially in this case, that it's highly likely that nothing is wrong with my CPU and windows or chipset driver or even deprecated motherboard drivers (Gigabyte tends to be insultingly slow on updates) could be the culprit.

I, too, tend to "WAKE UP" the cores by going to power plan settings and switching power plans a couple of times.
For example, going from AMD Ryzen Balanced to Windows Balanced and back again. The switch confirmation comes by closing the window. Most of the times a couple of switches are enough. The cores immediately wake up.

But I surely would not like the health of the pc I work from to be a dice roll.

So here's what I would add to the conversation.

Could anyone please check for their background installations windows might have done before the issue first appeared? Not through windows update (my history had registered only a minor windows defender update).


But In system restore I got this


Windows modules installer is a windows services that does what the name implies, it silently installs windows modules in the background.

Diving into the affected programs list for the restore point I got these among the other known installations.


The only one that is in some apparent way related to CPU behavior is the Security Devices one. AMD supplies it's own driver for this device, the AMD PSP 11.0 Device driver.

The drivers this background installation replaced were these ones.


Since I'm not an expert I don't really know what to make of this, but hopefully someone else here can, if it's at all helpful.

Hopefully there will be an official response to this bug.


Adept I

Googling this issue further shows this happening three years back already, so this is not a new thing. Does anyone know has AMD (or Microsoft) attempted to investigate this issue at all except just telling to reinstall all and make sure you have the latest drivers? Even to determine if this is solely a Windows issue or something more fundamental?


Seems for now, if you experience the problem when booting your PC into windows, go to the power plans screen and change to a different profile and then back again. I've been sticking with the AMD Ryzen high performance plan and it hasn't occurred for me.


I had done this, I did a lot of things, the only thing that has worked so far is to decrease the memory clock, mine is like 2667mhz. I've been using it for 15 days and so far it's normal, it still hasn't given me the problem.

Journeyman III

I have a similar problem but on ALL cores on my 3700X and B450 Tomahawk Max... My energy profile was always "AMD Ryzen high performance" and rebooting helped.

Today I've tried to change it to "Balanced" and then back to "AMD Ryzen high performance" and it helped!!!???

How this is possible? What do I need to do to fix this permanently without this hack?


hello shebuka,

have you AMD chipset drivers 2.04 ? have you installed them after uninstall the previous and rebooted before installing the 2.04?


I was using version 1.something from November 2019. Updated to latest Will monitor if this issue presents again.


It means the problem is primarily with windows and settings of its power plans upon cold startup.


Never got any issue with Windows power plans on any other system configuration. Even this problem happens like once every two months. Definitely not primarily Windows problem.


I only got this issue, once, when I first used a different windows power plan, a non-standard one which was 1usmas's power plan. This did, however, go along with changing a few settings he said to change in bios. For a board bios, there is also the possibility that the auto rules are setting something that would cause this behavior. I'm on the very latest bios for my board.



uninstall all AMD chipset drivers and all 1usmas tools, then install AMD chipset drivers 2.04 and nothing else. AMD power plans included in 2.04 already have 1usmas same optimization .

I solved my locked core speed like this.

Since end of march, never seen any locked core.


try leaving the memory clock at 2667mhz


How this can be connected with CPU multiplier being locked on the lowest value?

I have Gskill 2x16Gb with 3200Mhz XMP profile. Are there any known issues with my configuration? (3700X and B450 Tomahawk Max and Gskill)


For some reason, swapping between power plans seems to refresh the CPU and the cores essentially, wake up. 

I'm not sure what is going on that so many people are reporting this, but I think some of you have the behavior that AMD intended.

Only certain scenarios will you see every core running at max speed. When you do get all the cores running up to max speed, the speed they hit will be lower than if you had 4 cores hitting max speed. Usually a few hundred megahertz and I think this is what is happening. Perhaps for some of you, the software you are running, just isn't utilizing the full core/thread count. 

By the way, you can force all cores to run at max speed, but if you do, they won't downclock at all. To do this, either set the clock to a manual speed (OC/UC) or disable Precision Boost 2.0 or PBO (whichever you had selected).

I did a decently deep dive into AMD and W10 power plans in this AMD Community Thread if anyone is curious about my results. 

(AMD 3950X + ASUS X570-E + G.Skill TridentZ 3733)

ledhed wrote:

I figured out what is causing all of this behavior. The power plans all make the CPU core voltage behave differently.


In Ryzen Balanced mode, my CPU + Mobo holds the core voltage steady at 1.38V. The Average voltage and the Peak voltage are equal. 


In Ryzen HP mode the average CPU voltage is lower than Balanced about 1.18V, but the peak is higher, 1.435V. This means that the power is being delivered to the cores that need it most and less to the others. This could in theory lead to higher boost clocks, so it makes sense I guess.


Then in both of the 1usmus CPPs, the CPU voltage is about 1.41-1.42V steady, pretty much like the Ryzen Balanced mode, except it does vary a tiny amount


Note: Power Saver Plan puts it at 0.9V and holds it there.


You are right indeed that the "refreshing" of the CPU seems to wake things up but you're wrong about the software utilization portion of your comment.

While experiencing this bug, an Arnold vray or renderman render or even a simple stress test on the Ryzen master software produces a "sawtooth" graph not a flat/full utilization one, however high the Mhz count. The TDC and EDC flactuate erratically from ~20% and ~85% and this directly affects clocks.

By switching any power plan to any power plan, the cores seem to just... wake up. Sometimes even a couple of consecutive stress tests will do the trick. It happens quite often after a cold boot and it is an issue of stability and reliability.



I said it's possible that is why "some" people reporting it, might be experiencing that. 

I wasn't saying that about you (or anyone) specifically. Just wanted to point it out as a possibility, since this can be the correct behavior, depending on what was happening during the screenshot.