Showing results for 
Search instead for 
Did you mean: 


Adept I

AMD 5800x BSOD booting & installing windows

I've been stumped with an issue where I'm unable to get windows to boot or run the installer on my new system.  I've already tried 2 motherboards, and 2 sets of RAM, 2 different USB sticks for windows install.


  • 5800x
  • MSI MAG Tomahawk x570 WIFI
  • 32 GB (2x16) G.SKILL Ripjaws V Series DDR4-3600 (F4-3600C16D-32GVKC)
  • Asus ROG Strix 2080Ti OC

Previous attempt:

  • 5800x
  • Gigabyte Aorus Pro x570 WIFI
  • 16GB (2x8) Corsair Vengence LPX
  • Asus ROG Strix 2080Ti OC


Every time I boot windows (previous install on my SSD) or attempt to start the installer I BSOD with SYSTEM_THREAD_EXCEPTION_NOT_HANDLED.  I've tried turning off fast boot memory as well as disabling CBP & PBO.  I've also tried latest BIOS (beta) and the previous stable release.  I've also tried launching windows installer with no hard drives/ssd/nvmes.


Does anyone have any other ideas or things I could try?  Or should I go straight for an RMA?  If I have to RMA, I have a little problem of no longer having the box, it got accidentally added to the recycling because of Christmas (I do still have the receipt thankfully).


Thank you in advance,


8 Replies

Have you tried a fresh install? old Hard Drive or decent sized USB stick?

Id say it would be some secure boot or missing or invalid boot partition on SSD.

if possible wipe the drive Inc. Deleting existing partitions and start fresh. 

Not sure why the installer would crash unless it's detecting the existing WIN and tries to upgrade or repair and fails?

Could also try installing a Linux OS ON USB drive and see if it has any dramas booting?


Yeah I've tried doing a fresh install, but I cannot even get the installer to load.   I tried two 3 different USB sticks, 32GB, 64GB & an official Windows 10 one.  I tried using the media creation tool, as well as imaging a Windows 10 ISO.  It would always BSOD during the initial windows loading logo.  I even tried disconnecting all my drives (HD, SSD & NVME) as to eliminate as many components as possible, and the windows installer still gets the BSOD.  I swapped out my graphics card for a much much older one, no change in results.

The only component that's remained the same is my PSU.  I know it works since it powers my current machine, but I did end up ordering a new one just in case (and because I don't want to keep swapping it back and forth).

I haven't attempted a Linux boot yet, I might give that a try today.  Any recommendations on a USB bootable distro?


Thank you for your suggestions,



I got a Ubuntu boot partition that runs well on a USB stick. Just have to use a program to make it a bootable ISO can't think of its name now.. 

But ran and works well for testing and deleting files or partitions that Windows won't let me..


So I created a bootable ubuntu, I'm able to get to the boot selection menu; however any option I select just leads to a black screen and complete freeze.  Going through the BIOS I found an option for enabling how many cores to use, after setting it to only use 1 core I was able to see ubuntu going through a disk check, but instantly rebooted my computer after that completed.  I tried skipping the disk check but I got the same result.

I am going to attempt and RMA through AMD since I cannot go through my retailer anymore.  I no longer have the original packaging, it got mixed into the recycling by accident (Christmas time).

In the past I've always purchased Intel, but decided to try out this new generation from AMD, so far I've had a very poor experience :/

Adept II

Did you update your bios

Sounds like your cpu and ram is unstable


I tried several bioses, old... New... Beta versions.  The RAM works in my old setup, ran memtest86 for at least 4 hours, no errors.  I even tried a new 2 different RAM kits, and still had the same errors.  AMD has approved an RMA, I just need to send it to them for inspection.




If you RMA through AMD they don't care about the box.  They will ask for proof of purchase and a picture of CPU in the motherboard socket. Expect RMA to take around a month from start to finish.


did you choose UEFI in BIOS and install on GPT and not MBR?

PC: R7 2700X @PBO + RX 580 4G (1500MHz/2000MHz CL16) + 32G DDR4-3200CL14 + 144hz 1ms FS P + 75hz 1ms FS
Laptop: R5 2500U @30W + RX 560X (1400MHz/1500MHz) + 16G DDR4-2400CL16 + 120Hz 3ms FS