Showing results for 
Search instead for 
Did you mean: 


Adept II

A8-7680 R7 driver problem (?)

It's high time to admit (AMD) to have an A8-7680 processor in your portfolio, which I bought at official Polish distribution. This is an authentic AMD processor. It's high time to publish the official information about it on and immediately improve the graphics card drivers for Windows so that they work properly. As of today Radeon driver both the one automatically installed with Windows Update and the latest available 19.1.1 it does not work at all on Windows 7 and Windows 10. Bluescreen appears when installing, on a clean installation of Windows 10 bluescreen is already on the installation of drivers, and then on average every second run. On Windows 7 after installing the driver bluescreen appears every time. I don't write here about 3 frames per second in some game but about the operation of a brand new processor. Although how to work something that AMD doesn't admit and in principle Radeon drivers don't support this integrated R7 card ;-) ... because it doesn't exist :-). In the case of the open source amdgpu driver on Linux everything works properly. I attach a decoded kernel memory dump from Windows 10.

Is this the only place where I can report this type of problem to AMD?

If it's a hardware problem then I'm sorry for the reason in advance, but when you buy a processor, it's expected that the manufacturer will admit to it and provide drivers that at least the desktop of Windows will display stable :-).

18 Replies

Downloaded and read your Memory Dump.

Do you have the latest BIOS installed for your Motherboard. FM2A68M-HD+

Try installing the AMD ALL in ONE Driver (I believe it also includes the CHIPSET Drivers) from Asrock for the new CPU: ASRock > FM2A68M-HD+ 

Strange that it works in a linux environment but not in Windows.  You should reset your Motherboard BIOS back to "Default" by removing the CMOS battery according to your Motherboard's manual. Make sure you don't have anything Overclocked which might cause BSODs.

When you upgraded the CPU did you upgrade any other hardware like RAM Memory or Hard Drive?

In AMD Download page I don't see a specific AMD Driver for the A8-7680 with R7. So I would download the AMD Driver from the Motherboard which should be compatible with the new APU. 

See if the Motherboard's Graphics driver works or not.


Hello, sorry for the rather emotional description of the situation.

Thank you for your answer and your suggestions.

I have the latest BIOS (5.10), because only it supports APU A8-7680 and the second dual core new APU. I updated this latest BIOS just after it was released that year. So far, I had an A4-6320 on board and replaced it with the A8-7680. Nothing else has changed. In UEFI, only the memory clock is set fixed according to their capabilities (similar to the A4-6320). With the A4-6320 both Windows and Linux worked properly. The only difference that appeared in UEFI after mounting the A8 is fTPM (this module works quite capriciously, so I reset UEFI to default settings by resetting from its own level).

After installing motherboard's graphics driver (so it also contains drivers for the southern bridge, PSP, USB, etc.) and restart = BSOD, one more restart OK, another: BSOD, etc.

If Windows starts correctly, everything is stable, even in challenging games. In Linux, the same games running with Steam Play work correctly. Loading Linux with video encoding and graphical benchmark = everything is stable.

I thought this is a BOX processor and will be supported like any AMD product with GCN. However, after your suggestion, it looks like this is more OEM and drivers are on the motherboard manufacturer's website (but do not work properly  ).

I suppose Linux can handle all this probably because amdgpu supports all graphics cards, both mobile and desktop, without any special optimization. And this APU is a quite untypical connection because it has GCN 1.2, Excavator cores and ... DDR3 instead of 4.


When you say Windows starts once it is okay but if you restart it again it BSODs.  It doesn't BSOD as soon as you power up but rather when Windows starts loading drivers, Right?

I beginning to wonder if you may have some software that is not compatible with the video driver.

Try this for troubleshooting purposes only. It is simple and will eliminate 3rd party software causing the BSODs. 

Start you desktop in a "CLEAN" Windows desktop. This is similar to running Safe Mode except is has all startup programs "disabled" and most 3rd party drivers. Also disable your Anti-Virus to eliminate that possibility.

Here is how to do it: 

If you start up with a "Clean" boot and your BSOD ends and Windows starts up every time. Then start 'Enabling" half of the start up programs and see if the BSODs come back. Than do the other half and see if it BSODs. Then you can just use the process of elimination to find out what program is causing the problems.

Also a weak PSU could cause BSODs. What GPU Card and PSU Make & Model do you have installed if applicable. If no GPU card than most likely your PSU is strong enough unless you have a PSU of 300 watt or less installed.

If you are able to get Windows to boot up properly. Try stressing the APU, GPU, and PSU and see what results happens. I like using OCCT which stress tests the PSU besides the CPU and GPU. Furmark is another good one to use and Prime95 also for very severe testing of the CPU.

If you stress test the CPU, GPU or even the PSU and it BSODs during the test than you can find out or narrow down to see what caused it. I would install a monitoring software like Open Hardware or HWHardware to see what your temperatures, voltages, and other pertinent data is showing while the computer is under heavy stresss or load. 

Could be a Overheating or Power issue besides a Video Driver issue.

Also please post the exact BSODs Error messages or any error messages that pop up when the computer crashes.


My system is based on BeQuiet! Power System 7 400W. The computer includes: Asrock motherboard, which we have already talked about, 2x 4GB GoodRam 1866 MHz Dual Channel, CPU we are talking about, 2x DVD-RW, SSD + HDD. That's all.

The temperature measured on the heatpipe (by thermometer) right next to the CPU in stress does not exceed 40 degrees Celsius. CPU cooling is Cryorig M9A + thermoconductive paste with silver powder.

The error appears most likely when loading the graphics driver, because during one of the Radeon driver installations, just after trying to reload the new graphics driver, BlueScreen occurred.

I have 3 additional drives, so I installed new, clean installations on them: Windows 10 1803 x64, Windows 7 SP1 x64 and Vista x64.

Vista works without any problems, because there is no Radeon driver for R7 (from what I searched for) and runs on the standard driver.

Similarly Windows 7, until the installation of the Radeon driver. After installation, an error message is displayed each time until I uninstall the graphics card drivers in safe mode.

Windows 10 as the only one has built-in, working drivers for my network card, which causes that already during the last stage of installation there was an error as in the attached picture (I suspect that he tried to download drivers from the network, although I haven't met with something like that yet on 10). After installing Radeon drivers, every second restart/start is an error.

I attach a picture of the screen with an error we are talking about.



sounds like the APU might be defective or there is something that is not compatible. That is why I mentioned to boot into a "Clean" Desktop to eliminate any other 3rd party software or programs that could be interfering with the Graphics driver when it starts to load. 

If you install your APU on another compatible motherboard and see if the same thing happens. If it does it a good indication that the APU might be defective. If it doesn't and works fine with the APU Drivers installed than it is something wrong with your computer setup causing the APU drivers to BSOD when loaded.

Open an AMD SERVICE REQUEST from here: Online Service Request | AMD .  put a link to this thread to let them see all that you have done and see what they suggest.


Thank you very much for your help.

As I wrote earlier on clean, newly installed Windows 10 and 7, without anything, after installing the graphics card drivers from the Windows Update machine, the above mentioned error appears. The computer has changed only the CPU from A4-6320 to A8-7680. I have a different motherboard but A88X, which is not compatible with A8-7680.

I created a new AMD SERVICE REQUEST according to your suggestion.

Additional information after the two OCCT tests:

2019-02-10-11h36-Frequency-GPU #0.png

2019-02-10-11h36-Frequency-CPU #0.png

2019-02-10-12h35-Frequency-GPU #0.png

2019-02-10-12h35-Frequency-CPU #0.png

All graphs in the attachments.




2019-02-10-20h41-Frequency-GPU #0.png

Sorry for the late reply. While running the CPU and PSU stress test, did your computer crash by any chance?

OCCT is showing GPU running quite hot:

I imagine it is referring to the APUs integrated GPU. Most likely a misread by OCCT.

If you said you made a clean Windows installation and as soon as the APU driver starts to load it BSODs.

At another Forum that specializes in BSODs, one of the Windows expert mentioned that if you made a clean installation of Windows and it BSODs that generally indicates hardware problem or failure. Since there are no 3rd party programs installed or drivers except the APU driver, in your case.

Could be incompatible RAM Memory in conflict with the new APU. If your RAM Memory is not compatible with the new APU, it could cause BSODs to occur or your computer not to boot up.  I noticed that your RAM is not listed in your motherboard's QVL list: ASRock > FM2A68M-HD+ .

In fact I see only one RAM Memory of 1866 Mhz Speed in the QVL List:

Try using only one RAM Stick on the primary RAM MEMORY Slot and see if it BSODs.

The QVL list is a list that the manufacturer tested the hardware for compatibility and other issues. If it is listed it means that hardware (RAM for instance) is fully compatible with the motherboard and BIOS.

If it is not listed it could mean two possibilities:

 1) The hardware was tested and found not to be compatible

2) The hardware hasn't been tested yet for compatibility issues and thus is not listed.

So your RAM Memory would fall into one of the above categories.


Also I would update your Windows 10 to the latest version 1809. AMD Drivers work with the latest Windows version installed and Windows completely updated via Windows Update.


when it comes to answers:

0. When Windows already running with installed graphics card drivers, there was never a crash. Even during the OCCT test.
1. The CPU has been accepted for warranty claim. I sent the processor to AMD, and so far I re-installed the A4-6320, which works 100% correctly. There is one difference, the controller of this A4 supports memory only up to 1600. However, the same memory used to work with the A10-7800 processor at 1866 clock and there were no problems.
2. As far as RAM compatibility is concerned, in my opinion it has no idea at all. RAM chips meet certain standards at 1866 clock, and the processor itself has a controller that supports them. These are not overclocked memories or, as in the case of new designs, OC versions. I think that memory was not tested by Asrock, because it is a Polish manufacturer, perhaps not very popular outside of Poland.
3. As far as temperatures are concerned, in the case of APUs (and I already had 3 different APUs: A10-7800, A4-6320 and A8-7680) I do not trust what I see, I measure temperature manually. Here is an example:



Does AMD believe the APU is defective from the information you gave them?

Glad you were able to RMA it back to AMD.  Hopefully they will test it and find it defective. At least when you get a new Processor it should work normally. If it doesn't you may want to look at your RAM Memory. Maybe temporarily underclock the speed in BIOS just for troubleshooting purposes.

Yeah, sometimes OCCT is not compatible with the motherboard's temperature sensors and either misreads the temperature wrong or not at all.

Anyway, let me know if the new processor works correctly unless they send you back the original one saying it wasn't defective.


AMD asked me to change the Windows registry, which was also described in this forum. We extended the time when the graphics card was to be started at the start of Windows. It didn't help, so they asked me to send them the processor.

As far as temperatures are concerned, these sensors are simply not very accurate. E.g. in older APUs they worked correctly only from some threshold value, when we have e.g. 4 Celsius degrees in idle.

I'll let you know how the final of this case will be.


Something just came to me while posting right now.

I remembered trying to help this owner (?) of a small Russian computer company that assembles and sells PCs.  He opened a thread concerning the FM2 processors. I was asking if anyone was having problem with those particular FM2 socket processor because his company has been receiving many defective FM2 Processors from their customers. I noticed now that you also have a FM2 Motherboard where possibly the processor is defective.

Anyway if you are interested here is the AMD Thread opened by that Russian company here at AMD Forums: Problem with FM2 processor (A4-A10 & Athlon X4) 

Hello, my complaint was accepted, I should receive a new processor from AMD soon.


Glad to hear it. Must have been a defective APU.  I let the other thread from Russia know about this thread in case they are interested.

Journeyman III

Sadly, I have to confirm AMD A8-7680 GPU problems, which renders R7 video unusable at all.

My exact test platform is AD7680ACABBOX with ASRock FM2A68M-HD+ latest BIOS with 450w PSU and one MLC SSD all brand new. CPU serial number confirmed on AMD site.

I have desperately tested it with various memory modules on clean install of windows 10x64 builds from 1607 till 1809 with latest updates, home/enterprise and even Win10 Pro for Workstations during two months/

Drivers tested were from Crimson 2016 year till Adrenaline 2019 18.9.3 (latest stable) and 18.12.3 BETA.

There is obvious problem with amd drivers (most referring bug is "thread in driver stuck in atikmdag.sys"). In all cases system gets BSOD, the whole whole difference in stability depends on windows build - modern windows builds have better protection from memory corruption caused by bad kernel driver code and user even can get into the desktop for the minute or two, old windows 16xx builds crash during boot driver initialization. It is definitely hardware problem, maybe with powering internal GPU core.

Also I have heavily tested abovementioned configurations with different memory, voltage, frequencies, memory allocations for gpu -  with no luck. If only you disable graphic core of AMD A8-7680 - system works perfectly in any conditions with any load.

I have ended up disabling R7 video and using now old radeon 46xx PCI-E videocard which is very disappointing at all.

I have different crash dumps from different OSes and driver combinations and ready to fully collaborate with amd, because I have no other FM2+ processor to replace current CPU during RMA.

Also I have to confirm problems with stability with FM2+ socket at all, I receive complaints for BSODs (different weird error codes) for AMD A6-7400K(AD740KYBJABOX)+Gigabyte GA-F2A68HM-S1+SSD+PSU500W all brand new bought since Autumn 2018 at production environment with typical heavily tested and constantly updated OS configurations with ESET commercial antivirus. There are no clear reason or timing for these BSODs, OS journals are clean, sometimes BSOD can appear few times a day, sometimes there are no problems during months. There are a lot of other workstations connected to the same power line, network, peripherals with same software configurations, users do not have administrative rights - non FM2+ socket computer work flawlessly. Replacing memory modules, PSU and other components between FM2+ and not FM2+ computers did not show any reliable difference. It is not possible to replace these components by warranty because where are no reliable way to escalate BSOD - sometimes is doesn't appear for weeks, sometime - few times a hour or day.

As for now I have to assemble 4-5 workstations for a next week and don't know what to do - looks like I have to break up with cheap AMD solutions for half of year or more and wait for some improvement on market.

BTW all components are officially bought in Ukraine, it is the same region as Poland and Russia.


In my case, PSU, RAM, SSD, HDD and DVD are the same and have changed:

1. Motherboard Gigabyte FA2A88XM-HD3P (chipset A88X) + A10-7800 = everything worked very well.

2. Motherboard Gigabyte FA2A88XM-HD3P + A4-6320 everything worked very well.

3. Motherboard Asrock FM2A68M-HD+ + A4-6320 everything worked very well.

4. Motherboard Asrock FM2A68M-HD+ + A8-7680 = integrated graphics card problem.

Therefore, I can't say anything wrong about 2 in 3 processors (official distribution in Poland).

There are rumors that the A8-7680 is the A10-9700 just released for FM2+ (it has a DDR3 and DDR4 controller probably). Looking at the graphics card clock on these tests:

AMD A8-7680 (FM2+) Radeon R7 Review - iGPU Gaming Performance Test Benchmark - YouTube 

AMD A8-7680 (New) vs A10-7860K. FM2+ iGPU Benchmark Test Comparison - YouTube 

A8-7680 | Any good for Gaming? | AMD A8-7680 Gaming Benchmark - YouTube 

AMD A8-7680 R7 (FM2+) - Apex Legends - Gameplay Benchmark Test - YouTube 

it is quite likely (the official specification on the AMD website still does not exist), because the graphics card is clocked ~1000 MHz and previous generations of APUs to FM2+ had graphics cards clocked ~700 MHz.

Looking at my charts from a distance, the graphics card often lowered the clock to 500 MHz, and never went up to 1000 MHz. This would confirm the problem with the card itself. Although I've written two things that interest me before: why Ubuntu (Kubuntu) didn't show any problems and why the graphics card was stable after running on Windows, I could play a demanding game like Siberia 3 and there were no problems, just like in Kubuntu.

Are you able to check the clock of your graphics card (your A8-7680) over time? Does it also not reach 1000 MHz and drops to 500?

PS If you have a second copy with a similar problem, it came to my mind if this is not Athlon X4 845 with unlocked graphics cards ... :-). Of course, both the above mentioned information about A10-9700 and this X4 845 are not confirmed by anything, because I do not have such knowledge as to whether it is possible.

Journeyman III

OMG I think its not like that. I'm currently using that Processor running Windows 10 Pro. I use Amd Radeon Adrenalin 19.3.1 to install driver.

A8-7680 with R7 (Cooler Master Blizzard T2 CPU Fan)

G.Skill Ripjaws X 4Gx1 PC-12800 (OC to 2133mhz)

Asus A68hm-K


Im from Philippines.