Showing results for 
Search instead for 
Did you mean: 

PC Building

Journeyman III

SATA RAID 1 keeps becoming unwritable

Good day, everyone.

Here is the scenario:

New build with an Asus X670e motherboard and an AMD Ryzen 9 7900x.  I created 2 RAID-1 arrays.  Array-1 has a pair of 6TB HDDs.  This array has from day-1 worked perfectly.  Array-2 has 2 Crucial SSDs for items that need faster storage.  This one keeps breaking.

I have the latest AMD RAIDXpert2 installed, and I have installed the latest AMD chipset drivers.

What will happen is that as soon as just a few files (less than 5 typically) are written to the SSD mirror, I start to get "Error 0x8007045D:  The request could not be performed because of an I/O device error."  Files can now be read from (sometimes) but not written to the array in question.

Here are some things I have done:

1. Once this error occurs, it persists even after a full reboot.

2. I have re-created the mirror MANY times, the above symptoms persist...after a few files written the drive becomes un-writable.

3. Thinking I had a bad SSD, I have replaced not one but BOTH of the SSDs.  The same symptoms persist.

4. I have replaced the SATA data cables to the motherboard.  The symptoms persist.

5.  I have tried removing all hardware caching of the mirror through RAIDXpert2...symptoms persist.

6.  I have tried reinstalling AMD drivers and RAIDXpert2.  Symptoms persist.

7.  I have created the array in both the BIOS as well as in RAIDXpert2.  Same symptoms persist.

8.  I have flashed the MB BIOS to the latest version.  Symptoms persist.

9.  JBOD or RAID-0 configurations don't appear to have this problem, only RAID-1.


I opened a ticket with ASUS but their technical team was unable to provide a resolution.  Again, my RAID mirror of HDDs continues to work perfectly fine and has since day 1.  It's only the SSDs that are a problem and apparently only in a RAID-1 config.


Has anyone experienced anything like this?

Thanks in advance for any suggestions you might be able to provide.

4 Replies
Adept II

Hello, dmelczer, 

I get random error messages from my system stating that I need to configure RAID in BIOS press F1. I don't even use RAID myself as I am generally heading towards a cloud centric setup. The only way I could fix my problem was to reinstall the BIOS, sometimes it took several go's? But researching the RAID setup issues, I found the following a long time ago. I hope this helps you to solve your RAID issues, or at least puts you on the right path to doing so. Good luck!

Does Windows 11 support system drives in Raid like Windows 10 - Microsoft Community

Journeyman III

Thanks for the suggestion and reading, orbitech.

I did forget to mention the BIOS was reflashed more than once.  This didn't fix the issue.  I'm not sure that the issue resides with the BIOS though, because as mentioned the RAID-1 HDD set works perfectly.

Also, in my case, this isn't my boot drive.  My boot drive is a Samsung NVMe, non-RAID.  This is strictly a data storage drive using RAID-1 for redundancy.  As such, I don't have the issue of needing appropriate RAID-1 drivers to be present for system boot.  Even when these drives fail, my system boots perfectly fine (it's pure data storage, not executables, etc.)

Can I pop out 1 drive, put it in an external USB enclosure and just backup every few days?  Yes, I could.  I'd probably forget to do it more often than I would like to admit, but that's more of a behavioral modification problem, LOL.  The RAID-1 feature is available in software and hardware though, and in theory it should work so I thought the RAID-1 configuration would be the easier solution.  I've wasted so many hours troubleshooting this that I could have probably done a dozen full backups of the data in that time.

Warning to others...on an x670e chipset SATA SSD drives in RAID-1 work for a little while but will absolutely quickly fail.


You are welcome, dmelczer, my troubles where with the BIOS but yours seem to be the SSD themselves. From what I have read the modern SSD is not entirely compatible with the RAID setup. I would look into the SSD settings and question the manufacturer to see if the are RAID capable.

Journeyman III


I have had the same issue with I/O device error, but I found a solution on the forums here and you need to simply have the RAIDXpert2 GUI running for the drives to work until AMD/Windows come up with a fix.

I used Crystaldiskmark to check my drives were working.

Re: RAIDXpert2 & failure to access SSD if GUI not ... - AMD Community

Read through and check the links, I did the same as someone mentioned and set up a scheduled task to run RAIDXpert2 at start up.

"Thank you for checking this one. I have found a work around where I run RAIDXpert2 as a scheduled task on system start prior to user login. The binary is capable of running in the background in such a manner. So for now I have unhindered access to the SSD RAID Arrays." taken from MSI forum.