Showing results for 
Search instead for 
Did you mean: 

PC Building

Adept II

Raidxpert not in new bios update

I have a zenith extreme board, 32 Gb ram, amd 1950x processor,  Rx480-8G-OC video, 2 Corsair SSD drives.

I was using this in a working Sata Raid0 until I updated the BIOS to 2601from ASUS website. 

Once the update was done the raid disappeared and the raid utility in BIOS is not available.

I have changed all the setting to Raid but no Raidxpert utility to set up the raid with.

Drives are visible when set to AHCI mode But disappear when set to Raid mode 

15 Replies

I presume your Zenith Extreme board is a X399 Chipset since that is the only socket that appears for your old threadripper:

Here is the latest RAID drivers for your Threadripper 1950X and AMD CHIPSET drivers:

From what I can see the last RAID Drivers are from 2021 for your Processor and Motherboard.

There is a newer version from 2023 but listed under the newer Threadripper processors and motherboards. But looking at the compatibility chart it isn't compatible with the X399 Motherboard and 1st generation .

I know that with Asus BIOS sometimes you can't downgrade once you install a certain newer BIOS version. So can you downgrade the BIOS after a certain version. Can you install the previous BIOS version you had before upgrading or it is prevented from downgrading?

I notice in the history of your Motherboard's BIOS versions, BIOS version 0902 included adding support to AMD RAID.

I would open a Asus Support and see if your RAID issue is common with the latest BIOS version or not.

NOTE: Not familiar with RAID by I believe @Vynski is. Maybe he can give you some input.

Thank you for the reply.

I have the drivers all complete , but its the raidxpert utility that would not show up in the new BIOS.

I installed all the BIOS files and tried the setups over and over but no way, even with the tech instructing me how.

I was just hoping someone on here would have a work around. 

I also had an ASUS tech on the phone for over an hour and he could figure it out either, so he escalated it and someone will call me back at a later time, actually appreciated the tech help.

Could you post what the Asus Support says. This might help others in a similar situation. Sounds like a buggy BIOS update.

Yes I will, but up to this date al I have been getting is email looking for more information, repeating in text what the tech on the phone already has, fill out a form with all my computer equipment.

No real explanation or fixes.

Lets face it , I am but one of how many problems to fix, so my importance is not theirs. 


I've run into similar problems when I had the Ryzen 7 2700X.  functions in the MSI MPG X570 Gaming board were simply not compatible.  It's not that they didn't exist, the 2700 was just getting obsolete.  I  still have some compatability problems with my RX 480 GPU.  Need to upgrade when possible.

Famous last words of a RedNeck "Hey Ya'll, WATCH THIS"

I have had no problems at all with my Rogue Strix RX480-8GB-OC.

Yes my system is getting to the end of life, but the BIOS is still getting updates and support, but not as much as they used too.

This is why you don't always want to update your BIOS to the latest version unless you know the new version has something you need.  

As Albert Einstein said, "I could have done so much more with a Big Al's Computer!".

A lesson learned quite a few years back.  I never paid a whole lot of attention when I installed a new motherboard until a BIOS update went south and bricked the motherboard.  As I was looking through the manual is see this fine print that identified a problem when the BIOS was downloaded with a browser other than MSIE.  Not too much of a problem today with the update links built into the BIOS and bypass the browser issue all together.  

If you do happen to download the BIOS to do a manual update, I would recommend using MS Edge.


Famous last words of a RedNeck "Hey Ya'll, WATCH THIS"

I only use MS Edge for most of my  internet stuff , there is one thing I use Google Chrome for and that is so I can remove it when I deem necessary.

You are correct though in your thinking.

My opinion as well

MS Internet Explorer is not same as MS  Edge.

Today, MS Edge is basically a modified Google Chrome, they're essentially the same. Sorry for offtopic, Cheers.

5950X | Micron 32GB x2 ECC OC 3600mt/s CL18 | ASUS Pro WS X570 | PRO W6600 | PRO WX4100 | Fractal Design Torrent | Noctua NH-U12A | CORSAIR RM850
Adept II

This is the response I got from Asus support


This is the system as it was set up plus 2 - 970 EVOPlus NVME 500GB drives


So it sounds like your Asus Motherboard has a bad BIOS RAID chip on it or it isn't working the way it should.

NOTE: Glad AMD Forum Khoros finally fixed the Enlargement of images feature. I couldn't read Asus response without clicking on the amplification feature.

Thanks @Sam_AMD 


If it ain't broke, don't fix it. 

However, other features in the BIOS upgrade may have been needed.  

Do you have the older BIOS to reinstall?  I would go back to square 1 with the BIOS that came with the board when you first got it.  ASUS provides previous BIOS versions on the link @elstaci provided.  Even though the ASUS response that showed the RAID not available could still be due to buggy update software.

You may just have to bite the bullet because it might just be time for a motherboard update.

Famous last words of a RedNeck "Hey Ya'll, WATCH THIS"

once you update the bios to the latest you can only downgrade so far. I am back to BIOS 2201 now and I can only get back one more, beyond that it just tells you it is not a valid BIOS file. I tried this and the support told me also.

In any event this is not a must have just an attempt to accomplish something I wanted to do, the system is nearing it's end of usefulness  and will be replaced in the near future for sure.

Even though support did not help with the original problem I WAS ABLE TO succeed . 

I was able to get the Raidxpert utility to come to life on the latest BIOS. ver. 2601. but have not gotten the M.2 drives working the way I want yet,  but still trying. 

This being an older system I am not adverse to trying stuffin experiment mode. I am pretty much self taught in the workings of the computer world and this is just more education for me. 

I have no formal education relating to computers and enjoy the messing around.

Thank you to all who replied all help is appreciated.

Adept II

Update to this point .

I have installed 3 Samsung 970 EVO plus NVME M.2 2280 drive in Raid0, on BIOS 2201.

This is the stats Benchmark2.PNG