Showing results for 
Search instead for 
Did you mean: 

PC Building

Adept I

PC won't post after installing an RX 7900 XTX

I'm having some trouble with my PC.

I recently bought a new GPU, the Radeon RX 7900 XTX. (Not MBA, but Asrock Taichi)

I put it in my rig, and now it doesn't post. The PC turns on, fans start spinning, everything gets power.

My motherboard keeps cycling between CPU-DRAM-VGA, remains stuck on the VGA led, and then restarts over. Looping infinitely.

The GPU is seated properly, and when I put my old GPU (RTX 2080 Super) into the system, it works as normal. This is the second of these cards that has this exact same problem, so I doubt it's due to the card.

BIOS is updated to the latest version, Tried with 1 ram stick, and with 2 entirely different ram sticks. Also reset the CMOS.

I'm lost here... Anyone have any ideas?

MOtherboard: Aorus X570 Pro
CPU: Ryzen R9 3900X
RAM: G.Skill DDR4 Ripjaws-V 2x16GB 4000MHz
PSU: EVGA SuperNOVA 1200 P3 1200W

Attached is a video of what happens when I try to turn it on

24 Replies

Did you uninstall your old drivers prior to removing the Nvidia card.  It sounds like the system is looking for the Nvidia card and can't find it.

Famous last words of a RedNeck "Hey Ya'll, WATCH THIS"

I did, I used DDU, and pressed the uninstall and shut down option. I put in the new card after that


Since the 2080 works fine I think we can safely OK the motherboard as not the problem.  Everything you have done kind of points to a bad RX 7900 XTX.  I do believe it is time for an RMA.

Famous last words of a RedNeck "Hey Ya'll, WATCH THIS"

This is the second RX 7900 XTX that I've bought that has this exact same issue, it's possible that it's a 2nd faulty GPU, but somewhat unlikely?

What does the RED LED at the bottom of the motherboard that is always lit indicate?

Screenshot 2023-01-06 224343.png

Is that a Power or GPU Trouble LED?

It's the VGA led.

BIOS is saying you have an issue with the GPU card.

Adept I

So, going into BIOS, and forcing the PCI-e lane to 3.0 made it work... odd.

Volunteer Moderator

How many devices are using your PCIe lanes?  Do you have a few M.2 drives installed.  It sounds like you discovered a shortage of bandwidth issue with the PCIe allocation on your motherboard.

As Albert Einstein said, "I could have done so much more with a Big Al's Computer!".
Volunteer Moderator

Here's a good article that discusses the PCIe lanes and how they are used.  One question I have is would your system run the video card in the PCIe 4.0 mode with an upgraded CPU (3900X to 5900X for example).  

PCIe lane support varies between processors.PCIe lane support varies between processors.

As Albert Einstein said, "I could have done so much more with a Big Al's Computer!".

I know this may sound dumb.... but... please try changing your hdmi, display port, dvi or whatever you're using and also, if possible, try using a different monitor before you rma.... just a suggestion. 


forgot to add if you start having issue again 



It would seem to me that it is more problem with your mobo, as it works fine in pcie 3.


AMD Ryzen 7 3700x, Asus Tuf Gaming RX 6700 XT, Asus TUF Gaming x570 Plus, 32gb G.Skill TZ neo 3600mhz, Samsung 980pro 1tb NVME, Samsung 970 EVO Plus 1tb NVME, Lian Li Galahad AIO 240mm, Antec Titanium 1kw.

1) Boot with Nvidia, use DDU to uninstall Nvidia drivers
2) Shutdown, unplug from wall socket, clear CMOS
3) DOH! Forgot: Swap GPU's
4) Restart to Windows
5) Fix BIOS settings on a later boot after getting GPU to run
6) Report what happened

This is a longshot.. But in rare cases you can experience that your gpu will not show anyting on the screen since something is stuck in bios/ram.
The way i fixed a similar issue years ago was to power off the computer and remove the power cable to the PSU. Next i removed the bios battery and left the computer without power all night.
When i insert the battery and boot the pc it worked. Also turn off all other power to your screen and usb hubs and so on.. everything need to power off.

Els another thing some people do wrong is.. If you upgrade to a new PSU then DO NOT use the old cables in the pc.. You need to change 100% of all cables if you get a new PSU els bad things can happen.   Cables from one PSU is not compatible with cables from another PSU since the wiring can be different.  Typical though old psu and new psu cables do not fit into the psu since the slots/pins have different shapes.. but sometimes people somehow are able to install them anyway and well then issues happen.
Oh and when your pc is turned off, try to push the PCIE cables harder into the graphics card just in case one of them is only 99% inserted. DO NOT do this while the pc is on.

Also the first time you install new hardware ( especially cpu and ram )
then its normal the computer reboot 3-4 times without anyting on the screen, be patient if this happen it will auto configure itself.

In other cases the issue can be that the Graphics card did not make good enough contact in the PCIE slot.. so maybe remove and instert the graphics card again and push it in harder and check its in in both the front and rear end of the PCIE slot.
Also in rare cases it can happen that people who build their own pc did not correctly install the metal spacing parts on the back of the motherboard so that the back of the motherboard is touching metal of the case.. If one of these metal spacings is missing then it can be hard to push the graphics card correctly into hte PCIE slot..

ANother thing you can try... this happen 1 time for the +30 years i build computers.
Try to lay your pc on the side.. Push in the Graphics card hard while you turn on the computer
power and then boot the pc.  ( in my case i had 2 graphics cards and sold one of them.. But the buyers computer would not turn on, and it turned out that the PCIE slot and the graphics card simply did not fit perfect together I think reason was the metal spacing on the back of the graphics card made the motherboard bend a little so it did not connect 100% in the PCIE slot..
Anyway try to press in the graphics card a bit hard while you turn on the pc and see what happen... TIP do not use voilence but a firm push is enough.

Adept I

First of all, thank you everyone for the replies.

An update: The card works fine in PCI-e 3.0 mode. I do not have a new CPU to try it out with unfortunately. I am assuming it is some issue with the Mobo in any case. 

The only issue I am running into currently, is that it sometimes gets stuck in a boot loop, but then starts normally. It makes it to the windows loading screen, then freezes a few moments, and decides to reboot the PC. This usually happens a few times, but 75% of the time  turning it off and on again seems to just 'fix' it. 

I've also had a few occasions where I played God of War, and the PC eventually just turned itself off, only to restart. I checked my AMD adrenaline software, and the thing that comes to mind first is overheating. I can also see a difference of roughly 30-35 degrees celsius between my GPU temp, and it's junction temp. I am not too versed in GPU's however, so i am uncertain if this is acceptable or not.

Apart from this though, i have had little to no issue with the card ever since putting it in PCI-e 3.0. It once reset back to PCI-e 4.0, and stopped working immediately. Had to slot in my old card to set the BIOS back to PCI-e 3.0. 

Adept I

Hello Everyone,

I have had the same exact problem with two different 7900 xtx cards, Asrock Taichi and Sapphire Nitro +. My system consists of a 7 5800 X3D with an MSI X570S Ace Max with 32 GB DDR4 3600 CL14, Three M.2's, one with the CPU and two with the Chipset, Power Supply is a Seasonic 1000w and the video card I've been using is a Asrock 6950xt OC Formula.  This combination has worked flawlessly with Windows 10.  So the same exact issue when switching over to either of the 7900 xtx cards as seen in this post. System would not boot at all, I followed the advice here and other places and change the PCI-e lanes over to 3.0 and had the system boot. Note, I did a DDU before swapping cards. While I was checking a few things got the black screen of death, upon rebooting the scrolling Windows "Dot Circle" froze. Looks like Windows had tried to install a driver, not sure?  I then downloaded the latest 23.4.1 Adrenalin drivers did another DDR from safe mode, unplugged the internet connection and it booted. Installing the Adrenalin driver it again had the same unstable actions, crashing and slowness. I then did a fresh install of Windows 10 and had issues even during the installation process. Put the 6950xt back in and no problems at all. There has to be some sort of issue with either the x570 chipset and or the compatibility of these 7900 xtx cards with AM4. I've seen this reported from users with other brands as well, Gigabyte and Asrock. Please help if you can as I really don't want to go back to team green.  


You didn't mention it, but I assume your using 2 different power cables on both of those cards 6950 and 7900.

Is it giving you a POST error?  If it is not giving a POST error then Windows 10 may be the source of the problem.  I will check the Windows forums and see if others are having any issues with the 7900 XTX card.  Your CPU, motherboard, and I would assume the RAM if its GSKIL or Corsair are top quality.

Famous last words of a RedNeck "Hey Ya'll, WATCH THIS"

I used the same power cables that were used with the 6950xt OC Formula, 3 x 8 pin. All components are top quality. Ram is Teamgroup Xtreem 3600 DDR4 CL14.  Thanks I appreciate your help.  Postcodes cycle and end on 94 and then loops again.



I think you can rule out a thermal issue since the problems start before you even boot into Windows.  Have you cleared the CMOS (remove the battery and disconnect the power plug from the wall)?  What was your latest BIOS update?

As Albert Einstein said, "I could have done so much more with a Big Al's Computer!".

Hello, yes to all your latest questions. I’m using the system quite normally with the 6950XT back in. I really don’t want to upgrade to AM5 as that platform has its own host of troubles. I think seeing that I’m well within my return window at MicroCenter, that I’ll just return this Sapphire card. Perhaps I’ll try a 4090 or even 4080? 

Sure enough replaced the Sapphire Nitro + with an MSI Suprim X 4090 and no more issues. This doesn't make sense at all. I would have been very happy with the 7900 XTX. 


Everything I'm familiar with on the error code 94 is network related.  I assumeed that you are running this on your home desktop.  There are specific registry fixes for the error but you need to identify it in more detail.  Because making the wrong registry tweak could crash the system.  If it is your home desktop. Have you tried a reinstall of Windows.  I'm guessing, YES you did.  The code 94 is a result of corrupt registry error associated with some software products.  That is why I asked if you had performed a clean reinstall.  You would need to wipe the disk of all data to eliminate any remnants of the cause.  Check to see if your motherboard chipsets or setup is installing what I call "trash software" (promotional crap you don't really need).  When you run your chipset setup and GPU setup, only install the drivers, period. 

Famous last words of a RedNeck "Hey Ya'll, WATCH THIS"
Adept II

I have had so much issues with my 7900xtx, after 3 month i figured it out why I had boot issues, bsod and no posting. My mobo had pcie set on Auto, not sure what pcie gen it was running, but when i manually switched to pcie 4.0 then all my issues was gone.