cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

ikanham
Adept I

RX 6800 XT glitch issue

Hello, I hope it's not already posted, Icheck and it seems not
Describe your system:

AMD Graphics Card Make & Model
AMD RX 6800 XT
Desktop or Laptop System
Desktop
Operating System
Windows 10 64bit 20H2 Build
Driver version installed
Radeon Software Adrenaline 20.11.2
Display Make and model and connection/adapter in use, resolution, and refresh rate.
MSI G24c4 1920x1080 @144Hz DP
MSI G24c4 1920x1080 @144Hz HDMI
MSI MAG241C 1920x1080 @144Hz DP
CPU/APU Make and model number
Ryzen9 3900 X
Motherboard Make & Model + Bios Revision
Asus X570 Prime Pro BIOS 3001
Power Supply Unit Make & Model + Wattage
Corsair 80+ Gold 750W Rm750x
System Memory Make & Model + Frequency
Corsair Vengeance pro 3000MHz CL14 4*8GB

Describe your issue:
I received my 6800 XT this week and since installing it, things are become more and more worse and I can't find the exact reason why. Here's a list of the issues encountered :

Random square appearing on the screen (picture : https://i.imgur.com/cztrRgs.png )

Precedent issue, but on all the screen, causing a freeze, then a driver timeout and black screen. (Never had a BSOD)

Troubleshooting: I've tried reinstalling the drivers and windows (twice actually), updating to the latest optional ones, and fix the TDR issue without success.

I sent a ticket to AMD about this case, but I would appreciate if anyone has the answer for this issue, even if it means RMA'ing the GPU

Thank you

10 Replies
BillyFeltrop
Journeyman III

Re: RX 6800 XT glitch issue

Update BIOS and do a clean driver re-install. Otherwise you may need to re-install the operating system.
May be it should an temperature issue, so try increasing the fan speed but a better solution is lowering the voltage. amd gpu , and cpu too , are known to be over-volted from factory.

I hope this will 2nd option will work.

PC Hardware Specialist
0 Likes
forykw
Adept II

Re: RX 6800 XT glitch issue

I have just returned mine for testing, which looks very similar to what you report.

I have an intel CPU+GPU and using iGPU (on) with the HDMI from the mainboard (instead of from the GPU) I could go above 24 hours of work with the card, but eventually, it started to crash (youtube videos become weird, like greenish and there is some out of sync with my 5K screen).

Using the DP directly from the card, usually after 7-8 hours the screen freezes and nothing works (mouse, keyboard, nothing). The only way is to hard reset the PC and then it will boot normally.

I have latest drivers from AMD but I have tried other version (older) and still the same problem. Without the GPU card, I have no problems using the exact same hardware. I was previously also using another model of AMD card and it had no problems.

Note, that initially the card (when firs plugged), it ran for a couple of days straight 24/7 without any issues. Then after the first freeze, it never worked for more than 10 hours straight without freezing. Sometimes (very rare) it would freeze again 5 minutes after booting.

0 Likes
forykw
Adept II

Re: RX 6800 XT glitch issue

None of that worked.

I suspect there is either a problem with the RAMDACs or the buffer that feeds them either directly on the ports they work with or via the virtual buffer when going to the CPU GPU for example (as in my case with the iGPU option from intel).

My card was an overclocked version, but switching to the "quiet" BIOS did not change a thing.

The temperature was never an issue (always bellow 60C). Tried multiple version of drivers. Simply would freeze.

Later in the game (this was a 20 days experience), I noticed that before the freeze there were some glitchy behaviours happening... like some sort of areas of the screen (not the entire screen) would flicker or distort like when you have interlaced resolutions 1080i ie.

0 Likes
xlox
Miniboss

Re: RX 6800 XT glitch issue

hi,

it appears sometime on mine too, just 10 minutes ago,  it disappeared when i unplug my other displays

but still can't launch a game ... will try to reboot now... without the others displays ..

and this happened to me already sometime ago disappeared after changing psu cables (but apparently it was not related) ... and it worked fine for days (gaming, multi display etc)... just i updated drivers yesterday from 21.1.1 to 21.2.1 ... don't know if it as something to do either ... didn't had the problem while 21.1.1 were installed i think ... will have to check that

0 Likes
ikanham
Adept I

Re: RX 6800 XT glitch issue

Well, it seems update 20.12.2 made my problems disappear and... the last windows update made it appear again. It seems like the number of monitors doesn't matter in the frequency of the issue happening.

Even with the latest driver update, things are still not good so I guess it may have been because of the OS update (or just a coincidence). The issue only comes up when the gpu is under load, so I guess it doesn't like the excessive charge it's been put under?
Will update when I have more things to add, but it is definitely awkward that it worked for almost 2 months without a hitch just to do this again.

0 Likes
xlox
Miniboss

Re: RX 6800 XT glitch issue

i have rma my gpu last week .. couldn't start any game anymore without it to crash ... had artefacts on desktop too ... I have a 6900xt for now ... no problem for now with this one ... waiting to get back the 6800xt to see if it happens again but i think there was deffective memory because of this artefacts

0 Likes
uymau
Journeyman III

Re: RX 6800 XT glitch issue

Any updates on this? I'm currently having the same issue as well

0 Likes
Shiba_Inu87
Journeyman III

Re: RX 6800 XT glitch issue

I too would appreciate any update. I have this issue only when playing a specific game (COD Coldwar)

0 Likes
ikanham
Adept I

Re: RX 6800 XT glitch issue

Sorry for the delay

After I sent my card for RMA and was sent another one, never had any trouble again so I guess the card was a faulty one.

0 Likes