cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

cplifj
Adept III
Adept III

Idle 2D clockspeeds sticking at max on multimonitor setup. possible fix.

Jump to solution

This has been an ongoing issue, but i have tried alot and found something that is reproducable and fixes

the idle clockspeed on the memory being stuck at max of 1250MHz instead of a cool 150MHz.

THE thing that does the trick is following: when i check the windows properties of my monitors it states for all three monitors

they are running at 59 Hz , instead of the usual 60 Hz. When they are at 59 Hz the clock is GUARANTEED STUCK at 1250MHz.

Now i change those refresh frequency settings in windows to 60 Hz , one by one. Nothing happens TILL i set the third and last to 60 Hz

AND SHAZAM. The idle clockspeed immediatly drops down to 150 MHz again....

Back to you AMD engineers.

This fix works every time for me. Tested it with several clean installs in succesion.

works with windows stock 16.6 whql driver, as does with 17.4.1 non whql.

1 Solution

Accepted Solutions
amdmatt
Community Manager
Community Manager

Re: Idle 2D clockspeeds sticking at max on multimonitor setup. possible fix.

Jump to solution

It's still not a bug though.

Multiple displays with different resolutions, refresh rates, timings and or using different display adapters/connections requires more resources from the GPU, this can move the GPU up into the next memory clock state to compensate and avoid issues such as flickering or corruption.

If all displays are identical, using the same resolution, refresh rates, timings and using identical display adapters/connections then the GPU may be able to run two or more without moving up into the next clock state. It can vary from Bios to Bios and GPU to GPU, but the expected behaviour is increased clock speeds so this is not something we can change.

View solution in original post

0 Kudos
3 Replies
goodplay
Esteemed Contributor III

Re: Idle 2D clockspeeds sticking at max on multimonitor setup. possible fix.

Jump to solution

So Win10 does a diag first, then decides settings.

If an AMD prob.,then fine(sort it ?), but W10 does have known issues with high DPI(ongoing fix ?).

I heard/knew about the  59-60 prob. long ago, easy fix(as you say, change it).

As with any new OS, learn how it works(do you want a link to 1300+ Tutorials ?)

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3200c16d kit, Aorus nvme gen4 1tb, Nitro+RX6900XT,
0 Kudos
amdmatt
Community Manager
Community Manager

Re: Idle 2D clockspeeds sticking at max on multimonitor setup. possible fix.

Jump to solution

It's still not a bug though.

Multiple displays with different resolutions, refresh rates, timings and or using different display adapters/connections requires more resources from the GPU, this can move the GPU up into the next memory clock state to compensate and avoid issues such as flickering or corruption.

If all displays are identical, using the same resolution, refresh rates, timings and using identical display adapters/connections then the GPU may be able to run two or more without moving up into the next clock state. It can vary from Bios to Bios and GPU to GPU, but the expected behaviour is increased clock speeds so this is not something we can change.

View solution in original post

0 Kudos
nemo2607
Journeyman III
Journeyman III

Re: Idle 2D clockspeeds sticking at max on multimonitor setup. possible fix.

Jump to solution

is this good for your position on consumer and the environment.

i have a rx 5700 xt , atm high end on your gpu list, have 2 exact same monitors, and idle power consumption goes up from 11Watt to 35 Watt on wattman display- causing from mem clock goes up from 100 all up to the 875Mhz max.

thats just poor work, and u absolutly should bring engineering in it , for at lest the matter of our environment.

that just can happen, all over the place there is emphasis on environmental protection and u cant programm this behavior. thats nothing else but poor engineering, sry about that.

so better make other responses, and even give a chance to manual correct this big mistake, 

the other thing i saw is the consumption even goes up when i switch one monitor in 2560x1440 from 60 to 75Hz the memclock also goes up to 875mhz