cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics

xdevgamer
Adept I

Disaster with my 5700xt 50th Anniversary Edition Purchase.

I purchased a 50th anniversary edition and the shipment was delayed for two days for no reason. Tracking reported it was close to my house but it was held for two day buy the carrier. When the gpu arrived it shuts off my whole computer after a few minutes of play every time. There are no stats showing in wattman, no voltage, fan speed, clock speed and all graphs and gauges are disabled. GPUZ and afterburner have the same problem. AMD still hasnt gotten back to me after reporting it by email. I had to call in to customer service and they where terrible. I could barely hear the person because of static on the line and strong foreign accents. They had no technical knowledge and could not help me. They would not process an RMA replacement until I convinced them to. (dont ask, SMH) then they claimed because of problems with their system they could not process my RMA and would get back to me later. They still haven't gotten back with me. They put me on hold when I asked to speak with a manager and then told me I cant speak to a manager. So right now I have paid $480 ($450 + $30 tax) for a dead 5700xt 50th AE that I cant use, cant return and cant replace because of AMD. What can I do.

System specs:
4.5ghz i7
16GB ddr3 2133
850 watt PSU

0 Likes
5 Replies
osirismelb
Adept III

Did you download the latest driver 19.7.2 which was released today?

Fixes a lot of these issues.

0 Likes

Yes, I tried the new .2 driver, seems to only make the GPU behave worst. Now Im getting half the fps I was before and when the GPU shuts down after a few minutes it is extremely hot to the touch, but the fan was barely audible while playing. I believe a faulty factory bios flash may be the cause of all this, not the driver. AMD support got back to me so it looks like Ill be able to replace it. Although my return shipping label arrived  peeled off and missing in the box. Thats strange. Hopefully the next one works and gets to me quickly as I am a developer and I bought this GPU for work.

0 Likes
ykzcs
Journeyman III

Did you try DDUing (both for AMD and Nvidia drivers)? I had issues moving my 5700 XT into a computer with previously-installed Nvidia drivers on the hard drive and I did a DDU on both graphics and then clean-installed the latest .2 driver for Radeon and my GPU is working fine

0 Likes
xdevgamer
Adept I

So, I finally recieved my replacement 5700xt 50 AE in the mail. Turns out this one had the same exact issue, so its likely that whatever is going on, all these units share this behavior when paired with my motherboard. Instead of accepting that my motherboard is just not compatible with this GPU I started tweaking around with motherboard bios and GPU driver settings. Several hours later I actually discovered an unlikely fix. I found that if I overlock my freesync monitor to any refresh rate higher than the default setting then all of the GPU statistics become available in wattman and GPUZ and the gauges and graphs are enabled. This was a very weird experience that caused a lot of trouble but Im glad I could figure it out. I hope this helps anyone having a similar problem. 

0 Likes

Hi xdevgamer,

Yes it is an issue with HDMI and Refreshrate. I don't think it's a freesync issue however.

If you can, you could resolve this issue by going to Displayport and turning up the RR there.

0 Likes