Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Journeyman III

XFX RX 580 8GB Screen Flickering and Message "Default Radeon WattMan settings has been restored due to unexpected system failure"

Hi, I recently got an XFX RX 580 8GB version, and every time I play games, the screen becomes black, and most of the time the monitor says "No Signal", and after restarting AMD Software says "Default Radeon WattMan Settings has been restored due to unexpected system failure."

tho the CPU fans are still spinning, but sometimes when it black screens, it comes back without it needing to restart but the graphics are messed up. There are some pink/white cubes, i caught one of them on camera, but there are many more. What do I do? 

Btw I bought it as used, and it doesn't have a warranty.


CPU: Ryzen 7 2700X


PSU: LC-Power 600W

Monitor: AOC 2470W

Windows 10 Pro Version 2004.

4 Replies
Adept I

I have a similar setup; Ryzen 5 2600 and an RX 570 8 GB and 600 watt Coolermaster PSU. And, of course, Windows 10 64 bit. Just like you I had the same problem. After scouring the internet for hours and hours for a solution, it became clear that I was not the only one with this issue and that it's been going on for a LONG time. What you described is EXACTLY what was going on with my system, which annoyed the hell out of me because I got my system new. I though I had a bad graphics card. I'm a pretty advanced user and know my way around a PC. There were also a few other issues, such as FanXpert 4 crashing and a few other annoying issues which all seem connected.

As a side note, my son has the exact same RX 570 but an i7 and does not have this issue. It seems to be an AMD only issue.

Everything I tried was pointless. Fresh Windows install didn't help. Newest drivers, older drivers, nothing. The issue just kept happening. I went through the forums here and there were suggestions about increasing the power settings on Wattman to between +20% and +25%. I did that and it kind of helped but it didn't really fix the problem. One poster said that switching out to a different monitor solved the problem for him but I'm not really buying that one. If it worked for him, that's great. I tried it anyway because I was getting pretty frustrated and was willing to try anything by that point.

Yesterday after yet another episode such as you described, I came back to the forum here and found the official advice and went through it literally step by step. That was also annoying as I had done pretty much everything on the list already. Then I got to a part where it mentions about overclocking instability. My system isn't really overclocked at all. The processor was set to performance mode in the bios, clocking in at about 3.8 GHz. GPU and RAM were not overclocked at all. Still, I reset my bios anyway and made sure everything was either at stock speed or even slower as my RAM defaulted back to 2133 MHz instead of the 2400 that it's supposed to be. And what do you know? It happened again, right after boot up and opening Firefox to actually come back to this page. Firefox opened up and as I was switching tabs, there were the pink blocks, freeze, black screen and Wattman error. It's at times like that that I really just want to smash something.

Anyways, I opened up Radeon settings (on the newest version) and reset everything there as well. That's when I saw the button to open up Ryzen Master. So I clicked it. I wanted to check the setting there. Maybe, just maybe there was something there that I had missed. After checking a few things and clicking apply, I was informed that any changes would take place after a restart. Okay, sure. Let's do that. And what do you know? The system totally froze. It never restarted. It just went black screen and stayed there for 10 minutes. I had to pull the battery out of the motherboard and wait a few minutes. That was actually the second time that happened which is why I knew to pull the battery in the first place. Finally I got the system restarted. I went to add/remove programs and uninstalled Ryzen Master. Guess what? Issue solved. No move pink blocks. No more wattman crashes. No more mouse not being recognized at system start up (yeah, that was a thing). I even get slightly better graphics performance on a few games and even FanXpert 4 doesn't bug out on me anymore.


Bottom line TL/DR: If you have this issue and you have Ryzen Master installed, you should try removing it. It solved the problem for me and I've had it since October 2020. As a matter of fact, my PC has never run better and I finally have the performance I had been expecting when I put the machine together.

Adept II

  1. Check you PSU PCI-E and the pins for any damage
  2. Monitoring your sensors temp gpu when you running a gpu stress test (if u see something more than 100 c there is you problem)

Everything was new, out of the box in October when I put it together. Case, 600 watt PSU (both Coolermaster), board, Ryzen 5, AMD ROG RX 570, every screw and wire. All new. I inspected the stuff closely before I put it together. I've run multiple stress tests and never reached anything about 77 C.


I can certainly try another test. Which stress test do you recommend? FurMark?

That said, since I uninstalled Ryzen Master, I've gone 2 days without the crash and wattman message.


Decided to go with FurMark and just ran it for slightly over 3 minutes at 1920x1080 with 2x MSAA. Frame rate could have been a bit better, I guess but still average 41 FPS. GPU Temp peaked out at 71C. The fan spooled up just a bit more and temp dropped back to 70C, where it stayed. GPU pulled max 150.5 Watts. All of that looks exactly like it is supposed to. The rest of the system stayed pretty cool as well, with the CPU hitting only 42C.