Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Journeyman III

XFX Radeon 5700 and Gigabyte Aorus Elite Wont Post

Having an issue with brand new 5700.

Basically the system wont post, it appears to start but the display stays in power saving mode. Occasionally the system will start and boot to bios. when it does however the bios oddly shows to the CPU temp to be -55c. When i try my older GTX970 in the system, it boots and works fine, the CPU temp in bios shows a correct reading of around 25-30c.

I have tried manually locking pcie gen mode to gen 3, the motherboard bios has been updated to revision F4i

i have tried the other pcie slot. My next attempt now is going to be to fire up my old socket 2011 board and try the card there.

I am currently thinking its an issue between the motherboard and graphics card being incompatible.

Does anyone else with the same setup been able to get it to work?

Thanks for looking.

System Specs

Ryzen 5 3600

Gigabyte Aorus Elite

Tforce - 16GB 3200mhz ram

XFX 5700

Intel 660 series NVME 1TB

1 Reply
Adept I

Try to put manually a force on card across a pcie slot, so u hear click. I had similiar problem but doing that second time helped me and system started normally.If u do that write me if u can manage driver for Radeon in Windows so it work normally.I can only use Stanard graphic driver with shitty res beacouse normal driver wont work