Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Journeyman III

Why do my RX-5xx cards run in PCIe 1.1 mode on my AMD platform motherboard?

This is the system:

Sapphire PULSE RX 590 8GB or XFX RX 570 RS 8GB (1st x16 slot on the board)

Asrock 970A-G/3.1
FX-8350 @ 4.6GHz
2x8GB DDR3 1866 RAM
PCIe x4 M.2 SSD (in M.2 header)
Rosewill H.I.V.E. 750W PSU
No other board slots are being used.
All temps are normal.

I Tried both my RX 590 and RX 570 (individually), and they both remain at PCIe 1.1 while running Furmark and GPU-Z Render Test.* Yet, two of my Nvidia cards (GTX 970 & GTX 1050 Ti) switch to PCIe 2.0. The Asrock AMD platform apparently doesn't like AMD cards!?

* only showed RX 570 results for an example, but the RX 590 was identical.

7 Replies

You're not losing any performance if that's what you're worried about, both because neither GPU is bottlenecked at PCIe 2.0 x8 (equal to PCIe 1.0 x16), and because your CPU is not fast enough to unleash your GPU's full capabilities in some CPU heavy games.

Does Radeon Settings backup your reading? And also did you perform a clean driver install using DDU between your nVidia and AMD card installations? Clean Install AMD Graphics Drivers


Thanks for the reply, but that's not really my question.  I want to know why the card only runs at v. 1.x (2.5 GT/s) instead of v. 2.x (5 GT/s), and what I can do to fix it.  I have verified the speed with other apps as well, but I'll do Radeon Settings when I'm back at the machine just to add another one.


As you can see, my current bus setting is indeed only PCie x16 even while running Furmark.  That indicates v. 1.x

So that agrees with all the other apps I've tried.

Radeon Settings and Fuemark.jpg


If your chipset drivers are fully up to date, then I would suggest talking to ASRock or posting in their forums if it really concerns you, but like I said you aren't losing any performance, so it's really nothing to worry about.


And I can say that based on testing TechPowerUp did with a GTX 1080 which is in an entirely different league than the RX 590, faster by well over 50%, and even at that level PCIe 1.1 x16 yielded 94% of the performance that a fully unrestricted interface (PCIe 3.0 x8/x16), which means a card which is half as fast is not in any way restricted in performance at PCIe 1.x x16. Your CPU, which is extremely slow by today's standards, only 75% as fast as the low end R5 3400G and half as fast as the upper mid range R7 3700X, is a much larger hindrance to performance.


Worry about?  It's about the fact that something is wrong!  Not whether or not my CPU is weak or not.  Yes, I will contact Asrock, but I thought I could get some help here.  The board does not switch to v2.0 with any of my AMD cards, while it works fine with all Nvidia cards.  AMD cards I have from HD 5000 series backwards do not even display, while even my ancient Nvidia GTS 8800 produces a display.  So, I'm stumped as to which is at fault; all AMD cards, the ASrock AMD-based board, or simply some obscure setting.  And yes, all drivers are updated to the latest available as is Win 10 x64 (1909) itself. 



Did you resolve this?

I'm seeing the same thing in HWinfo with an Asrock 970 and an MSI GeForce 3060 TI - showing as PCIe 1.1 when I'm expecting PCIe 2.0.

Updated Bios, think my Drivers are up to date.