Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Journeyman III

Vega 64 keeps on crashing on Windows 10

I recently just installed Vega 64 into my Windows 10 PC.  However, upon completion of display driver installation, my Windows desktop keeps on stuttering badly.  I look up the task manager and noticed that csrss.exe is using up to 99% of my GPU 3D resource.  The usage is not consistent, keeps on fluctuating from 0-99%.  Which renders my PC to be inoperable.  Once a while Wattman will crash complaining that default settings have been restored due to unexpected system failure.

It only happens when I install Radeon Vega into my system.  I tried both Vega 64 and also Vega 56, same issue.  I even tried different graphics drivers from AMD, same issue.

However, if I install Nvidia GPU to the same system, no such problem.  And I did use "display uninstaller" to remove all GPU drivers prior to installation.

Anyone has any idea what's happening?

General spec of my PC:

Windows 10 Version 1809

Intel 4790K CPU

Gigabyte Z97 Gaming 7


Samsung 960 EVO SSD

10 Replies

What power supply are you using? Please make sure to use two separate cables with either Vega card also. Display Driver Uninstaller should only be used in safe mode after the graphics drivers have been removed with AMD software. When installing new drivers, select Clean Installation when prompted.

I tried with a more powerful power supply (1200w) but still the same result.  I have done clean installation with the driver.

Any other suggestion?  Thanks.

Adept I

That motherboard only has one pciex16 slot. Make sure you are plugging the vega into that slot.


Yes, it was plugged into the first pcie x16 slot.

I somehow think it is software related, either Windows 10 or drivers (but I have tried a few drivers).  Just not sure what went wrong.

The same GPU works fine in another PC.


Have you tried tracking it with Autoruns or MS process explorer ?

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, Aorus gen4 1tb, Nitro+RX6900XT, RM850, Win.10 Pro., LC27G55T..

Not sure how much tracking it with MS process explorer will help?

I know that "client server runtime process" is the one hogging up GPU resources.  Will the MS process explorer tell me the reason behind it?

Journeyman III

hi (my english is not very good but i try my best, sorry for this)

i have a quiet similar problem, my pc worked fine for 2 yeahrs but since 2 days no more...

was starting the PC and frezed in inmiddle of the windows loading screen

first i thought it was my SSD and had a problem with windows and so i reinstalled windows!

the reinstalling windows helped! i was on a fresh and new desktop and could do installing an other browser and so on BUT...

downloaded Radeon drivers ok, and in middle of the installation, the screen went black and Computer was still running and does nothing and screen still black

reinstalled windows again and tried to install an older driver version... same problem, and i dont get it, what kind of a problem could it be, software ? graphics card ? mainboard ?

before i had this problem it was all ok, the temps... FPS in games, no problems but one night later i have this problem

hope it is quite the same or nearly the same problem and hope for help :3

p.s. i only remember that i have only played some rounds rocket league and downloaded an Blizzard Overwatch update before this happened on next day


I think your problem is different than mine.  For me, whatever Nvidia gfx works fine but not Vega 56 or 64.  I tried both.

I have verified that both Vega 56 and 64 are working fine in another PC.

But I lazy to reinstall Windows to try again.  Too much work for me.

Journeyman III

Srorry for my bad english...

I have the exact same probleme i update from a sapphire r9 390 to a rx vaga 64.

Clean instalation without driver no problem but after driver instalation instant crash the only driver i get to work is 19.1.1 all newer didnt work. First i ordered a second RX Vega 64 because i thought the first is damaged but no same problem on the second.

Windows 10 x64

Ryzen 7 1700x

Sapphire Nitro+ RX Vega 64 

16GB Gskill Tridentz on 3200MHz

Whats the problem with all the newer driver plz AMD fix this.


I'm experiencing the same problem and it's driving me nuts. It's a crapshoot every time I boot my machine.

I read it has something to do with the voltage dipping too low or something like that.

When this happens the power gauge on the card goes to full power and then a crash happens. I get about 30 seconds of being on the desktop and then the Wattman crashes occur and eventually a full system crash happens.