Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Adept I

Scaling problem - fullscreen games at lower resolution in small window, top left corner


The problem is pretty hard to explain shortly, so I've attached a picture above. I'm using an ASUS FX505DY with a Ryzen 5 and RX560X, native resolution is 1080p. I want to play games at 1600x900 as I don't like 1080p on such a small screen, and to maximise FPS. I've done all possible configurations of GPU Scaling in the Radeon Software, configured high DPI scaling settings and compatability, text scaling, driver cleanup, multiple restarts - nothing. And this happens for every single game, no exceptions. 

Any help would be greatly appreciated as I cannot use the laptop like this.

16 Replies
Journeyman III

I'm having exact same problem on Lenovo S340-14API with Ryzen 3500U and Vega 8 integrated card. No matter the setting of GPU scaling, it always seems to go to the left corner surrounded by ugly black bars from three sides of the screen if the game isn't running at full 1080p resolution.
I already tried all the solutions I could find online, from reinstalling Radeon driver, to reinstalling whole Windows, and nothing helped.
Changing windows desktop scaling also doesn't fix the issue, despite a lot of people claiming online it's caused by that.

Only temporary solution I could figure out, is connecting the laptop to a TV with an HDMI cable... on which it for some reason is able to scale the games correctly. However needing to connect external screen like that kinda defeats the purpose of having a laptop...


set scaling to 100% as many games have issues with that

if the game does not support your LCD natively there is not much that can be done other than ask the developer


Nope, it doesn't work(I mentioned trying the usual solutions).

However I managed to solve the issue another way. I installed older AMD drivers and DIDN'T install Radeon Settings. For some reason that immediately caused the scaling issues to stop, and games are now properly stretched to full screen regardless of resolution.

Seems to me like it might be some conflict between either newer drivers, or Radeon settings themselves, and Windows 10 new update.

Hopefully it helps the original person who asked the question too!

EDIT: Simply installing older driver(19.5.2) seems to fix the issue. Radeon Settings also works fine with that driver.


I have also found older drivers can be more stable 

not sure why things get broken with updates


I've also rolled back to the last drivers and it's working again. Super annoying as the COD:MW beta requires up to date drivers to play, but at least I can play everything else now

Bro, you have no idea how much time I’ve been looking for a fix to this problem... I bought a laptop that played games in the top left corner at lower resolutions, and I’ve tried so, but so many fixes and none of them worked. Until I found this thread. Thank f*cking god I’ve stumbled upon this post and saw your reply, I freaking love you.


try alt-enter and see if that will bring the game to full screen


It's already in full-screen so doing that just puts it in windowed mode


Another person with the same issue: 

Journeyman III

I have the same problem with many older games like Touhou and even newer ones like Megaman 11. I'm currently using the 19.9.2 drivers, and don't want to install older drivers just because they could create even more problems, and I don't want that. Any news for fixes in future updates for that problem?


It was partially fixed in 19.9.3, update your drivers

I've updated them, and It fixed my problem for both games I've mentioned earlier, as you said. Thank you for the notice.


leapg wrote:

I've updated them, and It fixed my problem for both games I've mentioned earlier, as you said. Thank you for the notice.

I found using my panel at its native resolution was the least problematic for various games

Journeyman III

I have the exact same problem while playing GTA V... but I have the newest MacBook Pro, which has only received one driver version and that's it, there are no older drivers available for me to downgrade to. Has anyone found another solution for this problem?

The only workaround ive found was using the custom radeon drivers from BootCampDrivers, not sure if linking to the is allowed but if you search that in google they should come up as one of the top results. Just use the modified amd blue 2020 drivers and it should fix your issue until AMD comes out with an official solution.

Journeyman III

(notebook/dual graphics users) 

For me, forcing Intel app scaling override worked... 

In the Intel Graphics Control panel (Desktop, click RMB > Intel Graphics Settings > Display > General Settings @ Scaling) 

- toggle "Override Applications Settings"

- hit "Apply"