Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Adept II

RX580 Zero RPM mode not working after 18.12.2 driver install

Since installing 18.2.2 driver (Adrenalin 2019 Edition) for my Gigabyte AORUS RX580 8GB, Zero fan mode is not working any more. I tried resetting fan control but it just won't work. Even when all GPU settings are set to factory default, Zero RPM is not working and my fans are always on. Before that driver update, it was working fine, fan would stop when hitting certain temperature.

PS. I do not use any other software for GPU control beside original AMD Radeon Software.

Is this a known bug that will be fixed soon with new driver release? Or I can do something in GPU settings?

EDIT: Corrected topic title

22 Replies
Adept I

Some extra information:

* The driver in question is obviously 18.12.2 - *not* 18.2.2

* This behavior happens the moment you do *anything* in Wattman - the zero RPM switch has basically no effect on a RX580 (asus here)

* There is also a lower limit enforced on the fan RPM curve which is way too high - 35% on my card. The option should be there to override any "bios defaults" or "safe limits" - always assume card manufacturers are incapable of assigning sane defaults.

(why introduce a zero rpm switch anyway, when you can have that behavior with a fan curve that goes to 0?)

I rolled back to 18.9.3 because the noise was driving me insane (which is also less than ideal because the default fan curve sucks - but at least "zero rpm" works up to 55°C)

Adept I

I have same issue with Asus Strix RX 580 OC. Dosent matter what settings i change, zero rpm stops working and minimum i can set at fan curve is 40%. Anyway what i did is that i used DDU uninstaller and removed drivers, than reinstall them and zero rpm works again. But u cant touch any settings at wattman or it will stop working again.

Adept II

So I assume we all wait for next driver release. Knowing AMD it will be probably within next 30 days

Journeyman III

Hello to everyone!

I have the same problem with my RX 580 asus strix OC 8G. Dont try to change Wattman settings until the new driver. For the moment i have a solution for my asus strix and i believe works and with Gigabyte's software the same. The asus tweakII software is a good program but only to curve fans,  never try too overclock from there is unstable. I agree to reinstall AMD adrenalin with ddu uninstaller for the moment, a fresh installation always is better.

MSI Afterburner can do a custom fan profile that can deal with issues

I use a profile of 10% at low load and 100% above 65C

Journeyman III

They sent Adrenalin 18.12.3 today 12/19/18  and .....

It does not work zero rpm! in wattman


Oddly Zero RPM worked fine when I installed 18.12.2 but when I updated to 18.12.3 it broke with minimum 35% setting. So I went back to 18.12.2 and it is still broken. Maybe I didn't notice it before but having same problems with my Vega 64


The issue is recognized in the "known issues" section of this new release though, so still not giving up hope

Journeyman III

Same problem with RX580 sapphire nitro +.

Now i'm back to 18.11 in order to achieve zero rpm (with 18.12 the min was 19%)

Adept I

Same with rx590 nitro+ from saphiere.. first installation was beautefull... then i update to 18.12.3 and works well too. 19.1.1 destroeyd it. But its a littel diferent by me. When the Heat goes above 48-49 degres the system crashed. So by me its the temp on the gpu. Not logicel i think

Adept I

Gigabyte AORUS RX580 8GB here, installed 19.1.1, here is the result


I can say there is some improvement as it does stop, but for very sort time and I am not sure if it is temperature related.

In any case the temps are way below 60 and there no activity on the GPU - the two spikes are me taking the screenshots.

The above behavior would drive me insane - fan ramping up and down every few seconds.

I was wondering what the "logic" would be, in the above screenshot it seems to be voltage driven, where the period of 0 rpm coincides with a dip in voltage. Or this is the effect instead of the cause...

Either way; I don't get why "zero rpm" is a toggle with no user control. A customizable fan curve that goes to zero is a much better solution


I have get it run stabel with that settings

AMD RX590 Nitro+ Special Edition - How to FIX Wattman Crash the System - YouTube

I cleand, unsinstall, update, downgrade and i am one step bevor i take my backup and set it too point zero.

Ther must a Setting in Regestrie or a File that have data from Wattman. When Wattman was used one Time and changed one thing, its broken.


19.1.1 didn't bring fix in my case. After driver install, fan went to zero RPM. But as soon as I changed temp/RPM curve, it is not going to zero RPM any more.

mnaydenov​ as you have the same GPU as I do, what's your average temp during heavy gaming? And do you use stock temp/RPM settings or you change it? Also is you GPU in closed and well ventilated case? I'm asking cus my GPU goes up to 75+C when stock settings are used but I like to keep GPU to 70C max. and that causes fans to spin faster and produce more noise


zeroRPM i think and many other Gus too has a BUG!

I have setup Profiles... one for Desktop and Work with Adobe on low Fan Settings. Together with my CaseFan its by normal work at 39 up to 41°.
For my Games i Setup it very Hard... 31° 18% and a strate Line to 65° with 100% Fan Speed. With HIGH Settings i run stabel at 51° !

Only disabel zeroRPM and setup  your Fan curve

When you setup only 1 Setting zeroRPM will never works again. I think Wattman put some Data in the Bios that create the Bug..... have fun!

stilo2​ Sadly running on stock, factory OC is unstable and I run it at 1340. I have down-volted to 1060 and is a good experience overall.

I have a custom curve to keep it quiet targeting up to 77C and up to 1500rpm (~40-45%). Ventilation is very good as I have a 140mm low rpm side case fan.  That fan is what makes it all possible, without it reaches 80C with my curve and throttles. Also, I use Chill ATM as I play Grim Dawn and don't need full fps all the time which makes it all inaudible (never reaches 1500rpm).

This is my scenario ATM.

I don't run stock (except for the desktop) because, as said, it is unstable and also the fan curve is way to aggressive for me.

This reminds me, the screenshot is from fresh, reset Global Settings - no fan curve, no nothing.

Hm, I never heard for factory OC not stable. I run it @1380MHz with zero problems. It just scares me to run GPU above 75C so I wanted to see at what temps are other RX580s working. Are these new GPUs relay that good and endurable that they can work @75C for like three years?


I recently refurbished my GTX 750 and now it does not get over 63C even with the fuzzy donut

Thermal pads are useless in my opinion

About unstable factory oc - yeah it happens, I have seen reports about other 580s, vega and even nvidia cards.

About the temps 580 can run. Remember that for example many 480s had 80C as operational temps (the gigabyte one, the low tier xfx, the reference one, etc). So up-to 80 I believe it is ok.

I have many factory overclocked cards and my GTX 750 is one of them. My GTX 660 Ti is also factory overclocked. My HD 7870 is also factor overclocked.

Sometimes there are other issues that are affecting the machine. For that reason I have some small disks I use for a clean install of Windows to rule out problems related to driver problems or hardware issues.

Adept II

And there we go again, new driver arrived: v19.1.2 and guess what, Zero RPM still does not working even if you change one single thing in FAN control section.

I tried uninstalling chipset & GPU drivers with official driver uninstall executable and after reboot installed latest chipset (X470) + GPU driver v19.1.2. After restart, Zero RPM was ON and fans were stopped. But again when I changed fan curve and applied the cnage, Zero RPM broke again.


it could be that your ambient temperature is above the zero fan threshold