Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Adept I

RX 6700 XT - Cyberpunk with artifacts, flickering lights and poor graphics.

Hello, so i have fresh out of the box set-up: 

windows 10
be quiet! Straight Power 11 850W (BN284)


AMD Ryzen 5 7600, 3.8 GHz



While playing cyberpunk, the textures (especially the background ones) are flickering, lights are smeared. It certainly is dependant on the angle the objects are viewed at.


I have checked various settings, FSR on and OFF, XeSS on and off, and the issue is not going away. It is my first time using AMD graphics and i am not sure what could be wrong. I have only identified that issue in cyberpunk so far.


All in all, the background textures seem to look like a techno rave at times, with weird lightning artifacts at times. I am using the latest version of Adrenaline

9 Replies

With Cyberpunk it could easily be an update of the game that broke it for AMD users, have to wait for a fix probably if that's the case.

I myself played Cyberpunk about a month ago on a 6700XT and didn't experience any issues. Also, which driver are you using? Since I played new optional drivers have come out, could also be that they are the problem.

EDIT: Actually, now that I think about it, I saw someone post about weird artifacts in CS2 with latest drivers, so it's very possible that latest optional driver is the problem.


The driver i use is 23.10.2 adrenalin edition

Could you please elaborate what you mean by optional drivers? It is my first time using AMD and i am not sure what you mean. 


Yeah, that's the latest optional.

Basically, in your AMD settings under "check for updates" you can set wheather you want to be notified only about updates that are recommended (which are usually bigger, more important) or also smaller optional ones. Some optional updates may contain issues while the recommended ones take longer to put out and usually work better. Some people prefer to stay on recommended only, that's why I was asking which version you have.

For your issue I'd suggest to try an older version of drivers, the ones from september worked perfectly fine for me in Cyberpunk.

September's drivers are gone. Here is a link to all the older 6700 XT drivers.

Ryzen 7 7700X, MSI MAG X670E Tomahawk Wifi, Corsair DOMINATOR® TITANIUM RGB 2x16GB DDR5 DRAM 6000MT/s CL30, AMD Radeon RX 7900 XT, Corsair HX Series™ HX1000, Corsair MP600 PRO NH 4TB
Adept I

I have installed 23.8.2 drivers, i think it works better, however certain objects with heavy lightning still ale flickering, certain lights are smeared and sharp lines of lighting have this weird staircase flickering (idk how to describe it).

I have used AMD cleanup, or is there any other software i should use for removing drivers? 

Could it be that 6700XT is not strong enough?


I usually use DDU (can find it HERE). I've never actually used AMD cleanup so I don't know if it's better or worse than DDU.

6700XT more than meets the requirements and, like I said, for me it worked perfectly fine. Maybe you should try making a recording of the game, that way we would see exactly what it looks like and maybe someone can have a better idea what might be causing it.

i got same problem


Things to do IF you haven't done them already and see if issue persists

Update your motherboard's BIOS to latest

Install latest AM5 chipset drivers from website

IF you were running a different GPU prior to your current, run DDU in safe mode OR IF your previous GPU was an AMD GPU .. run AMD's Cleanup Utility Tool

Good practice to run separate power cables from your PSU to each power input on your GPU

Generally good practice to keep your Windows install up to date

Check for firmware updates for your SSD's ..especially IF you are running Samsung drives

ThreeDee PC specs
Adept I

Hello All,


I have the GPU connected by sepearate powerpins.

I have not touched undervolting/overclocking yet.

I have updated BIOS, chipset drivers, reinstalled GPU drivers after cleaning them with DDU, however it still persists.

I have attached videos.

It looks like there is an issue with an isotropy, not sure tho, not sure what else could i do.