Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Journeyman III

RX 580 - Hunt: Showdown Black Screen and AMD Driver Error

My system:
HP Z420
Intel(R) Xeon(R) CPU E5-2690 v0 @ 2.90GHz
XFX RX 580 8Gb GTS Black Edition
Windows 10 Pro 22H2
Samsung 980 Pro 1Tb SSD
750W PS

I had another identical RX 580 in the above system that played Hunt: Showdown at 55fps. It died during a marathon Subnautica session after 9 hours. I replaced that card with another just like it. It plays Subnautica at 30fps with no issues. It plays Crossout at 55fps with no issues. When I start Hunt: Showdown it start up normally, then at some point (30s to 1m) the screen will go black and I will get an AMD Driver timeout error with the option to report the issue. I have reported the issue several times. I have verified Hunt:Showdown files. Uninstalled Hunt and reinstalled. Reinstalled AMD drivers and Adrenaline. I updated to the latest Adrenaline today and tried Hunt again. Same error. After receiving the error, but not rebooting, I get the following message when I try to open Adrenaline: "The version of AMD Software that you have launched is not compatible with your currently installed AMD graphics driver." When I run the AMD Software Compatibility Tool it reports that "The version of AMD Software installed is already a compatible version. Please check if the AMD Display Driver is working correctly."

In Device Manager, it shows that the Display Driver is not working.

Driver Name: oem22.inf
Class Guid: {4d36e968-e325-11ce-bfc1-08002be10318}
Driver Date: 06/26/2023
Driver Version: 31.0.21001.45002
Driver Provider: Advanced Micro Devices, Inc.
Driver Section: ati2mtag_Polaris10
Driver Rank: 0xCF2000
Matching Device Id: PCI\VEN_1002&DEV_67DF&REV_E7
Outranked Drivers: oem5.inf:PCI\VEN_1002&DEV_67DF&REV_E7:00CF2000 display.inf:PCI\CC_0300:00FB2006
Device Updated: true
Parent Device: PCI\VEN_8086&DEV_3C04&SUBSYS_1589103C&REV_07\3&11583659&0&10

Device PCI\VEN_1002&DEV_67DF&SUBSYS_C5801682&REV_E7\4&16c9e9f9&0&0010 had a problem starting.

Driver Name: oem22.inf
Class Guid: {4d36e968-e325-11ce-bfc1-08002be10318}
Service: amdwddmg
Lower Filters:
Upper Filters:
Problem: 0x0
Problem Status: 0xC00000E5

1 Reply
Journeyman III

I have the same exact issue with near identical error message in the event log. Same XFX rx580. Mine happens with Baldur's Gate 3. I'm guessing it is an overheating issue, though there are some comments I've read that say it is thermal paste leaking where it doesn't belong. I'm going to replace the thermal pads and paste and see if that works.