Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Adept I

No signal first boot rx 5700 xt sapphire nitro+

Hello guys, i have a big problem with this card. when i turn on the pc the monitor gives me no signal
with the keyboard off, mouse on and the GPU on with led and fans on. This does it only on the first
boot, if I turn off and on immediately pressing F2 / F8 to force boot and I can see the monitor
correctly. I tried the GPU on a PC of a friend of mine who also has it, and everything works right
away. It does the same thing even when I put it in suspension, when I wake it up, there is
no signal on the monitor. When i play i don't have any problem. I have tried everything, DDU,
reset cmos, remove RAM,format Windows, etc.
Try HDMI and DP but same result.
There is my spec:
Mobo: asus a320m-k
GPU: rx 5700 xt sapphire n +
CPU: Ryzen 5 3600
RAM: 2x8 crucial 2666Mhz
PSU: cooler master 650w GX 80 bronze not modular.
OS: W10 home 2004.
Monitor 75hz with FreeSync on.
Adrenaline last version,but i have same problem with the previous one.
I also have 5 fans, 2 ssd and 1 hdd 7200 rpm.

My friends have a mobo 350 gaming, PSU 750w, RAM 3000Mhz. Same versione W10 and adrenaline software.
I hope to find help because I am going crazy,
every time I have to brutally shut down the pc and do the manual boot.

Greetings and thanks for help.
24 Replies

I think that's probably an issue with fast startup.

Try turning it off.

Open up control panel.

Change the view by option from category to one of the icon options.

Select power options

Select choose what the power buttons do

Remove the tick from fast startup.

You will need to hit the text "change settings that are currently available to change options.

save the changes and restart your computer.

Let me know if it helps


Hi , thanks.

i already have this settinga, but no Fix

Adept I


i had this error event while do first boot, need to power off, power on and press F8 to do manul boot and later all work.



You should disable Windows Power Options fast startup item.
Also you should disable fastboot and CSM support with the mobo BIOS boot settings.

There may be a problem with your Windows installation. It may not have been installed with UEFI support. The UEFI partition may have been written to the other disk. Turn off CSM support with the BIOS and install Windows again with UEFI support. Before installing, disconnect the HDD from SATA cable. Make SATA connection after installation. And apply the power options required for the new Windows. So there is no single problem with your system.

Your BIOS cannot boot Windows with the correct partition and the GPU driver cannot use fast startup properly. I guess...


Go to BIOS (and boot settings) and disable fastboot and CSM features. Also, make sure the BIOS starts correctly with Windows Boot Partition first. In short, if you have a boot problem, you can only fix it from the BIOS (or VBIOS (update)). 

just to add to MSTFBSRN980 reply:

To run UEFI Mode in BIOS your C: Drive must be GPT and not MBR.  As mentioned, UEFI Mode (Secure Boot) will not boot into a MBR C:\ Drive and CSM Mode will not boot into a GPT C:\ Drive.

Under "System Info",  if your Windows Drive is listed as MBR then you need to reformat your HDD/SDD to GPT before changing BIOS/UEFI Settings from CSM Mode to UEFI Mode and then installing Windows again.

Microsoft has a program that converts MBR Windows drive to GPT Windows drive without losing any data. It is called MBR2GPT.  Here is the link: MBR2GPT - Windows Deployment | Microsoft Docs 

You can try this first and see if it works for you if not then you will need to convert your MBR disc to GPT first before installing Windows which will wipe out all data on the C Drive when converted.

EDIT: Not sure if the RX5700 series GPU cards are compatible with both CSM and UEFI  BIOS Modes or not. If it is only compatible with UEFI BIOS Mode then you need to do the above.

Adept I

Hi guys,

thanks to all.

I have windows installed with UEFI mode.

Windows drive is listed as GPT.

I have disable CSM

I have disable fastboot.

All these things can't solve the problem.

Maybe i need to disable secure boot?


Your problem is not clear. Does your computer not boot at first? Or is it not signaling at first? Please bring the PC case and the monitor to each other and show the problem with a camera.

Also, please try your PC case with a TV. Does the result change?


I try the pc to other monitor/pc and i have same result.

i try to explane the problem more clean:

when i do a cold boot(first boot after 2min or more pc off) the monitor return me no signal, with no keyboard power , GPU power on 10/15 seconds later than mouse/fans.

I need to brutal power off and instant power on with press the keyboard to give her power.

in this case the GPU power on instant (led and fans).

i view the monitor and i choose manually boot.

after this procedure i can use the pc.

if i restart the pc it boot correctly at first time

if i power off the pc i need to do procedure 


You can't disable Secure boot which is UEFI Mode if your C drive is GPT. 

If you disable Secure Boot then it will go to CSM mode in which case your computer won't boot up since it needs the C drive to be MBR.

When there is no signal when you first power up does your motherboard show any TROUBLE LEDs or TROUBLE Codes or unusual Beeps?

Also try resetting your BIOS back to factory settings by doing a CMOS CLEAR and see if it makes any difference. Also do you have the latest BIOS and CHIPSET versions install on your computer? Especially BIOS?.

EDIT: Went to Asus Support and saw that there are very BIOS (7/2020) and CHIPSET (8/2020) versions to install if you haven't done it yet: PRIME A320M-K Driver & Tools | Motherboards | ASUS Global 

You also might want to check your GPU's manufacturer Support site to see if they have a newer vBIOS for your GPU card.


I have bios versione 5602, and chipset i think is the last.

i try cmos clear, I don’t have any led or beep error

If i put my old 970 strix or 1050ti i have no issue 

Thanks for the update.

Your symptoms eliminates the AMD Driver since the driver is not loaded until after Windows boots up.

If you installed two different GPU cards, doesn't matter if it is AMD or Nvidia, and it boots normally that does indicate the RX5700 has issues when first powering up or your Asus Motherboard has problems with your AMD GPU Card.

Since you mentioned your Rx5700 worked normally in a different computer that does indicate the problem is probably either with your Motherboard or PSU.

I would open a Asus Support ticket and see what they recommend.

Possibly you may need to downgrade the BIOS version, just for troubleshooting purposes, just to see if your PC starts powering up normally. Sometime newer BIOS versions are buggy. 

But before downgrading the BIOS, I would open a Asus Support ticket and see if they recommend RMAing your motherboard.


I think the problem is the mobo.

i do multiple clean driver amd installation with DDU.

i tried with the precedent version of bios but i have the issue 

i can try write a ticket to Asus or change mobo 

How did you infer that your motherboard is broken? Maybe one of the USB devices connected to the motherboard or one of the disks is defective. Or a power cable or a data cable is defective. Your motherboard cannot boot. If it cannot boot, there is no signal already. I really don't know what your problem is!


I try to boot with no usb device, only sdd with OS and same problem.


Your system is already without any problems with other GPUs. I think it makes more sense to look for the problem in the newly added hardware. When I do not have any problems with my system and if I have installed a new GPU in my stable system and if I have a problem like yours after GPU installation, I will immediately retire the GPU.

I am reading not only your problem on these pages, and I think some brands' VBIOS are causing serious problems. AMD GPUs themselves make digital VBIOS signature checks. It might be something like some models don't pass this check. I do not know.

I am not saying that a different motherboard will react the same to the problem you are experiencing.

Why on my friend’s pc , with a mobo version b350gaming, works on first boot?

maybe the processor? Ryzen  5 1600?

psu? 750gold modular

 Is a mistake 


Install an old GPU in your system and use it for a while. If there is no problem, I think it is unnecessary to look for problems in something different. I do not know the answer to your question.


i used 1050ti for 4 month nessun problem,

use 970 strix for 2 month, nessun problem.

only with the 5700 i have issue


Your processor supports PCI Gen4. Your graphics card has PCI Gen4 support. Your motherboard does not support this feature. It also has the lowest quality. Obviously this system had to be set up with a good motherboard. Even if you don't have any problems now, the probability of problems is high as you use it. It doesn't have proper 8PIN CPU power support properly. It has no cooler (marked zone).


For these reasons, I can recommend you a new motherboard. I can advise by PM if you want. But I cannot say that the cause of the problem is the motherboard or the GPU, unfortunately. Because I don't know the cause of the problem.

thanks, i'm going to buy a B450 msi or B550 msi/strix/gigabyte, i don't now when, because i need to change the case ^^


You need B550... My favorite is Asus. Strix is better, but you can choose TUF. I'm using TUF, and for now I had no problem...

I have had similar problems, but not with this exact same setup.  I have identified the problem to be such that very often, but not always, during cold boot my BIOS/UEFI changes automatically "CSM Mode = Disabled" to "CSM Mode = Enabled" and when this happens, there is no signal on display. This might happen also during a normal reboot. I have changed most of the components in my setup when searching for the reason, but the problem still occurs. List of my components (all of them are bought as new):

Processor: AMD Ryzen 7 3700X
MB: Gigabyte X570 ITX, later Gigabyte B550 ITX
RAM: 2x16 GB 3200 MHz Corsair, later HyperX
GPU: XFX Radeon RX 580 8 GB, later Sapphire Radeon Pulse RX 580 8 GB
Case + PSU: NZXT H1 with 650 W PSU
2 x nVME M.2 SSD + 1 x SATA SSD

As you can see I have changed everything else, but the processor and PSU.

If I change RX 580 to nVidia GTX 1660 GPU the system is working perfectly. For some reason, RX 580 is causing the problem. Sad to hear that also RX 5700 XT has similar problems.

Journeyman III

Hey guys, maybe it would be useful for some of you who still sit with 5700 XT: finally I managed to fix those crappy AMD Radeon driver crashes after 1 year torturing with it lol. What I did:

1) Completely deleted MSI Afteburner app from PC

2) Updated BIOS to last one

And also bad overclocked RAM can cause errors with drivers, checked your overclocks again: even one error in 1000% cycle can crash anything in Windows 10