Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Journeyman III

I have trouble with making a 7900XTX Pulse works on the top pcie slot of my motherboard

Hello !


I'm encoutering some problems with making my graphic card works in the top pcie slot of my motherboard, the one that is near CPU and accept from Gen1 to Gen5.

I've already searched in the internet, found sort of similar thread that expose same problem as me, but the softwares and hardware were not always exactly the same, so I'd like to have some help!

For instance, here is some informations about my hardware:


Motherboard: ASROCK PG SONIC z790. BIOS Version is 3.15

CPU: i7 13700k

GPU: Sapphire Pulse 7900XTX. Driver version is 23.4.3. BIOS Version is

RAM: 2x16 go DDR5 5600Mhs from Gskill

I have first tried to put my 7900XTX Pulse on the top pcie slot, it did barely works but stopped posting pretty quickly, and never worked on this slot after that. I did perform a clear cmos on my motherboard, updated motherboard bios to the latest stable one. 
I also tried to explicitly set the gen of the pcie slot gen to 3, 4 and 5, but none worked.

I managed to have a Nvidia 970GTX near me, so I put it in the slot and it worked well ! Pretty strange

I made my 7900XTX Pulse works on the bottom pcie slot, which is limited to Gen4. It work well, but it's only a x4 lanes pcie slot, so I'm loosing some performance (and also airflow, since its really close to the bottom of my case). I would really want to make it works on the top slot, which is x16 lanes for the gpu!
On the top slot, the GPU fans are spinning, but no output on the display, and nothing detected on the bios video card adapter list nor in the windows device list.

About power:

In my PSU (a Corsair RM850) I have 2 x (6+2) pcie cables plugged, and 3 x (6+2) plugged in the GPU. These are daisy cable. One if plugging 2 in the gpu, and the second is plugging only one, and the other one is just hanging in the void.

Maybe I need to have 3 fully independent cable ? Its work on the bottom slot, so it's strange it would need a different layout for the top one.
Since the 970 GTX only need 2x(6+2), it does not tell me if this is the problem!

I have contacted the ASRock support, since it may be only a bios problem that struggle to recognized the card in the top slot, but I really do not know their delay of answer, and some kinds and wises hints from internet people would help eheh

Thanks you for your time, I hope this post is okay in this forum

1 Reply
Adept I

Any update on this one?