Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Adept I

Graphics card bios broken?

Hello everyone

I will get straight to the topic

Recently I bought an Sapphire RX 5500XT 8GB Pulse
At first I thought it was running normally until i checked the clocks.

So the Memory clock is at 1736 (not 1750) and the Boost Clock reaches 1820-1830 not 1845.

And then I checked thermals with Hwmonitor and MSI Afterburner(Which wouldn't let me touch target temps and voltage even when i unlocked them from the settings). The card was hitting 80+ degrees while the fan speeds went up to 20% ( that happened at both silent and performance bios).

So I thought it was a driver issue. I had the 20.11.3 and I DDU it and installed the recommended 20.11.2
Nothing changed

I tried some of the auto-overclock that Andrenalin offers and things got even weirder. The auto-overclock set the speed to 1930, but my card decided to run at 1870 even when its colder at 68 degrees 

And then the crashes. For some unknown reason my card decide that the auto-overclock (yes even at 60Mhz lower) some day would crash and other day nope. For a whole day it was working fine , the next day it crashed. But it crashes when i close the game and not ingame.

So I thought that maybe i can reflash the bios(the performance one). I downloaded a matching bios from techpowerup , downloaded the amd flash tool. I tried to launch it as administrator. And it pops up "Error reading from ROM".

After that I knew it was time to ask someone more experienced 
(I have flashed an RX 480 in the past with completely broken bios, so I know how to use the tool , but I don't know what to do now)


Specs: i3 10100 , 16gb at CL12 and 2666Mhz , Gigabyte B460 D3H,XFX TS 650 80+ Gold, Samsung EVO 860 (250GB with windows 10), patriot 480GB  and Seagate 1TB 

1 Reply

Contact Sapphire.They made the Card,Might have a new Bios for it.