Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Journeyman III

Dual monitors only work with Crossfire turned off

Hello, I have crossfired R7 300 cards, 4 gb each. They are the exact same model, I bought them at the exact same time. They have worked crossfired for about 2 years. I have one monitor plugged into HDMI on one card and another monitor plugged into the other HDMI port on the other card. The monitors are the exact same monitor as well and using the exact same cable. After the recent update on Win10 (Home 64bit), my second monitor wasn't working. I could not system restore as I got an error saying it could not roll back the update. I updated the drivers to the highest recommended by the tool from the AMD website and am now running Crimson 17.X.X. When I turn the Crossfire option off in the dashboard, both monitors power on, but I am only getting use out of 4 gb of GPU (one of the cards). When I enable Crossfire, the second monitor goes off, but Crimson shows the second graphics card as linked. Is there something I am missing to keep Crossfire enabled and have one monitor plugged into each card as I have had consistently for the last two years?

1 Solution

In Crossfire all displays must be connected to the primary (top) card.

View solution in original post

3 Replies

In Crossfire all displays must be connected to the primary (top) card.

But it worked with a monitor in each for 2 years and crossfire on. In addition, my left monitor is connected to the to card and right to the bottom. When the update occurred only the left monitor was getting signal. I turned off crossfire and both worked. When I turned the crossfire back on, the right monitor was the only one on and the monitor plugged into that to one was off.


I am not sure why it stopped working with this latest driver upload all of a sudden, but a DP to HDMI converter is only $10 to line them up on the same card. I will re-enable the crossfire and the adapter will arrive Monday. Thanks for the answer.