Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Adept II

dedicated graphic card not being used

I have a pretty common problem which a lot of people in this thread seem to have so i will try to explain to the best of my ability what is wrong so that there maybe someone who had this problem can provide a fix. 

Product number
Product name
HP Pavilion Notebook - 15-ab136ax
AMD Quad-Core A10-8780P APU (2 GHz, up to 3.3 GHz, 2 MB cache)
Memory, standard
4 GB DDR3L SDRAM (1 x 4 GB)
Video Graphics
AMD Radeon R7 M360 Graphics (2 GB DDR3 dedicated)

So I'm using an hp apu laptop with r7 integrated as well as r7 m360 dedicated. The problem is that the m360 isn't being used for gaming, mind you i had this laptop for five years the only reason why i'm making a fuss now is that i didn't really play many intensive games back then( in fact till this moment all i want to play is dragon ball xenoverse 2, which even in the hub world at the lowest settings meaning even resolution at 800x600 i can't even average 30 fps in the hub world, thats how bad my laptop's state is at the moment). So i have tried everything that i could think of to making it high performance. Putting windows power plan to the ultimate plan, changing from switchable graphics(when radeon settings still provided it) to high performance, changing from windows graphics settings to high performance, but nothing uses the dedicated. I know its not a hardware problem because games with crossfire profiles like battlefield 3 uses the dedicated card, tho franky using 3-10 percent of it isn't really saying much but at least it does. Every other game just refuses to use it. I know some people would say to use the oem's drivers but i have two problems with them. The first being they are old as hell using drivers from 2016 not being the crimson one but the catalyst ones, second is that those don't work either when i change the game to high performance it will just change it back to power saving. At this point i know people would say to change my laptop which i am planning on it but at the moment i would at least like for this to be fixed. Sorry if this was very long but i just need to know if there is a way to fix this also i have contacted hp support and they couldn't find out what was wrong with it and asked me to ask amd(which i have sent a message waiting for an answer soon) so for now i'm trying my luck here.

Also before you ask, yes i have used ddu to clean drivers and install with a fresh slate and have prevented windows from updating them on their own. I know people would say to use apu drivers, problem is my apu 8780p don't have any form of drivers on amd, i'm not too sure why but r7 m360 drivers support my apu so i use those, but you know the answer to how that ends up. I will provide screenshots to show that it doesn't work with dragon ball xenoverse 2, but the card kinda works with battlefield.

15 Replies

I don't have any of those games or that hardware. But I do have some suggestions that may help, and one possible explanation that you won't like.

First, I would get all the drivers to the latest, never mind going to those old versions. The newer versions are sure to have fixes that you are likely to want and/or need. Go to Start -> Settings -> Display -> Graphics Settings. Select either Desktop app or Microsoft Store app, and then identify the appropriate game, or game executable. Click Add, then use the Options for that game and select the appropriate GPU.

Another option is to right-click the shortcut for the game, and then click Run with graphics processor option. This only works when there is more than one graphics processor available.

Finally, it may well be that your game just simply doesn't recognize the more power GPU. I ran into this exact problem with a game that refused to recognize an NVIDIA GTX 1060. The game would only operate at the lowest settings. Curiously, I used VMware Workstation Pro and a virtualized version of Win 10. The virtual DX12 graphics worked perfectly with the game ran at maximum settings. Obviously the game worked, the GPU worked, but the game didn't recognize the GPU as one that it could leverage.The virtual DX12 did the trick. Your game(s) might fall into that category. In that instance, I have no easy fix or resolution.


Honestly at this point don't worry about telling me what i don't like xD its all good if it helps it helps that's what matters. Now the thing is my drivers are at the latest that they provide for r7 m360 but the thing is and I'm not too sure if this is a windows glitch but even for battlefield that can technically recognize the graphic card, windows graphics will still show that high performance only uses the r7 integrated graphics. Now for the last part, honestly that may be the case that the game can't recognize my graphics but I honestly don't think that is the case because their are youtube videos of people using weaking apu laptops like the r5 m335( something along those lines bear with me haha xD) or like the r7 m260 and they can use the graphic card to play the game. So in my mind that would mean that it does know when to use the graphics card on an apu machine, it just hates my one. But besides the point thanks for trying and not giving the normal solutions that literally everyone and their mother does xD even when i have told them what i did they would still give it to me, and this is not throwing shade at anyone that wants to help but its just... when you been searching for a solution for more then a year hearing the normal things that most people who are desperate at this point, probably don't want to hear it.


Out of curiosity, is there a firmware update to the laptop that hasn't been applied? And in the BIOS, is there anyway to disable the APU and only have the more powerful GPU available? And do you see the right click option to force it to use a specific graphics card? That right click option is available in Win 10 build 1909, but not sure about earlier versions.

And as I indicated, there are games that simply will not recognize specific GPUs and, instead, run on the slower GPU (the APU), or just run in low graphics settings. An NVIDIA GTX 1060 is not that old and still I had a game that simply refused to do better than the lowest settings. That same game worked great at maximum settings in a virtualized environment on the same hardware. And even more curiously, I could tell that in the virtualized environment, it really was hitting the GPU and making it work, ramping up the fans, etc. Some software just has quirks.


My bios is the latest version provided by hp being a may 2019 update( tho their graphics driver are downright terrible being back from 2016) and sadly hp loves to lock their bios and give u the bare minimum so their is no option to force set the gpu. Also correct me if I'm wrong but their is no right click and set to dedicated card for amd laptops even on the latest update, i think that is a nvidia only thing. Their is the windows graphics settings but as my screenshots showed it doesn't show the r7 m360 anywhere. The game thing honestly idk i would love to give the benefit of the doubt that it should run on my graphic card but you could be right, i will try some other games later and give u some input on the performance on them. If you have anymore advice it would be very much appreciated


It could perfectly be a registration problem from what I see is a very common problem but the bad thing is knowing what to modify to give a solution


This is actually my first time reading about a registration problem not too sure what it is tho haha?

Journeyman III

Hi... I have this problem too. I have HP G2 355 with A4-6210 with iGPU Radeon R3 and dGPU R5 M240. Also i have Windows 10 64bit with latest updates. Unfortunately when i trying to play CSGO i get 10 - 30 FPS that is very low for M240. So i think my laptop can't use my dGPU and use integrated one. I try to change settings in BIOS and also updated my  BIOS to latest version but no different and i can't do any thing in my BIOS. Due to this article BIOS settings is only available for laptops with Intel CPU and AMD GPUs and we have no options to change them. Also i cannot see my dedicated GPU in Graphic settings in Window/Display Setting but when i run game (CSGO), dGPU performance up to 10 - 15 percentage and a few time even until 90% but not always. So what should we do? Also i do every things that you said and get no results. Even i install adrenalin 2019 that has switchable graphics option but when i change the performance options to power saving or to high performance, i see no different in FPS. HP websites says these kind of laptops use Dynamic Switchable Graphic, That mean it switch between graphics due to what applications are running but it seems this system doesn't work very well. PLZ help...

Adept III

me and also some other people have this problem with another model (n551zu with r9 m280x) . in windows 10 v1511 i had 12767MB of  total available graphics memory everything is fine but in version 1909 it's 8671MB and also not using my dedicated GPU.


they should fix this problem for us.

Adept I

same problem 
lenovo ideapad 320-15abr amd a12 9720p r7 m440




Sorry for the lack of replies here but I'm currently working on a solution with another fellow amd user here on a different discussion, the method worked for him however we are in the process of using my laptop as the benchmark to fix, so basically if we fix mine the method can be deemed usable for others considering the method requires specific programs to be used. Once i get this done which so far little by little progress has been made, I will be sharing this method with everyone here. Hope I can also be of help to other struggling users with this quite frankly ridiculous problem.

hi!!! i really really appreciate your efforts helping us, so we're waiting for some good news from you.


i hope you make it because i have this problem since 2019  oof  good luck


Sorry for all the late responses at the moment I am taking small breaks for this project as I have been trying to fix this for over six months, it is starting to take its toll on me lol but I'm still trying every now and then to fix the problem at hand. So for now I will link this it has two methods that may help you guys but I will highly recommend to read the steps carefully and to download the appropriate drivers from safe websites or use the ones you currently have in conjunction with the method provided. Hopefully, it may help a few out there if it does at least the method provided by rico is proven working, as of right now i have a few suspicions as to why the method isn't working for me but I will require more testing to prove any form of evidence, till then good luck everyone. 


Hi, sorry for reviving this post, but I can't find a solution in 2022 for this particular issue, any suggestions and help would be appreciated.



I have the exacly same laptop with the same problem too. If you find any solution please drop a letter for me to . I will do the same if I found something usefull. Of cource I will share the solution in this topic too.