Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Adept I



     I had originally had the R9 Fury X Crossfire working like a dream for a few months. I being a seasoned Lighting Designer use computers to visualize complex lightshows and video content at and need an extremely high framerate. My computer began to fall apart the day was getting an error with one of the R9 Fury Xs. I decided to RMA the malfunctioning GPU in hopes to get my crossfire system back to normal.

     After two weeks of waiting for the replacement device to arrive I finally get an Email saying that an R9 Fury X could not be manufactured at this time, and I would have to wait until a new shipment arrived. So another two weeks (over christmas) pass and I open a second Email saying that Sapphire would like to replace my R9 Fury X with a  Watercooled Vega 64. Ecstatically I say YES, quickly sell off the 2nd R9 Fury X, and later I receive my new GPU.

     Not even a day into using the brand new GPU my monitors suddenly turned to a solid color and sound would disintegrate; requiring a hard restart to get back online. I attached a picture of exactly what happens, given the screens are different hues sometimes. Naturally I assumed it was a faulty GPU considering I did not have this problem with my R9 Fury X, so I decided to RMA it once again. After two weeks I get a package with the second Vega 64, install it, and in under 24 hours of use the monitors glitch out again. Please note that during my 2 week Vega 64 hiatus I used my friends extra Nvidia 1050 and it had ZERO problems whatsoever.


Unfortunately Sapphire was not so willing to RMA it a 3rd time, claiming it was a problem with my system that was causing the crash. So naturally I took them up on their challenge, and decided to start buying brand new gear.

I purchased brand new,


AMD - Threadripper 1950X 3.4GHz 16-Core Processor

Corsair - H100i v2 70.7 CFM Liquid CPU Cooler

Thermaltake - The Tower 900 ATX Full Tower Case

G.SKILL TridentZ RGB Series 32GB (4 x 8GB) 288-Pin DDR4 SDRAM DDR4 3200 (PC4 25600) Desktop Memory Model F4-3200C16Q-32GTZR

With much dissatisfaction I must suggest to you that I continue to have the exact same problem. Consequently, the only thing I have not purchased is a new Power Supply, I first need to test my friends PSU before I make that purchase. I've probably spent around $2,000 trying to fix this problem, and I have had to endure an insufferable amount of time and money lost due to this issue.  It is unacceptable that while I am drafting stages in AutoCAD or Programming lightshows I must endure being weary of a random crash every 2-4 hours.

I have done a Clean Install of the drivers, and have updated them to version 18.3.4.

I used the Display Driver Uninstaller application recommended by AMD.

Additionally Windows 10 is up to date /w Version March 13, 2018—KB4088776 (OS Build 16299.309)

The RAM is of the DDR4 3200 Qualified Vendors List (QVL) for ROG Zenith Extreme.

Details: The crash can happen at any time and on any program.

Screens turn black and require a hard restart.

No Error Messages or Crash Dumps.

I used a single Nvidia 1050 on the same system for 3 days and not a single crash occurred.

I give speeches on Lighting Design in Vegas every year at Lighting Design International and I would hate to have to point my students and coworkers over to Nvidia. I was a huge fan of AMD until this started happening but as they say "Decisions make themselves eventually"... and there’s a push I'm feeling far away from AMD.

Has anyone ever had a problem similar to this? Or had any experience like this with Sapphire?

I hope one day they will come to their senses and realize they gave me two faulty GPUs.


10 Replies
Adept I

I just reinstalled the operating system and got the exact same crash today.



Sorry to hear you are having problems with your card. 
Can you please check what is shown up in Control Panel -> Hardware and Sound-> Device Manager ->  Display Adapters  after you run a clean uninstall of AMD software, reboot into safe mode, run DDU and remove any traces of Nvidia or AMD drivers, reboot?

What is shown in in that, could you show a screenshot?

Did you turn off or pause Microsoft Update before you rebooted after running DDU?

You might find that Microsoft Update might have seen you had no Display Driver, installed an old AMD Crimson Driver during reboot after DDU.
Then if you try to install Adrenalin 18.3.4 it does not see the Microsoft Installed AMD Driver, so it overlays a new driver install on top of the Microsoft installed. one resulting in goodness knows what.

Just a theory, but I and others were getting red screen and audio buzz on RX580 and R9 Nano cards in some applications  because of this exact situation.



Here's a screenshot. I am going to reinstall Adrenalin 18.3.4 now.



I did not Pause Microsoft Update at any point. Here is the latest crash. It's happened twice now today.




OK, since it says Microsoft Basic Display Adapter before you installed Adrenalin 18.3.4. then that should be O.K.
Microsoft Update does not appear to have done anything bad in this case.
Maybe Microsoft Update does not try to install Vega Drivers since it tried to install 1.5 year old rivers for my R9 Nanos.
It might be a good idea for you run update then pause it and then uninstall and reinstall your AMD Driver in future if you keep your Vega card.

Sorry I could not help you with a quick answer.
Please make sure you are not overclocking your CPU or your Vega GPU during debug, as that could add additional instability.
Also I think it best to power vega cards with two separate PCIe power leads.
You might also want to switch the Vega BIOS switch into low power position and see if that helps.



I'll try to plug in two power leads and switch it to low power. They sent me a Vega without a manual so I guess ill find it online.

I don't know how to overclock so I can't overclock anything. Thanks for trying to help me.

Good luck,


Adept II

Yeah, I'm getting random black screen system lock ups lately. It started happening after I got the second custom Asus 64 for Crossfire, and I used a new card as a primary. I switched places of the cards, but my system became unbootable. Reinstalled the windows, and saw a lock up only once lately, unlike several times a day previously, with the latest 18.3.4 drivers.

I just got a notification from another thread, some guy is claiming that his issue was faulty DisplayPort cable, and he got it solved.


I already replaced the Display Port cable. Thanks for responding.

Adept I

So I bought a new power supply, and upon plugging it in, it surged and fried all my SSDs, destroying my Data.

Its going to be a while until I can ttoubleshoot this problem again.


  Sad to hear that.  Try not to let it get you down. If you need any help on how to recover data from SSD you might be able to get some help from this forum.