Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Journeyman III

Cache hierarchy error RX 5700 XT/ryzen 7 5800X

Hello everybody, 
While playing call of duty games (warzone, cold war and vanguard), sometimes my screen goes black and immediately restarts, and event viewer shows cache hierarchy error. I feel like I've tried everything by now and I don't know what esle to try.
Here's what I've tried:

  • fresh windows install
  • DDU drivers uninstall and reinstall (drivers are updated to the latest version)
  • chipset drivers reinstall (latest version)
  • reseating components
  • made sure every cable is connected
  • swapped motherboard (before it was asus strix X570-F, now its Asrock x570 taichi)
  • swapped ram (g.skill tridentz to corsair vengeance 3200mhz)
  • swapped cpu (r7 3700x to r7 5800x)
  • PSU is less than a year old (corsair rm750x 80+ gold)
  • temperatures are fine, gpu is 63C while usage is at 100%, cpu about the same)
  • disabled PBO
  • added positive offset to PBO
  • added negative offset to PBO
  • disabled and re-enabled XMP
  • applied more VID voltage & Vcore voltage
  • removed dual boot with fedora linux
  • enabled and then disabled resizable bar
  • upgraded to windows 11

Nothing worked, althoug before it crashed like once or twice per day, now it can crash once or twice per week.
I'm pointing my finger to the GPU because it's the only thing I haven't swapped so I'm kinda out of options here, any help is appreciated.

my specs:

  • Asrock X570 Taichi
  • Ryzen 7 5800X
  • RX 5700 XT Powercolor red devil
  • 32GB DDR4 Corsair Vengeance PRO RGB (4x8GB) @3200Mhz
  • 1x sabrent rocket 4.0 Nvme SSD 500GB (OS)
  • 1x sabrent rocket 4.0 Nvme SSD 1TB (games)
  • 1x Kingston sata SSD 250gb (ex linux drive, now general storage)
  • 1x WD blue 1TB (storage)
  • Corsair RM750X 750W 80+ Gold PSU
  • Corsair H100i Capellix 240mm AIO CPU cooler
  • NZXT h710i case

I'm going crazy with this error, thanks in advance for your help.

0 Replies