Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Journeyman III

AMD W5100 Graphics card causing Microsoft Excel 2016 Crashes

OK, friends, this is an unusual one so bear with me and feel free to ask whatever questions you come up with.

First, I am legally blind (I have really, really bad eyesight[20/250 Lt, 20/350 Rt corrected]).

Next, a rundown of my system: (Newly assembled in July of 2018 - less than 8 weeks ago)

AMD Ryzen 7 2700X processor on a Gigabyte AUROS x470 Motherboard with 16GB of Corsair Vengence RAM and the AMD W5100 graphics card.

I am using Windows 10, v1803 build 17134.228 with all updates.

To this I have connected 2 Acer ED273 Abidpx 27” Curved Monitors.

The first monitor is configured normally. The second is used exclusively using Windows Magnifier app at 600% magnification.

The problem:

Microsoft Excel 2016 (no other app that I am aware of has this issue) crashes after making some changes to any file. This has been an issue since I built this system.

Why I believe this is a graphics card issue:

At first I thought it was an issue with MS Office. I have been through every conceivable test, repair, re-installation, etc. to no avail.

I came across an article that suggested it could be a network issue (as I have all of my documents stored on a server). I moved the file I was trying to edit to a local drive and the problem continued.

However, I noticed that just before there was a crash, I had what I can only describe is a jump or a flicker on the screen (on the magnifier monitor).

I tried closing the magnifier app and zooming the document enough to see it and made many changes to the document with no issues. I reopened the magnifier, made three or four changes and Excel crashed. I repeated this several times before concluding that this is definitely the issue. Although I can zoom a document enough within Excel to make changes, I cannot see the menus well enough to effectively use the app.

Something else I have noticed the last couple of weeks; I do not turn off the computer or let it sleep (because of an issue with the Thermaltake Fusion software). I do lock the system when away and I have a slideshow on the lock screen and the screens sleep after 30 minutes. Three or four times a week I come back to the system to find that one screen or both do not wake properly from sleep. This doesn't appear to be a problem with the actual monitors as I can turn them off and back on and the problem continues. The only solution I have found so far is a system reboot.

Please let me know if you have any questions. Thanks for all your assistance.

9 Replies

  • What is your system BIOS version?
  • Which AMD driver did you install?
  • What is the Bios Part Number of the W5100, you can find it here:
    • Radeon Pro Settings => System => Hardware
  • How are the monitors connected, cables and adapters?
  • Which inputs an the monitors are used?

Thank you for your response. Followihng your line of questioning, I realized that the driver I had installed was more than three years old. I downloaded and installed the most recent (both the old and new versions, as well as the answers to your other questions, are noted below).

I have tried things with the new driver and Excel crashed within two minutes and again within 20 seconds.

System BUIS Version: F2 (3/14/2018)

Video Driver: v.15.200.1062.1004  (8/3/2015)

  Updated to: v.24.20.12024.10 (7/17/2018)

BIOS Part Number: 113-C5870300-100

Both monitors are connected via Display Port Cables - no adapters needed as my monitors were specifically selected to not need them.

Which ports are used: They do not appear to be numbered, but looking at the card I started from the 'top' down.


  • There is a new system BIOS version F4 available from Gigabyte website. Please download and install:

          X470 AORUS GAMING 7 WIFI (rev. 1.0) | Motherboard - GIGABYTE Global

  • Are your monitors set to DP 1.2?

Thanks again for your response.

I downloaded and flashed to the latest BIOS Version - for reference, my motherboard is the x470 AORUS Ultra Gaming (rev.1.0) so the most recent BIOS version is F3.

My monitors don't offer the ability to change which DP version, and the manual they have on the web site is for the older version of the monitor. However, I was able to speak with Acer tech support and they have assured me that the monitor is DP 1.2a compatible.


I cannot repro the issue at my end. The issue must be related to your system


OK. Again, I appreciate the assistance. This is what I have discovered:

I had a different bug - one that prevented the system from auto-locking or letting the monitors sleep. After hours of shutting off tasks and services, I determined that problem came from a Gigabyte app that installed with their RGB Fusion. The file is called "SelLEDV2.exe". I renamed this file, rebooted and fixed that issue. Coincidentally, Excel has yet to crash since that change. I cannot say with absolute certainty that both issues are resolved, but it appears so.

With regard to the problem of the monitors not coming back on properly after timeout, I am still having that problem, but I power-cycle the monitor and everything goes back to normal. It is unclear as to whether the problem is with the video card or the monitors. A design flaw in the monitors could well be the problem. I doubt that the DP cables are the issue, but the DP cables I am using were not the cables provided by Acer (they were 6' and I needed 8').

If you want, I can repost this problem in a different location.


I am glad you got your EXCEL issue resolved. In terms of monitor issues, DP cables are quite sensitive. Do you have the make and model by any chance? Did you try different high-end DP 1.2 cables? 


Cable Make: Cable Creation

Cable Model: CC0109