Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Adept II

AMD CSGO Loading Bug on current graphics hardware / drivers?

Hello Community,

a few months ago, i sold my GeForce GTX 1080 Ti and bought a 6900XT. One of my most played games is Counter Strike : Global Offensive. Since changing to the red team, i am experiencing a strange problem.

Problem description:

When loading any map in competitive matchmaking or on private hosted servers, the game gets stuck on the loading screen while "recieving server information". Normally, the process of loading a game in CSGO takes less than 20 seconds on a modern system and in some cases, the game indeed loads that fast.

But in most cases (approx. 80% of all tries), the game will get stuck for a long time at this stage. The game will freeze for about 10 seconds to several minutes (!). During this time, it is shown as "not responding" in the Task Manager. After that, the game will load and run absolutely normal.

I never had this error before changing to AMD and i tried various things to get rid of the problem:

- Reinstalled Windows
- checked game files for integrity via Steam
- reinstalled the game
- ran the game in Administrator mode
- tried all fixes i could find on the internet, including several startup parameters, config-changes, ...
- updated all drivers (including VGA) to the newest version available
- updated motherboard UEFI
- reported this problem various times by using the Driver-Bug-Reporting-Tool

Unfortunately, nothing helps.

System configuration:
- AMD Ryzen 9 5950X
- Gigabyte X570 Aorus Pro with newest UEFI-Revision 33h
- 64GB DDR4-3600 CL16
- Radeon 6900XT Reference with newest Adrenalin driver 
- Seasonic Focus PX-850 Platinum PSU
- Samsung 1TB 980 Pro SSD
- Windows 10 x64 20H2
- ASUS PG278QR WQHD-Display @144hz

First, i did think that this is some kind of strange system-related problem which cannot be solved, but then my girlfriend changed from a GTX 1060 to a Radeon 6700XT and is experiencing the exact same problem now. Her system is completely different to mine, but the problem is exactly the same.

Her system specs:
- Intel Core i5 11600K
- 16GB DDR4-3200 CL18
- Asrock B560 Pro4 Motherboard with newest UEFI
- Radeon 6700XT Reference with newest Adrenalin driver 
- EVGA 650W Gold PSU
- Samsung 980 Pro 512 GB SSD
- Windows 10 x64 20H2
- iiyama FullHD 60Hz Display


I would really appreciate any help, because this problem is really annoying and leads to missing the start of a game or even getting kicked / time-banned in competitive because i cannot join before the game starts. 

Thank you very much in advance for your time and your help.

239 Replies
Adept II

Doeas no one have any idea? Are there any devs reading here as well? This seems like a clear driver issue to me...

This is a user-to-user support engineers here. If you want to contact AMD use the supplied methods.

Thank you for your answer. I did contact AMD by using various channels (Bug-Reporter, Mail, ...), but unfortunately there does not seem to be any solution or even the will to acknowledge this bug...

Try That set launch command 


steam --> cs:go properties -> generals -> launch options

Adept I

It happened to me as well just yesterday. I did a complete removal of driver with DDU before installing the latest optional update and installed latest update for windows 10. Now it's not happening anymore. I own a 6800xt instead of a 6900 but I guess it's the same issue. I guess this could really be a driver issue. I also disabled gaming mode from windows settings btw.

Oh and I also removed the anti-lag function beacuse I heard it can cause problems in some games.

I contacted AMD by using the link @kingfish posted. They answered that they will look into this thread and forward the issue to the relevant department.

I hope this will get fixed soon

This is what i got as a response from the AMD support:



Dear xxxxx,
Your service request : SR #{ticketno:[xxxxxxx]} has been reviewed and updated.

Response and Service Request History:

Thank you for your email.
I understand that you still noticing the reported issues with latest drivers. The issue has been already escalated to team internally and its under investigation also please note it will take time to reproduce the issue from our end and we cannot comment on the exact ETA. Once developers acknowledge the issue that you can notice in the known issues in release notes, once its fixed you can notice that on the fixed issues in the driver release notes you can install that driver.  meanwhile I request to to please check the same from the CS GO support for any available patches or workarounds. 

Thanks for contacting AMD





Hi,  I would like to add to this as I have exactly the same problem. Have tried every single fix for this that both AMD support (slow and generally shockingly bad) have suggested. I work in IT / Back end datacenter network engineer so know my way around troubleshooting issues. This is very clearly a driver / game interaction issue most likely with the shader cache on level load from my digging around. 

To  add to what the OP has tested I have performed the following on my pc  with the following setup.

  • System configuration:
    - AMD Ryzen 3600X
    - ROG STRIX B450-F GAMING II - Latest bios Version 4602
    - 32GB DDR4-3600 
    - Gigabyte Radeon RX 6800 XT GAMING OC 16G 
  • - Corsair 850W plat
  • - WD_BLACK SN750 1TB High-Performance NVMe
  • Mi laser projector at 1080p 60hz


Tested full reinstall of

  • Both Windows 10 and windows 11 with basic driver and full amd driver installations. 
  • All bios options that can be tried have been changed. From virtualisation to overclocking. Ram timing 
  • Smart access memory 
  • Tried a different pcie slot as someone had that fix it on linux 
  • Crashed every single time on the second map load at the same point and will sit for around 2 to 3 minutes then recover and work perfectly. If its the same map again its absolutely fine suggesting a cache issue with loading. 
  • All the command line fixes / Repairing files. Compatibility / Direct x 9 disable and so on 

Game works flawless with the above hardware on both ubuntu and pop os so suggesting again driver / direct x / windows issue. 

AMD have acted like this issue does not exist and no one has reported this before yet numerous people have. I switched from a 3070Fe / Intel to AMD as I wanted to try them again after about 15 years and this little headache is driving me back to nvidia and really annoys me as I despise the way nvidia operate as a business. 


The problem persists with the recent driver version - nothing fixed, not even mentioned as a known bug.

I cannot even mention how much this problem and the ignorant way of handling from AMD-side is p***ing me off right now. 
Since i am now dealing with that problem for months, i came to the conclusion that i will sell my 6900XT and go back to the green team, even though i do not like their way of doing business either.

Great hardware - bad drivers, just like in the past. It is really a pity that this hasn't changed over the years.

Adept I

Any update on this? I am having the same issue with a 6800 non XT model. Rather annoying ...

Superpatate38 from reddit found this:

After lot of tries (many many....) I found a way to have it work properly. I noticed that the use of the launch option "-disable_d3d9ex" doesn't block anymore the map loading from the second map on - but then it crashes when starting the game. Then when I set the graphic parameter "Model / Texture detail" to "Low" all is working nicely.

So "-disable_d3d9ex" and "Model / Texture detail" to "Low" solved for me

( I tried for sure to reinstall dx9 but didn't help)


These two steps made the loading time issue disappear for me but I now have occasional crashes (cs go instantly closes without any error message) when playing the game or going back and forth between windows and cs go.


I'm on a new system (5600x CPU, B550 MB) with a fresh windows install, latest radeon driver.


No, AMD does not care about this issue. First report was at the beginning of may with links to this thread.
The problem is not even listed as a known bug, even though AMD said in every one of my tickets that it had been forwarded to the developers.

I am not expecting that this will be fixed soon (or fixed anyways).


same problem just like you bro, pls let me know if there's any reply!


I have the same issue, after changing from an older nvidia GPU. Very annoying!


Will go report it now, maybe help to bumb it up in the to do list..


Same problem here. (August 22). Apparently it won't be fixed.


Thanks, thats help me, now can play normaly.

Adept III

Try That set launch command 


steam --> cs:go properties -> generals -> launch options

This also worked for me but first set textures to Low in game, everything else maxed out is fine. Otherwise this launch command wouldn’t work game crashed

Adept III

After a 2 year wait for a decent (I thought) graphics card, 6700 XT, what do I find but this mess. Yes people play CS:GO get a grip AMD sort this out


I have the solution.


buy an nVidia card sorry storry but heh

Adept III

Just an addendum but as one poster mentioned, this happens loading all maps after the first is this the “infinity cache” failing to purge. No idea. But technology advances things get … slower. For some anyway

Adept III

1 other little detail, a look into the console shows texture files are failing to load one after another. As yet haven’t found a soltion but the problem appears quite clear

Adept I

Have the same issue with my rx6600XT.

Look around for solution and looks like this start commands fix the problem: -novid -high +fps_max 0 -threads 6 -nojoy -disable_d3d9ex -nopreload -nopreloadmodels -nopreloadsounds

They partly replace command cl_forcepreload 0 which seems not working now.

My conf:



Aorus evite v2

16db DDR4

CSGO starts from NVME

Adept III

In game set textures to Low everything else can be max. In the launch command box of steam enter


this came from a reddit post but worked perfectly for me, maps load in 1 s again. Experienced after upgrading from 570 to 6700 XT

Adept II

I am reading through these posts and knowing how long this issue been around and no solution so far is beyond normal for me, no way AMD does not give a single F about one of the largest esports title like CSGO.

Even though I created a ticket to AMD and I been told like 2 weeks that engineers are working on my issue and will update me about it, I still believe more in the solution which might come after the game ports to Source 2, than actual driver fix by AMD.

I have always been so loyal to them but such attitude does have serious impact on your overall experience.

I will post it here if they have come up with any solution/fix or at least workaround ( command in launch option does not count, it crashes the game and makes playing even more unplayable).

By the way I tried installing the newest driver - 22.10.2 still same I am afraid.


There will be no fix from AMD for this problem - they just do not care.

I first reported this issue in 05/2021 - this is far more than one year ago! Of course, i was told that they will investigate and update me, nothing happened. 

It is a shame that CSGO takes ages to load with a RX6900XT while it does not take 20 seconds on any crap-machine you can buy für 300$.

I am selling my RX6900XT right now, mainly because of this issue. Will switch back to the green team, even though not all is fine there as well.

Thanks for nothing, AMD.

Adept I

Same for me 6800XT and CPU both up for sale. Tried to switch back to amd as hated intel and nvidia but why should we have a totally subpar experience. 

Community Manager

Thanks for the posts flagging this, I have raised it with driver engineering for investigation. I'll update the thread when I have further information to share. 

A useful way to report issues is using the Bug Report Tool built inside AMD software, as this allows us to review the report from different systems. Instructions on how to do this here

Thanks for paying attention! 
Will use bug reporting tool for sure and hopefully many others too if thats the most effective way to raise concern regarding such cases.

No offence bud but thats utter tripe. This has been reported numerous times over YEARS!!! and nothing has been done. I flagged this via email and other methods and spoke with engineers and its still never been touched. Its a farce. 

Thanks a lot @Matt_AMD for deleting my post in which i wrote something judicial about your product policy and the way you are handeling your customers.

You probably deleted it, because its not that good for PR if a customer mentions problems known for over one year in connection with switching to another graphics card producer.

Not worth mentioning that my new Nvidia card is working flawlessly and i am still glad to have sold the RX6900XT.

Feel free to ship a 7900XT to me as soon as it is available and i will deliver anything needed to investigate the issue, since it is reproduceable very easily - that would be some kind of positive PR. Dont get me wrong, it is good that you are investigating now, but it took ages for you to begin.

Ofc, feel free to delete this post again for some more good PR - will be sharing it on Reddit.

Adept II

22.10.3 is out. Uninstalled previous driver with DDU, installed a new one and well... issue is not fixed.

Adept III

As mentioned elsewhere probably just waiting for the game to move to a newer engine. Might be nice to let us know and even describe a workarround but don’t get over excited

Journeyman III

I have the same problem as well Idk how long it's gonna take AMD to fix this! I'll report it thru the AMD software too. It's driving me crazy I swear spending a lot of money just to have this problem..

Adept II

Welp, the workaround mentioned here, which I tried a long time ago, which actually worked for me but with a side effect that crashes my game every 30min or so is now wokring flawlessly. I received no response from AMD as well beside "please wait the whole eternity and we might come up with a solution,"so screw AMD and their cards, RX6900XT is definitely gonna be my last AMD card.


Is that the workaround regarding launch option "-disable_d3d9ex" mentioned on page 2 of this thread?

We have tried reproducing this issue several times, however in our testing the second map loading time takes 10-20 seconds, and not the 1 minute as mentioned.

We are trying to understand why you see the longer loading times and we do not. We have followed the steps suggested to reproduce the issue, which has been provided by several users, but so far, we do not see longer loading times on the second map.

Is it possible that it only happens on a particular map? Does it need to be a particular game mode? Do we need any custom maps, mods or command lines active for the longer loading time to occur?

Appreciate any extra information that folks can provide, as we've been trying to reproduce this issue for quite some time since it was first flagged to us. 



No. This happens at every single map. It does not matter if it's a public server or if it's a private server running for example a workshop map.

The first map load is fast, and subsequent loads are slow, unless it's to the same server, with the same map / a game server reload.

The issue can triggered in more ways than those mentioned by other users, one way I found was that after going into a server, then leaving it, which has now triggered the issue. If I now choose to change my resolution, the time it takes for it to change can be measured in minutes. Easily 1-2 minutes of black screen. 

Community Manager

Just as a follow up to this, we did extended testing playing for around six hours consecutively over two days and were able to reproduce the issue 3-4 times. That is, 3-4 times the map loading was 1 minute long rather than 10-20 seconds long.

You should try playing on comunity server browser, that’s where I noticed it and my friends also, try a server that is known to change maps regularly. Myself after purchasing a new pc (5600x/6700xt) am facing with the same problem, like one week after I started playing this problem started. Ps. my friends neighbour is a BNE clan member (a pro CS:GO team) and he also complained about the same problem when he was playing on Amd gpu.