Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Adept II

7900xtx MW2 and BF2042 issues

I can go into a game and turn all settings to Ultra and it plays perfect, looks amazing.  

As soon as I get out of the game and close the game and try to re launch it it will not go past the splash screen, it just goes into a cycle.  I then have to restart the PC, it will open up and go onto Safe Mode.  IF I leave the settings on default (low Res) it will perform normal.  Any changes to quality (even on setting) it will repeat the process.  I loaded BF2042 to see if it was just MW2 and the same thing happened other than no safe mode - just the splash screen shows up and dispappears.

I put in a case with AMD and I did the following with no change in results, I asked to return the card and they said it was past my 30 day return.  

Any ideas that will help?

Its an OMEN PC with an upgraded RM1000x.  It bothers me that I spent $1000 and have to deal with poor graphics.  my RTX3060ti looked much better and weas stable.

I am running a 144hz 1080p monitor.. so the card is way capable (planning on gett9ing a 4k)

Here is what AMD asked me to do and I did it and not help:  (THANK YOU)

To get the system into standard configuration, follow the steps below:
1.I request you to please make sure you are running run all hardware components at their default factory settings.
This would include the processor, graphics card and system memory.
Processor and system memory changes can be reset to factory default settings in the motherboard bios.
For instructions on how to reset your motherboard BIOS to default settings, please refer to your motherboard manual or system documentation.

2. I suggest you to please perform the clean boot and check the issue status.
Please refer the below link to know how to perform clean boot.

3.I would suggest you to do a clean installation of AMD software with driver for windows OS by using the AMD cleanup utility and check the issue status.
• Download AMD Cleanup Utility
• Driver
• Disconnect the internet.
• Restart the system.
• Use the AMD Cleanup Utility to thoroughly remove any previously installed AMD driver files, registries, and driver store. Please refer the following link for more help.
• Install the driver

1 Solution

So I fixed it. The OMEN gaming center had to be uninstalled. It competed with adrenaline I believe.  

View solution in original post

2 Replies
Adept II

One thing to note - The RM1000x PSU wires were a lot thicker than the OEM PSU so the side panel is off.  


So I fixed it. The OMEN gaming center had to be uninstalled. It competed with adrenaline I believe.