Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Journeyman III

7900 XTX issue


I just switched from 6900 XT to 7900 XTX (ASRock Taichi White). I also changed 12700K to 14700KF and my PSU to MSI A1000G PCIE5.


Everything seems to be working perfectly fine, normal, fast boot, when I open applications, benchmarks (Cinebench and Superposition), I can run them without them crashing, with good results. Same goes for applications (and games) like Steam and Epic. Now the issue...

When I turn the PC on (or even restart) and do whatever, for example browse Opera, and then, a few minutes later, I try to open AMD Software, it just does not open. Same thing can happen when I restart the PC, open AMD SW, open Photoshop, open a benchmark software, they all run, everything seems fine. However, when again, a few minutes later, I try opening Epic, I get an error saying my GPU is not supported. Steam gives me an error saying D3D11 compatible gpu is required to run the engine. Another example, restart, Opera, Steam, Epic, all opened right away, everything seems okay, but when I open Photoshop, I get a warning/error saying a driver update is recommended and that OpenCL is unavailable.


The examples could go on, I can not actually explain what is the turning point, when the gpu stops working, or just works partially... When I open Photoshop right away, it works and I can use it even at later stages, as previously said, a few minutes later. I honestly don´t understand what or why it´s happening. I tried DDU uninstalling previous drivers and installing the new one, uninstall and reinstall AMD software, I would like to not have to reinstall windows, so please, if there´s anything else I should write down, ask away and PLEASE help me. I´ve been waiting for this card for way too long not to be able to use it normally.


Thank you in advance.



EDIT: I tried uninstalling all AMD drivers and installing just the driver instead of the full install option, disabling SAM, turning on and off XMP, nothing seems to help. It´s completely random, but what I just realized after giving it a shot, even if I´m at a stage where it stops working and for example Epic Launcher doesn´t open, I can open device manager, disable and re-enable my display adapter through there, it works again. It´s some kind of a stupid timeout or something like that.

5 Replies
Journeyman III


Adept I

did you try to use DDU in recovery mode to uninstall all the drivers? 
I also would try to set the X16 pcie to Gen. 4 instead of 'auto'.


Thank you for the answer.

Yes, I uninstalled all the drivers (several times) with DDU in recovery mode, with the AMD cleanup tool, and the two tools combined as well. I just tried your next suggestion as well, it didn´t change anything, the issue persists.


what driver versions have you tried ?  the current one is 23.11.1

Asus ROG Strix B550-F Gaming Wi-Fi II - Ryzen 9 5900X - Deepcool LT720 360mm AIO - 32GB G.skill Ripjaws V Series DDR 4 3600 - Sapphire Nitro+ 7900XTX - Corsair RM1000x - Corsair 5000D Airflow

I tried the current one, the one before that, and an older one too, can´t remember which one exactly - no change though. I´m currently using my old GPU, the 6900XT one, absolutely no hardware or software change was made, just unplugged the new one and plugged this one in and everything is working as supposed to.