Showing results for 
Search instead for 
Did you mean: 

Graphics Cards

Adept I

6900 XT high idle memory clock

I know there are some other people out there with the same issue, but AMD needs to fix this as nVidia had the same issue in the past and they fixed. 5700 XTs, 6800 XTs, 6900 XTs, and tons other that are not aware of this because they don't monitor clocks and temperatures as they use their expensive PCs.

I have moved from a Radeon VII with a dual screen setup both 1400p 144Hz without any clock issues for over two years to a 6900 XT which stays with the memory clock stuck at 2000 MHz while on Windows, browsing etc. Why that?

Can't you AMD care a bit more about your consumers and fix this?

If I set both screens to 60 Hz the clock goes down, that is, power draw goes from 45W to mere 15W, memory temperature goes from 55C to 36C, and clocks go from 2000 MHz to 190 MHz, and if completely idle, around 20 MHz.

It is a decrease in temperature of almost 20C, and 30W for the electricity which is waster for nothing. That is, something is going on and the memory is working for nothing also drawing electricity for nothing.

19 Replies
Adept II

i got a stupid answer, but can you underclock and undervolt the card for temporary, just a weird solution but if you want to do it, but i suggest to check the customer care first before you do something to break the 2000$ card 

Adept II


One of the common workarounds is to adjust the blanking time using a program like CRU.

I've noticed the high memory clock on my RX480/1080p 144MHz monitor and on both my 1440p/144MHz monitors with the 5600/5700XT cards.

I've never seen anything official, but I believe the memory is cranked up to make sure it can feed the higher refresh / resolution displays. While some will tell you this is normal, I agree that the extra heat and power usage with the higher memory clock is not awesome.

CRU takes some playing around to find the right settings. For example, I couldn't find a setting for my Asus Strix XG27VQ that would work at 144 MHz, so I clocked the refresh down to 120 MHz and the memory clock went down to around 200 MHz (down from 2000).

I also found cables` can make a difference as well. I bought new DisplayPort ver. 1.4 cables to make sure they supported the fastest throughput.

My setups are single monitor configurations, so it may be that your multi-monitor config may still speed up your memory clock.

Congrats on actually getting a 6900XT btw

@MisterEHi! I've downloaded CRU but I am not sure how it works. I've tried couple of times (working is not allowing me to spend too much time in the PC lately) but I ended up with a black screen. I am going to try again. That is a strange issue, I've never had this with the Radeon VII with the same pairs of screens.

You are correct when saying the clock is high to be able to "respond" to the 144hz screens and just throttles down when set to 60Hz, it's annoying specially because of the waste of electricity, and some extra temperature.

Both cables I am using are quality ones, so one less thing to worry about. Ideally I would not want to set it to 120Hz because then I will be limited to 120FPS, and this card is very capable to surpass that with ease.

Thanks for the congrats, I was looking forward to a 6800XT for months and I could get this 6900XT for really good price, almost MSRP!

Same here. Very annoying indeed.

I have a Samsung  165hz 3440x1440 and a 6900xt.


I have to clock the monitor down to 100hz because anything above that and the mem clock on the gpu skyrockets to max and stays there just sitting on the desktop.


It is problems like this that do not bother to even be noticed that get my pantys all bunched up

I did not succeed yet with CRU but for now I set both screens to 60Hz, and maybe this is the way, AMD won't fix this as it is supposedly the monitor specs that cause this. Not just this issue is bothering me, but now my unit is stuttering in games every 10 seconds and I have not idea why.


Make a custom resolution with a 142hz refresh rate. 

Thanks @rawintellect! I will try now!


It did not work. I have to reduce both to 60Hz in order do work.

Hi again,

Sorry for delay.

Can you post the display specs of your monitors at 144 MHz as listed in the Radeon Software?

I'm interested in seeing the pixel clock speed. I came across a Reddit thread that went over this issue in depth, but having trouble finding it again.

Another thing with CRU is that you lose the setting when you perform a factory reset install of the newer Radeon drivers. I have I pic of the settings which I re-apply after the install. If I'm being lazy, I just to an upgrade and avoid the work that way.

Custom resolutions can be tricky especially if your monitor doesn't respond or allow you to get back to a workable setting. That's where working with the CRU restart app helps as it allows you to hit F8 to get back to a viewable setting.

You can add a detailed resolution in CRU based on the presets e.g. Automatic (HDTV) and then modify the clock speed and blanking. You have to make sure your resolution is at the top of the resolution list and then run the Restart app to restart the driver.

I'll see if I can find that Reddit thread again. 

Also, at what monitor refresh timing does the card speed up the memory clock? Or is 60 HZ the only speed when the memory clock is down?

If I put my monitor to anything above 100 refresh rate, even 120, that is when the mem clock goes up.

Samsun G5 34' ultra wide 3440x1440 


@MisterEHi, sorry for the delay, working a lot lately!

Here they are, both screens are VA.

The main screen, 32" 1440P 144Hz

Timing Info - Horizontal - Vertical
Total - 2720 - 1481
Display - 2560 - 1440
Front Porch - 48 - 3
Sync Width - 32 - 5
Polarity - Positive - Negative

Interlaced/Progressive - Progressive
G.Pixel Clock (KHz) - 580070
G.Refresh Rate (Hz) - 143.998
HDMI Link Status Monitoring - Disabled
Current Link Settings - 5.4 Gbps x 4
FreeSync Range - 48 to 144 Hz reported by display

The secondary screen, 27" 1440P 144Hz

Timing Info - Horizontal - Vertical
Total - 2666 - 1543
Display - 2560 - 1440
Front Porch - 8 - 25
Sync Width - 32 - 8
Polarity - Positive - Negative

Interlaced/Progressive - Progressive
G.Pixel Clock (KHz) - 592000
G.Refresh Rate (Hz) - 143.912
HDMI Link Status Monitoring - Disabled
Current Link Settings - 5.4 Gbps x 4
FreeSync Range - 48 to 144 Hz reported by display

And answering the other question, the card speed up the clock at any refresh timing but 60Hz in both screens. I've just tried 60/100/120/144, did not try anything like 75, 80 etc.



So I found the Reddit threads.

This is the one that tipped me off to using CRU:

The second actually links to the first but has a little more info:

This issue has been frequently reported, even in these forums:

The trick in CRU will be to create a 144 MHz setting with as much blanking as possible without exceeding the pixel clock of the monitors. I confess the clocks on your monitors seem lower than what I experience (600+).

One of the original Reddit thread posters had this to say:

  • Display link standards (DVI, HDMI, DP) have maximum bandwidth limits

  • Sometimes the bandwidth needed for a given resolution is slightly higher than the link allows for

  • Display manufacturer reduces amount of "blanking" pixels, which are at least partly a vestigial remnant from CRT days. This lowers the overall bandwidth so it will fit over the link.

  • GPU can only change it's GDDR clock speeds during that blanking period. But the blanking period has been reduced to almost nothing, so it goes to full speed since there are insufficient gaps to adjust the speed on the fly.

It's hard to tell if a multi-monitor set up will work. A lot of people haven't had much success. It would be interesting to know if you can pull off a lower clock with just your main monitor (not your goal, I know).

Sorry I  can't provide a definitive answer. If you do manage to get a setting to work, definitely post it as there are ALOT of people looking for working scenarios.

I got tired of the trial and error on my backup gaming system, so I just live with the notch down to 120 MHz (VRAM clock sits at 300 MHz at idle).

Hope this helps!





@MisterEthanks for pointing out the threads, I will be off on the weekend and then I will take a look at it and give a try.


@MisterEHi! I've tried a bunch of possible settings and I believe it just does not work with dual screens. I will trying, but the solution for now is keeping both screens at 60Hz.

Thanks for trying to help.

I was troubleshooting this last month on my RX 6700 XT & ended up using a German thread for instructions on what to do. All the info/mini-guide available here: ^_^


Hi @jo3yization thanks for the suggestion. I am not really hopeful it will work with a dual screen setup but I will try and report back!

No worries, and yeah it might not allow very low downclocking, but I think getting ~half speed clocks would be very possible, you'd have to make sure to increase blanking on both active monitor profiles & the values would be different for different model monitors, much higher chance of it working well with good cables & the same model. Good luck!

Adept II

Check the new driver out (21.6.1). 

It fixed the always max mem clock for me, ahtough running a one monitor setup.


Sadly it did not work for me. I saw some people mentioning this around Reddit and but as I am with dual screen it did not work. But I am glad it was addressed for the people using 01 screen!