Showing results for 
Search instead for 
Did you mean: 

General Discussions

Adept I

X670E Master M.2 issues

I have some issue with the bottom two M.2 slots.

If I put my OS drive on the third M.2 slot, the system becomes extremely laggy. If I put my OS drive on the first, second, or fourth M.2 slot, the issue dissapears.

On the fourth M.2 slot, "device harddisk3 dr3 has a bad block" error keep popping up when moving large file from my other drives to the SSD on the fourth M.2 slot.

All of my drives are brand new, so I'm assuming that the MB is faulty or the chipset is unstable.

Does anyone have same issue?

1 Solution
Adept I

After few weeks, the issue is finally resolved.

Gigabyte replaced my X670E Master with a completely new one, but I'm tired of wasting time on this useless piece of rubbish platform.

Anywho, I switched my platform to Intel I9-13900k. No issue so far. Couldn't be happier:)

For the record, all parts are exactly the same except CPU and Motherboard. 

View solution in original post

26 Replies

have you run a SSD diagnostics to see if your SSD has any bad blocks on it?

That would cause the SSD to slow down quite a bit if Windows is trying to write to a bad block. Eventually it will stop trying and move on to a different good block.

Run in a elevated Command Prompt the following two lines separately by clicking on  "enter" key each time  to check your SSD:

wmic diskdrive get status

wmic /namespace:\\root\wmi path MSStorageDriver_FailurePredictStatus

You can copy and past the above command in Command Prompt.

The first command line lets you know the status of all your internal SSD and HDDs. If it says OK then everything check good.

The second command line will predict if your SSD or HDD will fail. If all comes back FALSE than everything is fine.

This is the way mine looks. I have several HDDs in my PC:

Screenshot 2022-12-06 114516.png

To check to see if your SSD has any Bad Blocks on it run the same elevated Command Prompt :

chkdsk /f /r  to check your Windows drive or any internal/external SSD or HDD you have connected.

That command will scan your SSD and if it finds any bad blocks it will try to repair it if it can't then it will tag it as "Bad" so that Windows will not try to write to the specific block anymore.

If you keep getting bad blocks that is a good indication your SSD or HDD is going bad and will eventually fail.

NOTE: This is the first time I see mentioned the first two command lines in checking to see if your SSD or HDD is good or going bad. Nice command line to use in the future.

EDIT: Many M.2 slots may be configured to be used by other ports like SATA Ports. You need to go to your Motherboard's Specs and see how all 4 M.2 slots are configured.

Also, at times, M.2 slots may be shared and the speeds might be cut in half. Thus the need to check your Mobo Specs on M.2 lanes.

Generally the first M.2 slot is controlled by your CPU and the rest by the Motherboard's Chip drivers.

Thanks for the reply.

I've already done chkdsk /f /r and smart scans a couple of times, the issue still presents.

I also tried other two brand new M.2 drives, still the same.


Sounds like a bad motherboard. I would open a Warranty Support ticket and find out if they believe you motherboard needs to be RMAed  to be checked or replaced.

Since you tried more than one SSD on the M.2 slots  with the same results seems to indicate a defective motherboard.

I doubt a corrupt Chip Set driver would cause those type of errors. It is possible the physical contacts on the M.2 slots might be bad or doesn't make good contact.

Anyways that is just my opinion. Maybe someone else more technical might come up with a better theory.

NOTE: Your Windows SSD Drive should always go on the first M.2 slot which is controlled by the CPU.

Thanks for your reply.

Is there a reason why the OS drive should be placed in first slot?


Sorry I gave a wrong reply in my previous reply concerning installing the M.2 OS Drive in the first M.2 Slot. I was thinking about the installation of a GPU card on the first PCIe slot.

But it depends if you have a M.2 SATA SSD or M.2 NVME SSD drive.

If you have a SATA SSD M.2 drive then it doesn't matter which slot you install it as long as it is the fastest for SATA.

Some M.2 SATA slots share with your motherboard's SATA ports. so if you use a SATA M.2 that shares a SATA Port it will disable that SATA port. The motherboard Specs will indicate this if it applies to any of your M.2 slots.

If you have a NVME SSD then you would install it in the best or fastest NVME M.2 slot. This is normally the M.2 slots support by your CPU unless the Chip set is able to support the same speeds as the CPU M.2 slot.

This tech site about M.2 slots explains it in a simpler manner:

Does it matter which M 2 slot my boot drive is on?
If you're using M. 2 NVMe drives, you'll want to prioritize using slots that enable those NVMe speeds. With M. 2 SATA drives, your choice of slot doesn't really matter as long as you're aware of any potential SATA Connectors being disabled by their use.

Some M.2 slots use CPU lanes and some M.2 slots use lanes from chipset. Perhaps those that use CPU work properly and those that use chipset, don't. Perhaps problem could be solved with BIOS update, chipset driver update or M.2 drive firmware update. If not, likely a motherboard issue.

One thing to check is, when you installed M.2 to those problematic M.2 slots, was there a standoff on motherboard already or did you put one in, or forgot it and just used a screw? It there is no standoff, it can bend M.2 drive and then connection to M.2 slot can be faulty and cause issues.




There are stand-offs preinstalled on the MB, so I just put the ssd in and screwed the screws in.


You could install SSD-managements software from your SSD-brands website and run it. Update firmware to drive if there is one. Sometimes they can improve compatibility.

Also did you install chipset driver from Gigabyte or AMD as chipset driver from AMD's website is updated more recently 



So two connectors work and two do not. Likely the ones on bottom are those from chipset.

Problem is, it could be broken hardware or could be something that can be fixed with update. I think I would contact Gigabyte if this is a thing they know and update is on it's way. If not... RMA.

I think I will RMA the board. Thanks for the help.

Not applicable

FIRSTLY did you ever encrypt the drivers? use partition managers? have viruses about randsomware or crypto mining? if so you must secure erase it in BIOS.. i mean secure erase theres an option but it might require you to install your drive makers software and toggle the secure erase in windows first. If you are on windows 11 and TPM secure boot setup you tried to custom or modify secureboot options its maybe stuffed up and requires as secure erase too. leave it to standard unless you understand how they keys and certificates work by that i mean DO ENABLE THE REQUIREMENTS TO INSTALL never bypass them but theres an option for standard secureboot keys on mine or custom. dont fiddle with custom. 

If you tried to enable store MI not knowing what drive tiering is or how it works, it zeroes a drive and you dont use it or see it, its speed bosting buffer cache for the others so your fastest drive becomes unusable and all your slower drives perform as if they were your fastest almost completely its ideal for webservers. but if you screwed up just umm secure erase in bios, try reset bios to defaults. 

I know a guy pretends to be an IT tech for a large national company working citrix remote administers like a thousand or more PC's on his network in multiple sites. but stupidly bought intel/nvidia fake stuff and off brands. he claimed his Adata SSD's were having read errors and issues. But they were rated for up to 550MB/sec PCIE gen 3 M.2 ULTRA.. and he used an intel 9600k or whatever and a lame intel board with not even half that in PCI express lane bandwidth. and tried to force it in bios and drivers to run at the ADVERTISED SPEED not what his fake hardware was pretending it could do. So your x670E board, is it M.2 ultra or express or some number after M.2 is it same number for all slots and are you setting pci express gen 4 or gen 5 for NVME that is PCI E gen 3? if so you will have issues. 

MOST IMPORTANT. Originally OS cant boot from NVME drives at all because its supposed to be a stick of RAM made into a HDD and be about as fast as RAM.. but for some reason intel and nvidia and microsoft cant do it but AMD and samsung and the people who made the free open standard could.. so it was crippled to be way way worse latency and seek times than the decade older sata stuff and regular SSD. which intel then took some older IDE master slave tech and drive tiering like AMD store MI in ryzen and threw the tiniest piece of not nearly as crippled NVME in front of an SSD as a drive buffer or cache and called it optane or something.. i dunno..

point is.. because NVME originally was sooo crippled by fake tech companies like intel and nvidia.. it was far worse than SATA in response times so many smaller files like the operating system games and apps were actually for realtime memory accessing and writing better off with SSD so it wasnt possible for the first year or so on majority of boards to boot from NVME at all. You also often have to install the NVME drives software like in samsungs case samsung magician software and maybe enable RAPID mode for their 'benchmark' scores to be what they trumpet about which can create and use a 2GB RAM drive of your PC system memory dedicated in some cases. You must also install the AMD chipset drivers and may need to set your bios to RAID MODE or AHCI depending on what you're trying to do or if its for the multiple NVME slots. 4NVME slots sounds like an awful lot to me, ones i've seen with more than 1 or 2 even just the 1 or 2 sometimes the second one is half bandwidth lower spec like a TV with 1 HDMI 2.1 port and 3x 2.0b or a monitor with only one DP 1.4 port.. often the 3rd or 4th NVME port is shared with the sata controller and lower bandwidth/half. my PCI express gen 3 on an x470 board with m.2ultra needed 38gigabits bandwidth of the 40gigabits perlane advertised on my board.. intels boards had 15 at the time. but i installed my sata raid drivers, did a VOLUME RAID in bios and software striped RAID in windows disk manager i think it was?  remember when install AMD chipset and and adrenaline drivers after they unpack check for no error codes before click finish on the finish button page. if it says error you think its working but it isnt. You should also then go to c:\AMD where the setup exe files extracted and run all the exe setups individually under packages and in device manager add all the drivers after you put them in an AMD folder in syswow64. once i had my stuff sorted my several samsung SATA SSD's and maybe one or two ADATA NVME's all 1TB could with maybe just the several SSD's reach about 7GB/sec in benchmarks and with the NVME's hit maybe closer to 9.6GB/sec on maybe it was windows 11 beta or win10 with ryzen 2700x asrock x470 gaming k4 but i tweaked the mainboards RAM timings completely had some of the lowest latency best DDR4 gskill on the market it was the cheapest best timings gskill when DDR4 RAM first hit stores and boards with DDR4 magicked into existence. the advertised 550mb/sec was well surpassed. not sure if store MI was actually working or the samsung RAMDISK or whatever or me attempting to install SATA raid drivers multiple times made it work multiple fast. 

If you do have half the bandwidth you can cheaply get a PCI express to NVME m.2 ultra riser card or a USB 4.0 drive enclosure or maybe something thunderbolty but i'd avoid that crap. if you have thunderbolt on try disabling it. as it could allow you to have the full 4 drives with full speed if it was a lack of bandwidth or FULL m.2 speed ports.




Why are you so hostile towards me like I was doing something wrong?

I merely installed Windows 10 on one of my drives and encountered some connection issues.

Thanks for sharing your little rant I guess, but that didn't help anything.


I agree with @elstaci .

Post your system components brands and models.

Famous last words of a RedNeck "Hey Ya'll, WATCH THIS"

CPU: 7700x

MB: Gigabyte X670E Master

GPU: Gigabyte RTX4090 Master

PSU: FSP Hydro PTM Pro 1000W Pcie5.0


WD SN850x 2TB

Samsung 970 EVO PLUS 2TB

Gigabyte 2500E 1TB

MX500 2TB *2

Which storage device is the OS on?

Try removing all others and installing the OS in the second slot.  Restart.

Now install one of the other drives and restart.  If all is good.  Remove that second drive and install a different one in that slot. Restart.  Same procedure with the nest drive.  If all is good with the second drive installed in that slot, remove that second drive and install it in the third slot.  Follow the same procedure as above for the other drives.  Then move to the fourth slot and follow the same procedure.

Now you can install one drive in the second slot and procede to check what happens with 3 drives installed.

Hopefully you can determine when the problem becomes an issue and with which device.  

Famous last words of a RedNeck "Hey Ya'll, WATCH THIS"

I've tried clean installed OS on 850x, 970 Evo plus, and Wd blue. (And gigabyte 2500e which is a garbage ssd that I'm not using rn)

The issue appears no matter what OS drive I'm using.

I'm pretty sure it's the m.2 slot that is broken, but Gigabyte said otherwise. They told me they had tested the slot, and it was working properly.



I would tend to agree with you.  That's why I build with MSI, and I might add the X570 and future X670 chipset.  If I can' get an MSI go ASUS.  I have a Gigabyte on a Windows 7 system and hate it with a passion.

Famous last words of a RedNeck "Hey Ya'll, WATCH THIS"

I looked at the specs on this board on the Gigabyte site:Gigabyte X670E Aorus Master .pngGigabyte X670E storage.png

You say that you have 4 m.2 slots and Gigabyte says you don't.  Its not the first time I have run into this problem where the Specs info is outdated and you have something different than they are showing.

So, on that assumption when other brands have 3 or 4 M.2 slots the 3rd and 4th are PCIe 3 x 2.

That is what I'm seeing in the specs sheet from Gigabyte.  The 970 EVO is a PCIe3 device where the WD SN850x is a PCIe 4 device.  I assume that your OS is on the WD drive.  There would technically be a drop in performance but I don't think it would cause extreme noticeable lag.

Now you mentioned something about a "bad block" error that your getting and with the price we pay for these I would submit an RMA ticket.  Simply because if your getting bad block errors that drive is not not right. 

Famous last words of a RedNeck "Hey Ya'll, WATCH THIS"

Top two slots are from CPU. The rest are from chipsets. 

Only the chipset ones are giving me headaches.


I have three 2Tb NVMe's all of them different brands. First I installed one to new system and installed operating system on it. Then I added the other two so I wouldn't have to download everything on them again. For some reason one of them doesn't show up in BIOS, nor in Windows. Ended up swapping their position and now all of them work.

Adept I

MB comes back from Gigabyte. They said the MB was working properly.

I guess I'll rma the CPU next. 

Should've bought the other brand. This is wasting too much time.

Adept I

Now my PC won't even boot when RAM speed is higher than 4800.

$800 for a such problematic platform. Greaaaaaaat.

Adept I

After few weeks, the issue is finally resolved.

Gigabyte replaced my X670E Master with a completely new one, but I'm tired of wasting time on this useless piece of rubbish platform.

Anywho, I switched my platform to Intel I9-13900k. No issue so far. Couldn't be happier:)

For the record, all parts are exactly the same except CPU and Motherboard. 


I´m experiencing same problem with a Gigabyte X670 Gaming X AX.

Strange is that SSD in fourth slot worked, not anymore with whatever SSD I try, BIOS update or rollback and CMOS Clear.

Just to help, you said Gigabyte sent you a new board, did you try it to check if problem was solved? It´s not clear on your answer if you tried it again on the new board or just moved to intel where it all worked.

Journeyman III

Hi I have the same issue on my Motherboard x670e Gigabyte Master. I think is a driver issue or mess from AMD or Gigabyte. I change all, CPU, Mainboard, and Ram, nothing work! And it makes no diverence if you have array on chipset or cpu. It only slow down to the slowest part! I think AMD have some Driver-problems with new Windows 11 2H22,too to fix it. Some issue i know is not to install Windows on second array, this will crash. Maybe need to wait for driver update if they can fix it, or change to intel! Remember you have luck some Pcie powermangament deaktivate or dynamic tick can help you to fix. I'll try but nothing work! Deaktivate raid controler, try stripping from windows, that all you can do. Or buy Intel motherboard !!! Grap to spend 500 EUR for Board wo dont work finaly 🤪



PS: it shows up, The IO Operation At Logical Block Address for Disk was Retried!!

Thats no Hardware issue! I like ppl wo write so much grap. It's driver issue or powermanagment problem!

And still remember XMP is a easy way overclocking. Give you 1-2 % more speed. Ram is testet on oc, but not you Front Side Bus or cpu. It will destabilize your System and you will lose you warenty!!! Hint try to stablize your system first

Journeyman III

Asus x670e-f gaming wifi


32x2 Corsair 6000MHZ C30 Hynix. No errors on at least 4 test I have done with memtest86 (new version) and nonfree memtest86 and microsoft own memory test.

Similar have happened to my motherboard. The pcie buss connecting to AMD USB Host 20gig is broken. Also LAN that is connected via chipset is broken. Other problems too.

When example downloading inboard LAN Intel 220 something  my machine notices faster the error and mouse and screen freezes (dunno if actuall freeze). Audio also show IRQ something error and crashes the PC, before this bigger failure. Disabled wifi / bt, audio in BIOS (forgot to disable LAN, I remember now).

Connected USB to NVME adapter on USB 3.1 20gbit and USB flashdrives show shecksum errors.

Downloading from internet example hefty 700mb intel drivers cannot be done.

Errors happen in Linux also, where the problem is even higher as the machine gets unresponsive and needs a hard shutdown. In windows it mamages a soft shutdown but takes a long time.

I circumvent these errors by using breakoutboard (adapter or whatever) with USB 2.0 connected to motherboard header inside case. And using USB3.0 to LAN adapter on unaffected USB 3.X Host to get 1gigabit. So some pci lanes are broken but not all since I can use the two USB 2.0 headers (giving 4 x 2.0 USB). I wish to write a detalied description so others searching will find my and your post.


What I am going to try is to figure out if it is a CPU or motherboard error somehow. Don't know yet how, reading description on the AMD USB host what pci lanes it is connected to can help maybe. Going to try and crosscheck with LAN and unaffected AMD 3.2 20gig HOST, affected HOST and a direct CPU pcie lane to example NVME slot 1 (0) or GPU.


Some ports on the rear goes to the affected host and some not. I was thinking about all went to AMD CPU directly but I am no engineer in that yet.


Many things to learn in troubleshooting.