Showing results for 
Search instead for 
Did you mean: 

General Discussions

Adept II

Trying to figure out what's wrong with system not supplying power to GPU No Signal, Post HELP!

Hello I hope someone can help me figure out a solution here, it’s a long story, I recently purchased through Amazon a Asus 450-F ATX RGB motherboard, about a week or so ago it arrived, I was a little too impulsive and took out the CPU a Ryzen 1700 out while the case was vertical, first big mistake, the processor fell onto part of the chasis and some pins got bent, I’ve bent back a pin or two in my day on a CPU so I wasn’t completely freaked out, but this wasn’t just one pin it was at least 3 and I didn’t want to take any chances so I started looking online for tips on how to fix pins, second big mistake, 1 tip said use a credit card, than I found a video by Jayz2cents about how a razor blade will fix bent bins, in the video he shows how it’s done with a double edge razor, all I had was a flexible safety razor so I tried it, big mistake #3 not only did I bend more pins but I broke pins left and right, next day I got hold of a double edge it worked to unbend pins but it also broke more pins than I could count saved as many as I could in case I would try the old pin the motherboard socket trick, but with the loss of so many pins and not being able to get the bent pins straight enough to get the cpu in the socket that was a hopeless endeavor.  So I had a nice shiny Ryzen 1700 medallion that some day I may turn into pendant or something or sell for parts.

So I broke down and bought a new Ryzen 3700x from Newegg through eBay.  Of course after what happened with the CPU I was gun shy about doing any further motherboard swap or upgrade, so I called my local PC repair and set up an appointment for Monday to have them do it for a base fee of $60, than I got the brilliant idea afterwards to see what I can DIY and maybe save a little money and time, that was big mistake #4. I set out to test the new board ala bench test on the box it came in, i jumpered the power pins, got everything hooked up with the Seasonic 620 Watt PSU, which I have tested with a multimeter and it’s putting out 12 volts or more and the fan is spinning, but I question as to whether I have enough watts to run a Ryzen 3700x and Rx480 combined although I haven’t found any good info online that says it’s too little and my 1700 ran just fine with the RX 480 on my Mini ATX board.. I carefully installed the CPU with no issues. So this is what happens when I power up with the Asus ATX board, RGB fan works no issues, no power to GPU, GPU fan tried to start I can see it move for like a mil second. GPU doesn’t light up, RGB Ram lights up just like on Asus board  No Beeps, Orange DRAM light blinks, and system shuts down after a few seconds and will not go back on till power is disconnected and reconnected but if the 8 PINS 12 Volt EATX is not connected, the orange light doesn’t come on, and fan stays on, and the system stays on with no power to GPU and no video signal or POST tested with HDMI and DVI and even tried a different DVI Nvidia GT card. I swapped RAM in all 4 slots tried different RAM same error. Insured GPU was well seated, Didn’t check to see if CPU heats up. Some other  things I have already tried CMOS reset took battery out,  reset BIOS on jumpers on motherboard, unplug 24 pin ATX and replug in, not sure what else. I did make sure I observed ESD guidelines and wore a grounding wrist strap.

I found one post to reddit that was exactly the same issue with the same mobo but there were no replies. After 5-6 hours of troubleshooting and looking for answers online with little progress, I figured  it’s a bad mobo and I should just send it back for a replacement and worse case I go back to my old mobo till I get the replacement, there shouldn’t be any issues, only new hardware  is the CPU and and there are no bent pins on it. Only other thing would be the Coolermaster AIO but how would a cooling fan be an issue affecting this?  So I carefully swapped everything back to my Mini ATX Asrock B 350M HDV, everything connected but a hard drive, fire it up and no joy, not the same problem because if the 4 pin AETX is plugged in I have the 24 PIN ATX plugged in as it should, there is no issue like on the Asus board, I checked the CPU to see if it heats up and it does so I can rule that out, no beeps, there is no video or power to GPU. So I remembered the other day I tested the GPU on the only other desktop we have a Mac Pro, it doesn’t have the 6 PIN setup the GPU needs only 4, but when plugged in the GPU lights up and the fan goes on, just no video, my guess is because it doesn't have full power with only 4 pins,  so I don’t suspect the GPU. I plugged in a Sata drive and it spins so there’s power there. I once again tested the PSU getting around 12.8 volts.  So either the PSU is inadequate with this processor, there is something wrong with the PSU even though there are no telltale signs or both motherboards are shot and something is bad that I don’t know about, although I checked both boards and the capacitors are not swollen or leaking.  If I have to go to my local repair shop it will have to be troubleshooted and it’s going to cost me $60 base plus $60 an hour, who knows how long it will take to figure out what’s wrong. I don’t want to throw anymore time away but I can’t afford the cost of repairs. I’m in a real dilemma here if I could just narrow it down more it would really help and than maybe it won’t cost as much to repair, any clues? I will try to post a link to some video I took. Thanks

4 Replies

On the ASRock B350M-HDV if you purchased the Motherboard and it was manufactured after August 2019 then it should have BIOS version 5.90 or newer on it which supports the Ryzen 3700X.

You didn't mentioned, I believe, the Make & Model of your new Asus Motherboard so I couldn't find out which BIOS version you needed to be install for the Motherboard to recognize the Ryzen 3700X.

Next I would check to see if the RAM Memory is on the Motherboard's QVL List for both ASRock and Asus. Most QVL list are out-dated so you may have to go to the RAM Manufacturer's website to double check and see if it is compatible with your motherboard.

Also when you say there is no power to the GPU besides the Fan not turning, most GPUs have a LED light that lights up when power is applied. 

The PSU you have should be adequate and strong enough to at least boot up into Windows. Even a slightly under powered PSU will boot up into Windows. So that shouldn't be a problem unless the PSU outputs are abnormal - 3.3/5.0/12 VDC or it is defective.

Best way to test hardware besides RMAing  is to install it in another compatible Computer and see if the same problem occurs. If your Ryzen 3700X boots up in a compatible motherboard with compatible RAM then that would, at least, eliminate the Processor.

You didn't mention if you used one RAM Stick or 2 or more RAM sticks. If you used 2 or more RAM sticks I would suggest to use 1 RAM stick in all Memory slots and see if the computer boots up in any of them.

Some RAM sticks just are not compatible when 2 or more are installed at the same time if there are compatibility issues.

Also I did mention make and model in the first sentence, guess you missed it, going back to the Fan spinning faster and slower I'm running Core Temp and it shows temps going from 49 to 66 C at almost idle, this doesn't seem right?


I a lost the ability to edit my replies, not sure why, so I'm sending separate replies, I just checked BIOS and the CPU temp is 57 C that  really seems a bit high for an idle temp, could it need more thermal paste? Ok I just figured out what I was doing wrong that I couldn't edit, so now I am, so apparently after finally uninstalling and reinstalling Ryzen Master I'm getting a better idea of what the CPU temp is it' running around 39-42 C so that's safe, not much of a big difference from what Core Temp is now reporting 45-53 C I think that might be inaccurate for some reason. So only issue if it is an issue is the Cooler Masters fan keeps fluctuating is that because of PWM? I tried to change that setting in I think it was the BIOS but the option wasn't working I'm have to check again now that I've updated the BIOS.

Adept II

So I decided to just take it to the repair shop, they diagnosed it for me and installed the new motherboard, so I found out that my old motherboard was shorted by risers that were poorly placed, not by me since this was custom order PC, how I went a whole 2 years without the board being shorted is a miracle, second the only thing wrong with the new board was that the BIOS had to be reset and I didn't do that correctly so lesson learned thankfully they only charged me the base fee. Thanks for trying to help me figure it out. Right now the only issue I'm facing is my new Coolermaster AIO keeps changing fan speeds and doesn't light up. Any thoughts on that? Update just checked with HwiNFO and same as coretemp, is Ryzen Master the only one showing the true temps or am I missing something here?