Showing results for 
Search instead for 
Did you mean: 

General Discussions

Some Ryzen Motherboards With Older Firmware Won’t Boot With Ryzen APUs

If you’ve ever tried to upgrade your motherboard to a newer CPU, you’re probably aware that the process can be dicey. In some cases, a newer CPU may not be properly detected, but the system will boot and can then be flashed with an updated BIOS / UEFI. Of course, you can avoid the problem entirely by flashing the UEFI before you switch to a new CPU, which is definitely something I’ve remembered to do before. Sometimes. At least twice. If the board fails to boot, you’ve always got the option to fall back to your older CPU and complete the UEFI update that way.

This process is somewhat more complicated if you buy a Ryzen APU and a motherboard with an older UEFI variant. Tech Report tried exactly this, dropping a new Ryzen APU into a Gigabyte AB350-Gaming 3 motherboard that hadn’t been updated since they first received the board. The board failed to POST.

One potential way around this problem is if your Ryzen motherboard (See on Amazon) has UEFI Flashback protection. Different companies refer to this by different names, but if your motherboard can update its BIOS without a CPU or GPU attached, you can load the new UEFI image from a flash drive (instructions on how to perform this step will be located in the motherboard manual, typically available online if you’ve lost the dead tree version). This should neatly solve the problem, provided you have a way to download the UEFI image in the first place.

If your new motherboard doesn’t support BIOS / UEFI flash back, fixing this problem is going to be trickier. Some motherboard manufacturers might be willing to provide a UEFI flash as part of an RMA (it’s a long shot, but you might as well ask). Buying and then returning a Ryzen CPU that you know the board supports is another option — not a great one, to be sure, but if you can find an online store that’ll process the RMA, it may work. A local computer shop might also be willing to help if you explain the situation.


AMD has created a sticker program to help buyers differentiate between motherboards updated for Ryzen APUs and those that aren’t. The “AMD Ryzen Desktop 2000 Ready” moniker means that you can safely drop the APU in and expect it to work.

We should also note that this problem is not unique to AMD. In the past, there have absolutely been Intel motherboards hit by similar issues. If Intel has avoided the issue more often than its smaller rival, it’s only because Intel has a habit of forcing its customers to buy new motherboards much more quickly than AMD does. The flip side to that, however, is that it may be a bit trickier to ensure the motherboard you buy has an updated firmware matching your CPU.

Some Ryzen Motherboards With Older Firmware Won't Boot With Ryzen APUs - ExtremeTech

3 Replies

Here's where you can "exploit" Amazon's return policy: Buy a cheap Ryzen CPU, flash your BIOS, then return it claiming it didn't work. However this is a feature I think AMD should have mandated, the UEFI BIOS Flashback, given Socket AM4 is going through multiple generations of chips.


Many times too I would add don't just assume you can't buy that board retail either if it doesn't have a sticker. Many dedicated computer stores may update that bios for you, if you ask.


Usually, if you are upgrading to a new CPU/APU only it isn't a problem, as you can flash to the new BIOS with the older CPU installed first.  The issue lies in buying that new AM4 ITX board with a new Ryzen APU, only to discovered the ITX board has a version of the UEFI that isn't updated to support Ryzen APUs.

This issue has been around for a long time.  Even in the socket AM3 days, you could buy a board that hadn't been update for Vishera at the store when the FX-8350 launched and there were some compatibility problems there as well.