cancel
Showing results for 
Search instead for 
Did you mean: 

General Discussions

stevieg013
Adept I

R9 390 - Ran 60hz @ 4k with displayport (generic pnp w/ TV) fine until....? Please help!

Hello all,

I've been using my Samsung TV as a monitor for quite some time.  My gfx card is an R9 390 which can output 4k@60hz using the displayport.  Recently I restarted my computer (there may have been an update) and upon reboot I noticed the framerate looked choppy and felt laggy.  Back to 30hz.  There's no longer an option to select 60hz from my card.  It's completely gone.  I've tried removing the generic pnp driver and reinstalling, I've tried using different resolutions and "tricking" the PC into remembering, I've uninstalled/reinstalled the drivers for the gfx card, etc.  I spent, no joke, around eight hours yesterday reinstalling, uninstalling, etc.  I'm completely stumped.  I even tried downloading the newest AMD software and setting a custom resolution.  Once it "let" me make the settings change, but it did nothing to the display.  I just tried again and now I get a compatibility message saying the monitor isn't capable.  Again, I want to stress (since I've read a lot of posts across the internet/time regarding this card/4k) that I have the necessary equipment and that up until yesterday it was running 4k @ 60hz with no issue.  Can anyone please snip01.PNGSnip02.PNGoffer any help or advice?  Thank you so much!

2 Replies
stevieg013
Adept I

Re: R9 390 - Ran 60hz @ 4k with displayport (generic pnp w/ TV) fine until....? Please help!

Also - if there's something else anyone needs to help me with this please let me know. I'm happy to screenshot anything or provide any additional information that could help me help you. Thank you!!

stevieg013
Adept I

Re: R9 390 - Ran 60hz @ 4k with displayport (generic pnp w/ TV) fine until....? Please help!

Halp plz I will PayPal $5 to someone who can get this working right before I go insane. THANK YOU! For real tho $5.