Showing results for 
Search instead for 
Did you mean: 

General Discussions


no POST with M.2 SSD installed in PCIe 4.0 slot


New PC build will not POST when NVMe SSD (GP-ASM2NE6200TTTD) is installed in PCIe 4.0 M.2 slot.

Installing CPU + RAM + SSD only will result in no POST and it wont even check for the missing GPU.

Removing the SSD with CPU + RAM installed will yield the expected VGA missing beeping sounds and VGA debug LED on.

Placing the same SSD into the slower PCIe 3.0 slot will also yield the expected VGA missing beeping sounds.


- CPU: AMD Ryzen 7 3800XT (8c,16t)

- RAM: G.Skill Ripjaws V 3600 MHz CL16

- MB: MSI B550-A Pro (PCIe 4.0 support)

- PSU: 650W, 25A+ 3,3V, 25A+ 5V

- BIOS: current version: AGESA ComboAm4v2PI Patch C (MSI BIOS 7C56vA4)


more details:

- The MSI mainboard has EZ debug LED (CPU, RAM, VGA, BOOT) and 2 M.2 slots.

- 1st M.2 slot is PCIe 4.0x4 (connected to the CPU PCIe lanes)

- 2nd M.2 slot is PCIe 3.0x4 (connected to the chipset PCIe lanes)


When the SSD Gigabyte Aorus 2TB (GP-ASM2NE6200TTTD) is connected to the 1st M.2 slot,

the system will not POST/BOOT and the CPU debug LED will stay on.

I can NOT enter BIOS with SSD in 1st M.2 slot. (PCIe 4.0 CPU lanes)

The SSD is working fine in the other slot. (PCIe 3.0 chipset lanes)

I can only enter BIOS when connected to 2nd slot (PCIe 3.0)

and the SSD will show up in BIOS and can be selected (only on PCIe 3.0 slot).


I have also tested another SSD (Kingston KC2500) in the first slot and it is working fine.

So the slot is working too. At least with a PCIe 3.0 SSD...

I have tried different BIOS versions including the latest AGESA ComboAm4v2PI Patch C (MSI BIOS 7C56vA4).



- M.2 slot is working (tested with another SSD)

- SSD (GP-ASM2NE6200TTTD) is working in PCIe 3.0 slot

- BIOS version is up to date (for Ryzen 3000 series)


What can I do to make it run in PCIe 4.0 M.2 slot?

Any suggestions or help to solve this would be nice. Thank you!

--- [ CPU: Ryzen 7 3800XT | GPU: ASRock RX 5700XT Challenger Pro 8GB | driver: 23.3.1 ]
--- [ MB: MSI B550-A Pro AGESA | RAM: 2x 16GB 3600-CL16 | chipset: ]
17 Replies

Go back a version on that BIOS to a non "C" patch for starters. That "C" patch is beta and causes issues with the 3000 series and 5000 series. I'm using Agesa, different board but going to your Agesa version, I had many issues, one was my SSD failed to be recognized, others were sudden reboots, WHEA errors, etc.

"It worked before you broke it!"

@mackbolan777 thanks for the reply.


Interesting to hear that you have these issues with the current BIOS version.

I initially started on 7C56vA0 and worked my way up to 7C56vA4, step by step.

I even contacted the MSI support and asked them which BIOS to use, and they said 7C56vA4.


I do not have errors on this BIOS version tho. Windows event log is looking good on my end.

... and the SSD did not work on any tested BIOS version (when connected to the 1st slot).


--- [ CPU: Ryzen 7 3800XT | GPU: ASRock RX 5700XT Challenger Pro 8GB | driver: 23.3.1 ]
--- [ MB: MSI B550-A Pro AGESA | RAM: 2x 16GB 3600-CL16 | chipset: ]

Well you may have issues down the road with that BIOS revision, it's a complaint all over the web, verified by Igor's Lab as a "Beta" version. Doesn't mean you will, as I said it's a known factor. The best BIOS for the 3000 series is one with Agesa V2 PI for a B550, X470, B350,B450,A320 chipset. MSI doesn't parse out those numbers on the site just by date I would say they should've guided you to: 7C56vA1, since that was the July release it probably had the proper coding.

However, it may be a board issue or limitation they either missed or don't know exists. That top M.2 is by the GPU and possibly there's a problem with the GPU sharing the same PCIe 4.0 "lane", or less likely interference from the frequency the GPU tosses off (RF interference). The fact that it works in the lower slot is interesting in that you claim it operates there at 3.0 vs. 4.0 spec. Lends more credence to a defective motherboard, ie: not internally wired right. Lastly, in your manual it states that one should use a support bracket for heavy GPU's, yours is 2.2lbs and the GPU is a PCIe 4.0 device. There may be too much stress on the slot causing  the grief, unlikely but trying to cover every angle. 

A side note is the PSU is a bit on the light end with a 25A rail, 45A is a better choice. Not that that is the problem here. There's more to PSU's then advertised wattage. 12v/45A rail is pretty standard especially with a beefy GPU.

If you put the GPU in the bottom slot what happens? If it then works as PCIe 4.0 and boots, there's a board issue for sure. I would be willing to bet it's a board issue period. So if you're in the return window of the vendor, do so, otherwise RMA the board to MSI. The manual even states if using the lower M.2 slot the lower video card slot is disabled. It's reasonable to assume that there's a defect in how the upper M.2 is designed into the board looking at p. 21 of the manual. Check that the RAM is in the A2/B2 slots as well. In the end the PCH chip is most likely at fault, looking at that block diagram, if everything else checks out. 

"It worked before you broke it!"

7C56vA1 seems to be AMD AGESA ComboAm4v2PI

- Optimized the support of AMD Ryzen 7 PRO 4750G, Ryzen 5 PRO 4650G, and Ryzen 3 PRO 4350G processors.


7C56vA2 (no idea which version this is - could it be

- Improved PS/2 KB/Mouse compatibility.

- Improved memory compatibility.


7C56vA3 seems to be AMD AGESA ComboAM4v2PI

- better latency (?)

- higher bandwidth (?)


I don't see on the available BIOS downloads for my board. (it could be 7C56vA2)

Can you recommend any of these BIOS versions?



The boards manual (and specifications) clearly state that only the top M.2 slot is PCIe 4.0 ready.

This is the only M.2 slot which is connected to the CPU directly. (page 21, block diagram)

The other M.2 slot is on the chipsets PCIe lanes.

And as I said: another M.2 SSD drive with PCIe 3.0 standard is working fine in the top slot.

It is just the PCI4.0 drive that wont let me boot, when it is in that top slot.

Even with not graphics card, the system will not POST/BOOT with the PCIe4.0 SSD in top slot.


PSU 12V is rated at 53A. The other lanes are 25A, which should be plenty enough for my use scenario.


As I said:

I have already contacted MSI support directly and they gave me the advise to upgrade to BIOS 7C56vA4.

I also contacted the SSD manufacturer (no reply yet).


I am gonna write a message to my vendor and let them know what is going on.

Maybe their tech team can try the same scenario on hardware they have there from recent RMA's.

If they think I should replace the board, then I will indeed try just that as the next step.


I still want to see if anything comes up in the meantime, that could fix the issue without a replacement.


--- [ CPU: Ryzen 7 3800XT | GPU: ASRock RX 5700XT Challenger Pro 8GB | driver: 23.3.1 ]
--- [ MB: MSI B550-A Pro AGESA | RAM: 2x 16GB 3600-CL16 | chipset: ]

That PSU spec is more like it. It's good you read the manual well, most do not and that's why I referenced it. Not to make you feel ignorant. BIOS Agesa is the next best option. I didn't see any labeled as such which is why I went by date. So trying the Gigabyte M.2 in the top slot, no GPU, you assume no post/boot by the lights on the board? It's a reasonable assumption, just trying to be clear. I assume you are using 2 X16GB RAM and they are in the A2/B2 slots?

If so, we've exhausted all the common issues that would cause this other than a defective board or limitation they missed. Personally, MSI hasn't been doing the best lately with anything less than the X570 boards. I lost faith in MSI back in the AM3+ days after having to RMA 2 boards for a customer.

No matter what board you wind up with, keep that BIOS issue in the back of your head, it spans multiple brands/chipsets when using a 3000 series CPU. I also never had luck with a Beta BIOS. I don't understand why manufacturers release them. Are we "guinea pigs" for something that can really cause problems? They should really spend a bit more time in R&D testing/writing a BIOS before releasing it to the public.

"It worked before you broke it!"

I actually read the manual online before I even purchased the board. ^^


The RAM is indeed in the correct channel and slots: A2 and B2

2x 16GB - 3600 MHz CL16 with XMP Profile enabled and FCLK and UCLK 1:1 (1800MHz)

I also tried default 2133 MHz XMP off and 1 RAM module instead of 2


My step by step testing was this:

1) only CPU installed (no RAM, no VGA, no SSD)

-> result: board speaker beeping and RAM debug LED on (so far so good)

2) CPU + 1 RAM module (installed in A2) (no VGA, no SSD)

-> result: board speaker beeping and VGA debug LED on (still good)

3) CPU + 1 RAM module + SSD in top slot 

-> result: board speaker silent (no beep), CPU debug LED on (should have been VGA still...)

-> installing the GPU will result in the same scenario 

-> keyboard mouse don't work

-> no display signal either


Thanks for your input. I gonna have to sit this one out and see if vendor wants to replace it,

or if they can maybe test it with another board in their own tech/repair shop before replacement.


--- [ CPU: Ryzen 7 3800XT | GPU: ASRock RX 5700XT Challenger Pro 8GB | driver: 23.3.1 ]
--- [ MB: MSI B550-A Pro AGESA | RAM: 2x 16GB 3600-CL16 | chipset: ]

Sounds like a solid plan. You went through everything. I wish you success at the end.

"It worked before you broke it!"

quick update: no solution yet.


MSI support did some testing on their own (I guess they tried hardware from their own tech team?)
They were not able to find any problems on their own tests.
They also could not tell me if my issues come from CPU/MB or SSD itself.

I have also contacted my vendor and their tech team suggested to try CMOS reset again,
with SSD installed and only 1 RAM in slot A1 (instead of recommended A2).
I sadly don't have time to test this step right now. The time I had to build the PC and set it up was already
used up by all the problems that I had to deal with. So this has to wait for now.

Everyone ist still pointing me to different BIOS versions. MSI support still insists on the latest BETA BIOS.
I can live with my SSD being held down by PCIe 3.0, if it means I can stop looking for the compatibility issues.

-maybe- I have the time/energy to try that step on the weekend...
-> will update this topic, if I do. 


--- [ CPU: Ryzen 7 3800XT | GPU: ASRock RX 5700XT Challenger Pro 8GB | driver: 23.3.1 ]
--- [ MB: MSI B550-A Pro AGESA | RAM: 2x 16GB 3600-CL16 | chipset: ]

I was thinking, looking at your RAM. 32GB @3600mhz is probably the issue. Try running that at 3200, might need to tweak the CL down with Dram Calc to maintain performance or not. Especially if you run 4 sticks, most Ryzen's have an issue running over 3200. If you do get it to work, when you install Windows make sure to head over to AMD's driver area and pick up the latest chipset driver: 10/20. It's one Windows Update nor adrenaline will ever update, so you need to look for yourself every so often.

I found it yesterday because Windows new update went sideways causing me to need to reinstall. For some reason I looked for a chipset driver update and there was one.

"It worked before you broke it!"

@mackbolan777 I already tried default 2133 MHz RAM frequency in my tests.

I even tried another RAM module from another PC, cleared CMOS and same result.


I tried all the things I could think of. Even tried the steps that support told me...
I already have a fresh windows install and I have looked for the drivers manually.


--- [ CPU: Ryzen 7 3800XT | GPU: ASRock RX 5700XT Challenger Pro 8GB | driver: 23.3.1 ]
--- [ MB: MSI B550-A Pro AGESA | RAM: 2x 16GB 3600-CL16 | chipset: ]

Return the board and buy a different brand like Asus or Gigabyte. If it's past that window, RMA the board. I've been reading about more MSI issues then I have since the AM3+ days. Most RMA the board or return for a different brand and that's it. Being it's not reading that M.2 at 4.0 no matter what BIOS, it's gotta be board related given the fact I think you tried the M.2 in a different PC and it read 4.0? Losing track of MSI problems posted on here, lol. All the issues relate to MSI's mid-range boards, just like in the AM3+ days. RMA'd 2 boards from the same customer that had goofy issues. He insisted on those boards because at the time they were the only offerings with serial ports. 

"It worked before you broke it!"

Having exact the same issue with Gigabyte B550i AX Pro & a PM9A3. My 2nd board now, same behaviour each time. Gigabyte telling me to use the lastest beta BIOS, which didn't help at all and then recommend to RMA it but tbh if two boards with with four different BIOS (1, 13, 13a, 13c; 13c is with AGESA didn't work I somehow doubt a 3rd will do the trick.

SSD is working fine in PCIe3.0/ chipset slot, no POST with the CPU/ PCIe4.0 slot. I ain't got a PCIe4.0 GPU (2060) and the PSU shouldn't be a problem here (Corsair RM650x).

I guess the B550 chipset making use of the CPU's PCIe4.0 lanes is just causing problems, no matter the manufacture...

I also have the same problem with ASRock B550 Phantom Gaming 4 and I'm expecting my vendor do something about it. 


New BIOS out for Gigabyte, AsRock, Asus. Might help but the real fix is coming 1st week of April in an Agesa update that addresses the USB port issue, this M.2 problem and others. Sop hang in there. AsRock I can tell you for a fact, is putting BIOS updates out with the wrong SMU. They're using older SMU's for some reason like 56.43 when you should be at 56.46 . I changed to an Asus board and they had the newer 56.46 SMU, ending a RAM issue I had for several months. 

A workaround for M.2's that go missing or fail to be seen, is to try raising the SOC up to but not over 1.2. The other voltages can be raised as well to the 1.05-1.07 range to fix the issue. See my Zen Timing pic as an example.SOC, VDDP,CCD, IOD changesSOC, VDDP,CCD, IOD changes

"It worked before you broke it!"
Journeyman III

Hi guys, any update about that? Same issue here.


@pippoétriste what are your system specs?
- mainboard?
- BIOS version?
- which CPU do you have?
- which M.2 NVMe SSD?

--- [ CPU: Ryzen 7 3800XT | GPU: ASRock RX 5700XT Challenger Pro 8GB | driver: 23.3.1 ]
--- [ MB: MSI B550-A Pro AGESA | RAM: 2x 16GB 3600-CL16 | chipset: ]

Just out of curiosity, Which PCI Slot do you have your GPU in? PCI E1? This is from the manual. You might have over looked it. that could be why it isn't working. I don't think you mentioned which slot the GPU was calling home? hopefully the top one E1.. just a thought to throw out there. I couldn't easily search the storage compatabilty list on my phone will try on desktop later today. **bleep** that list was hard to find!!


⚠ Important
PCI_E1: PCIe 3.0/ 4.0 x16 (CPU)
PCI_E2: PCIe 3.0 x1 (PCH) PCI_E3: PCIe 3.0 x4 (PCH)
PCI_E4: PCIe 3.0 x1 (PCH)
∙ If you install a large and heavy graphics card, you need to use a tool such as MSI Gaming Series Graphics Card Bolster to support its weight to prevent deformation of the slot.
∙ For a single PCIe x16 expansion card installation with optimum performance, using the PCI_E1 slot is recommended.
∙ When adding or removing expansion cards, always turn off the power supply and unplug the power supply power cable from the power outlet. Read the expansion card’s documentation to check for any necessary additional hardware or software changes.
∙ When installing PCIe SSD in M.2_2, PCI_E3 slot will be unavailable.