cancel
Showing results for 
Search instead for 
Did you mean: 

General Discussions

lolington
Adept I

New pc build doesn`t work, need help

Jump to solution

Hello,

I`ve spent like 10 hours sitting trying to figure something out...

So basically I got my new parts for my new pc build today.

This is the build: https://pcpartpicker.com/user/earthwarmed/saved/kpq9Jx

When I turn on the pc everything seems to be working, but when I connect my monitor it doesn` connect.

Also I can`t install windows 10 because the usb seems to be not working too.

I`ve tried connecting my keyboard in case the flash was bad, but no signal too.

I`ve checked my cables a thousand times.

My vega 56 didn`t fit on the left side as you can see I`ve added zip ties

and it seems to do the work, the lights turn on, fans working etc.

There is only one thing that looked weird to me. The stock amd cpu cooler has lighting around it and when I turn on the pc

it starts to blink. It looks like it is turning on and off, I can also hear a quiet noise that sounds similar to turning on and off.

0 Likes
1 Solution

Accepted Solutions
lolington
Adept I

Re: New pc build doesn`t work, need help

Jump to solution

I`ve managed to fix it. I forgot to put the standoffs under the motherboard.

It works perfect now

View solution in original post

0 Likes
10 Replies
arcticwind
Forerunner

Re: New pc build doesn`t work, need help

Jump to solution

Do you have the 8 pin power connector (top left side of motherboard) plugged into the motherboard as well as the 24 pin power connector?

Also, your system is under powered. The GPU you have requires a minimum of a 750w power supply.

elstaci
MVP

Re: New pc build doesn`t work, need help

Jump to solution

I am in concordance with arcticwind​ .

In the photo you uploaded I don't see any PSU cable going to the area where the Power 8 Pin 12 Vdc of the motherboard connector goes. Upper top left corner of the motherboard.

I see the 24 pin Motherboard power connector on the right middle of the motherboard.

As mentioned, you installed a under powered PSU. Since you have both a Ryzen CPU/APU and a high wattage GPU card, I would suggest you get at least 850 or higher PSU for your computer.

Plus you have a very new BIOS update from 12/04/2018 that can be beneficial to make the motherboard more compatible with the Ryzen CPU/APU.

lolington
Adept I

Re: New pc build doesn`t work, need help

Jump to solution

The Power 8 Pin is plugged in, it is not visible in the picture.

My build takes up only 300w, my PSU is more than enough to power it. (you can check: https://pcpartpicker.com/list/4zzsgw )

I still didn`t find a solution.

0 Likes
kingfish
MVP

Re: New pc build doesn`t work, need help

Jump to solution

I too would be looking at the power supply:

PSU REQUIREMENTS - RealHardTechX

lolington
Adept I

Re: New pc build doesn`t work, need help

Jump to solution

Okay, I guess it's the PSU, do you guys have any PSU recommendations for my build?

0 Likes
leyvin
Miniboss

Re: New pc build doesn`t work, need help

Jump to solution

That PSU is absolutely fine., the (Recommended) PSU on AMD Graphics Cards essentially assumes a "Worst Case" Scenario.

The above system will draw:

Ryzen 5 1700 (4.0GHz OC)            145w (35w)

16GB (2x8GB /  DDR4 3000MHz)  15w   (15w)

RX Vega 56 (1.6GHz OC)               275w (18w)

512GB SATA-SSD                           2.8w (2.5w)

2TB Barracuda SATA-HDD              5.6w (4.5w)

B450 Chipset                                   4.5w (4.5w)

----------------------------------------------------

Total:                                              < 450w (80w)

A 550w 80+ PSU will Deliver a "Minimum" of 440w (Guaranteed) up to it's Rated Power Delivery.

I've listed in bracket the actual Draw during Boot / Idle / Desktop.

IF while playing Games, or engaging in Intensive Tasks your System simply Resets / Triggers a Surge Shutdown (i.e. Randomly Switches off) then the issue is that your PSU is unable to Deliver Enough Power.

I can't think of a single Scenario (today) where you wouldn't have enough Power to Boot / Install / Idle on the Windows or Linux Desktop., but if this was the case then the System would "Light Up" but nothing would be Active, with the BIOS giving 1 Short, 2 Long, 1 Short Beep (via the PC Speaker) to indicate that One or More of the Core Components is not "Present" during Boot,. which will typically be the GPU / PCI-E / USB Devices; of which only the lack of GPU will result in "Failure to Post"

No, instead if it appears like the Power is Intermittent (i.e. Cycle On / Off) means that there is a Short., either on the Motherboard or within the PSU; which in my experience is typically the PSU is just Dead-on-Arrival.

Of course as it's a "Semi-Modular" PSU, it's also possible that you've just not seated the Modular Connectors in the PSU properly and firmly as to create a Solid Connection... I'd recommend Reseating all of the Connections, as well as testing the Motherboard outside of the Case (I personally tend to do a Dry Run of all new Hardware via building it on-top of the Motherboard Box).

0 Likes
lolington
Adept I

Re: New pc build doesn`t work, need help

Jump to solution

I`ve managed to fix it. I forgot to put the standoffs under the motherboard.

It works perfect now

View solution in original post

0 Likes
elstaci
MVP

Re: New pc build doesn`t work, need help

Jump to solution

Can you clarify by what you meant as "Standoffs"?  This a terminology I haven't heard yet concerning a motherboard. Just would like to know for my own future reference if something similar comes up in the future with another User.

0 Likes
arcticwind
Forerunner

Re: New pc build doesn`t work, need help

Jump to solution

"Standoffs" are the metal spacers/screws (hexagonal, brass) that are used to keep the motherboard (back side) from touching the inside back panel of the case.

0 Likes