cancel
Showing results for 
Search instead for 
Did you mean: 

General Discussions

Highlighted
Journeyman III
Journeyman III

my msi gtx 750ti shows no signal

i had this problem that whenever i run game, it freezed in 2 seconds and rebooted automatically

i showed my motherboard they repaired it, then other low level gfx cards are working but not my mis gtx 750ti, it shows no signal with VGA AND HDMI, The computer boots and the fan is spinning, when i run without gfx card, it works fine, there is display but not with gfx car, please help me here

my specs-

msi 750ti

16gb ram

coolermaster liquid cooling

psu- buldozer 500w

gigabyte 78lmtusb3 motherboard

fx 6300 processor

please help me here out

thanks

0 Kudos
2 Replies
Highlighted
Esteemed Contributor III

Re: my msi gtx 750ti shows no signal

First this is a AMD Forum. You need to ask this question at Nvidia Forum here : https://forums.geforce.com/default/board/33/geforce-drivers/ concerning GPU problems with a GTX 750ti.

It seems like your Motherboard has Integrated AMD HD 3000 graphics. Do you have in BIOS settings to have your Discrete GPU (GTX 750ti) card to boot up first rather than the Integrated Graphics? Make sure your monitor cables are connected to the GTX GPU card and not the Motherboard's Integrated Graphics port and in BIOS your settings are for the GTX GPU card to boot first.

0 Kudos
Highlighted
Big Boss
Big Boss

Re: my msi gtx 750ti shows no signal

Check for a BIOS update as some boxes  do not properly recognize the discrete card as primary

0 Kudos