cancel
Showing results for 
Search instead for 
Did you mean: 

General Discussions

paddyb
Adept I

Do B450 Motherboads support PCI-E 4.0?

Can someone clarify the situation with B450 boards and PCIe 4.0? About to build my first system and have have decided on a Ryzen 5 3600 paired with a B450 board. A 570 board is just pushing my budget too far, but being able to utilise PCIE 4 at some point in the future might be useful. As I understand it, it theoretically should work with some boards and was included in older BIOS, but has been removed from updates at the request of AMD. If this became a feature that I could make use of in the future, would I be able to flash an older BIOS to make use of it? I’m not a gamer, so won’t be needing a top spec GPU, but  do a lot of video work and seriously multitask and want to build a machine that will have a reasonable upgrade path to that will last me a few years.

51 Replies

pastedImage_1.png

pastedImage_2.png

pastedImage_3.png

pastedImage_4.png

pastedImage_5.png

Read speeds appear pretty rock solid across all tests.

Slight drop on SEQ1MQ8T1 write speed on the second run otherwise looks good.

Hopefully pokester‌ & hardcoregames™‌ will be able to able to post their benchmarks so we have more data on consistancy.

0 Likes

I don't have such a drive so I doubt any results I could share would be relevant. 

0 Likes

pokester wrote:

I don't have such a drive so I doubt any results I could share would be relevant. 

not many have that many to test and make tables

0 Likes
paddyb
Adept I

Unless either ADATA or ASRock can confirm a firmware fix (ASRock have tested the previous model, not this one), then I should look at a replacement. Just to muddy the waters thought, I’ve just done four tests in a row, with various others apps running, and had sequential speeds of over 3,0000MB/s R, 2,400MB/s W. Maybe there was something else that was slowing it up before? Will keep monitoring it.

Which Sabrent drive do you have fyel?

This one is the same price as the ADATA:

https://www.amazon.co.uk/Sabrent-M-2-NVME-SSD-500GB/dp/B0863DHZDJ/

 

And with a quick look seems to have great reviews, but it’s not on ASRock's compatibility list:

https://www.asrock.com/mb/AMD/B450M%20Pro4/#Storage

0 Likes
fyrel
Miniboss

0 Likes

AFAIK Sabrent are all PCIe, I have SATA SSD but they are in my old Lenovo machines.

I have some mSATA units but they are not M.2 format. M.2 surfaced with AMD with Ryzen's introduction.

0 Likes
paddyb
Adept I

Sounds like someone else is having similar problems:

https://community.amd.com/thread/255637 

Some mention that this could also be Mobo related?

0 Likes

paddyb wrote:

Sounds like someone else is having similar problems:

Very slow NVMe write speeds 

 

Some mention that this could also be Mobo related?

AMD motherboard BIOS problems are well known

0 Likes
paddyb
Adept I

I really hope it's the drive and not the mothnerboard.

Been away from thias for a few days.I think I should get another drive, benchmark it empty first, then if I get the desired speeds, transfer the OS from the ADATA and send it back for a refund (I got it on Amazon, so there are free returns until the end of the month). 

There is a second M.2 socket on the board, which is SATA III. Would the ADATA drive work in that socket (but obviously a lot more slowly)? That would make the process of testing the new drive and transfering the OS so much easier.

0 Likes

Not sure if the drive will work in the second slot or not but I think it's worth trying the slot switch so we all find out

0 Likes
paddyb
Adept I

I've asked ADATA to clarify this. There are virtually no instructions or documentation with this drive. 

0 Likes
paddyb
Adept I

Back on this again, and the plot thickens!

 

I got a replacement drive from Amazon and they will let me keep the old one until I have transferred windows over to it. This is what I’ve done:

 

Put the existing card onto an NVMe PCIe Card and put it in the spare PCIe Gen 2 socket

Put the new drive in the PCIe Gen 3 M.2 slot

Formatted my drive to NFTS

Tested it when formatted but empty, running windows on the old drive

I got this:

Screenshot 2020-08-31 00.45.54.png

 Screenshot 2020-08-31 01.25.16(2).png

I did this test several times and got almost identical results. Much more like what I expected from this drive, through the write speeds are a little low.

 

I installed Windows and apps on the new drive from an image file created from the old drive, booted Windows from that drive (still in the PCIe Gen 3 M.2 slot), ran the tests again... and I got similar results to the old drive, usually around 2600 R and 2500 W on the first test. 

 

I tested over and over and similar results every time. It appears to be performing about the same as the old drive.

 

Any ideas as to what’s going on here? Is it a software or hardware issue?

0 Likes