Showing results for 
Search instead for 
Did you mean: 

General Discussions

Journeyman III

Crossfire AMD R9 280X cannot apply overclocking/underclocking + low frame rate in games

I'm running a Crossfire configuration but since I'm using Vulkan to run Doom, Crossfire is naturally disabled. However this is where it gets tricky. Normally, I leave the AMD crossfire toggled to ON in the global settings. When I run the game, I get 25 FPS and less. This checks out with Adrenaline's performance monitoring since the primary card is downclocked to 500 MHz core and 100 MHz memory. When I try to change the clock speeds using MSI Afterburner, I still get the same numbers for both clocks. The temporary solution I did was to toggle the AMD Crossfire setting to OFF via Adrenalin's Global Settings. This gives me 90+ FPS and (see attachment 3) resets the clock back to its default values which are 1150 MHz core and 1600 MHz memory respectively. However, when I try to vary the clock values at this point, they instantly return to 500 MHz core and 100 MHz memory. (see attachment 2)

Problem: Cannot perform overclocking/underclocking

Driver details: Adrenalin 17.12.1

Hardware details: Sapphire R9 280X Toxic Crossfire w/ Sapphire R9 280X Vapor-X


-Default normal clocks: 1150 MHz core clock, 1600 MHz memory clock

-Supposed overclocked numbers: 1200 MHz core clock, 1600 MHz memory clock

-Default problematic: 500 MHz core clock, 100 MHz memory clock

-ULPS is disabled

-Unofficial Overclocking mode is set to "without PowerPlay support"

-Using MSI Afterburner for overclocking

I've also checked GPU-z values and it displays the core and memory clocks correctly. (see attachment 1)

I haven't tried removing the secondary card just yet but knowing how frustrating and tricky Crossfire configurations are, giving it up would be a last case scenario.

Edit: Nevermind. Uninstalled MSI Afterburner and replaced with Sapphire TRIXX. Everything works seamlessly.

Message was edited by: Paolo Anino
February 9, 2018

0 Replies