Showing results for 
Search instead for 
Did you mean: 

General Discussions

Adept I

Cannot unlock steam game


I'm trying to unlock the Callisto Protocol on Steam with AMDRewards.

I've tried Firefox (my default browser with many privacy enhancing extensions), Chrome without Plugins (allowing all third party cookies), and Edge without changing anything.

It always tells me to try again later.

Any way to resolve this?

Kind regards

9 Replies
Adept I

Still getting this error. It's german for "Activation not successful. Try again later"Still getting this error. It's german for "Activation not successful. Try again later"Bump.

Wanted to play on release day

Adept I

How to redeem a game.. in germanHow to redeem a game.. in german
This picture tells me how to activate and unlock the game on steam and i followed this guide.
Bullet point number 5 tells me to enjoy.
And here I am complaining that I can't redeem it.
The only reaction I get is a like from a mod.

Maybe someone else can tell me what I'm doing wrong trying to unlock the game?

I'm commenting because I have the same issue as OP.

Support finally got back to me and sent the code directly, but I tried on 3 PCs using different browsers, both logged into Steam and incognito.

You guys have a serious bug of some sort where the Steam login fails...

Adept I

Hey Chittick,

thanks for your reply. I have not received the code yet but I hope they provide an easier way to redeem games in the future.

Glad you finally got to play the game.

Kind regards

Adept II

We could not successfully complete the activation. Please try again. I HAVE THE SAME POBLEM

Amd should give the keys like in old times 


how i send them a support ticket?

Seconded! My last experience redeeming games from AMD came in the form of Dirt Rally when I bought my MSI R9 390 Gaming 8G back in 2015. That was a painless process.

I guess this fits with the today's logic: "let's make easy stuff hard"


In the same boat, my friend. Different browsers, different devices. I suspect perhaps the new Steam App/Authentication might be gumming up the works, but I have no concrete evidence to support this claim.
For now, it is a little frustrating to not be able to enjoy something you're supposedly entitled to; but I guess this falls under 1st-world problems.

I really just want to enjoy Callisto Protocol with my shiny new 6900 XT, but fates have decided otherwise. An overhaul of would be terrific. I have tickets in at both sites, yet I have gotten zero responses. Just more hoops, it would seem.

Hope you all get yours sorted. I'm just gonna hang out in Satisfactory until they tell me I can escalate to Space Horror...


Hey all, I believe I found a solution (at least for my issue) when activating AMD rewards through Steam.
I snapped a screenshot from the user who provided this fix /u/phex_us and the link
Basically, deauthorizing all devices from Steam Guard menu, logging back in during activation of reward fixed this problem for me. I hope it does the same for the rest of you. Finally installing Callisto Protocol and I'm stoked!