Showing results for 
Search instead for 
Did you mean: 

General Discussions

Journeyman III

cannot activate rewards account


I just got an AMD CPU and received an email for 3 months of Xbox Game Pass. I created an account and AMD sent a verification email. I click on the link and it quickly flashes that my account has been activated but then quickly returns to the login page. I log in again and I get a screen that tells me that my account must be activated. I click on resend email and try again but no luck. Can anybody help?

3 Replies
Adept II

The only 3 times I tried to redeem anything for a GPU I bought from AMD, 
I was denied the thing I was suppose to get with my GPU I bought... 

1st time, I was told that I had to buy an Entire PC from AMD to get my Reward... 
2nd time, I was told I had to download this AMD Tool which grants me the Reward... (AMD Tool Failed) 
3rd time, I was told I had to download the AMD Tool which grants me the Reward... (AMD Tool Failed) 

AMD Tool = Must Detect AMD Hardware, or it will not grant you any Reward Items, 
it only detects specific Hardware, too... If any of this Hardware is off, it will Fail, & 
AMD states you must complete this Task in a given time frame, in order to get your Rewards, 
if not done in the time frame asked, your Reward will Expire... 

When you ask AMD About it? They either 1. tell you they won't help, or 2. just ignore your message entirely... 

That has been my Experience, I said, this happens again, they can keep the items, I don't want them... 

But, as far as I know? Regarding the Log-In issue? It is possible the System is just down right now? 
I also noticed I had trouble with Account Setup as well, it took me forever just to get my Password 
changed, due to the E-Mail was never being sent at all... 

When I finally got it fixed, it turns out? A random Password just so happens to have worked, 
so I had not even needed it anymore at that point... 

Contact AMD About it, but also make sure your E-Mail has actual room for them to send you messages, 
& also make sure you can actually recieve messages in the E-Mail, too... Sometimes Cookies, or something 
else might be blocking the Messages from getting through... Other times, it's not on your End, but with 
this virus going around right now? It might not actually be this at all, it could just be High Volume in terms 
of Network overflow, dunno... 

Good Luck...

Copy and paste the Email Activation Link in a different Browser and see if it works.

Otherwise open a AMD REWARDS SUPPORT Ticket and see what they suggest from here: 

Journeyman III

I'm having the same problem. I tried in with 2 different e-mail addresses and 3 different browsers.

Did you manage to find a solution? rick.herrera